Jump to content


anyweb

using System Center 2012 Configuration Manager - Part 5. Adding WSUS, Adding the SUP role, deploying the Configuration Manager Client Agent

Recommended Posts

Well perhaps that is normal. I double clicked on a workstation that had "Not Yet Reported" and then navigated to page 91 of 91 and it showed that the "Report Data Collected:" was today. When I went to that computer and checked the logs everything looked like it ran successfully.

 

post-18089-0-72053700-1356731635_thumb.jpg

 

When I opened the WUAHandler.log file for that client is is shows that the GPO setting for the WSUS was conflicting with the Client specified agent. (See Attached Capture2)

 

post-18089-0-29591400-1356731930_thumb.jpg

 

I removed the GPO setting and rebooted the computer and no more error (See attached Capture1).

 

post-18089-0-86814200-1356731782_thumb.jpg

 

Now my questions is, how can I verify that "Update Source {48888AAF-45AA-....:8530}" is the local Distribution Point and not the actual SCCM server?

Share this post


Link to post
Share on other sites


Hi,

Thank you for great post.

I followed the steps -but on a stand alone primary site on 2012 server with SCCM SP1-

When I got to the point of "Post-Installation Tasks" of WSUS role, I cancelled it exactly as noted above and went ahead with CM configuration. Everything works fine now and I can use it flawlessly. There is one thing though that is bothering me! On my server manager, I keep getting this message from Windows that I need to run post configuration tasks for WSUS at least once!

And when I open Updates Services Console, it starts with a wizard asking me to run this! I always cancel/ignore it. Do you think I should run this as the OS says?

Thanks a lot.

H.

Share this post


Link to post
Share on other sites

Hi Anyweb,

 

First, thanks for the guides! Very Useful.

 

One question:

 

When i have tried to install te WSUS role on the P01 Server, i have the following error (In french):

 

Erreur inattendue lors de l'actualisation du Gestionnaire de serveur: Element introvable. (Exception de HRESULT : 0x80070490)

 

In can't see roles or features installed in the server...

 

Any Idea?

Share this post


Link to post
Share on other sites

are you a local administrator of that server ?

  • Like 1

Share this post


Link to post
Share on other sites

are you a local administrator of that server ?

 

Yes, i was. I succeed to resolve the problem. I use KB947821 and the problem disappears.

 

Now my new problem is an authentification windows when i click on the link to application catalog? (from Software Center)

 

Why do i have this authentification? I try to connect with different user (smsadmin, an other domain user...) but i can't access to catalog anyway

 

Any Idea?

Share this post


Link to post
Share on other sites

Hey,

 

Im able to see the configuration manager client installation in windows update, but I get error code 1 when I try to install. I've opened up the 2 firewalls rules to allow installation. and ran the hotfix 2749655. What am I missing?

Share this post


Link to post
Share on other sites

Hello,

 

First of, thanks a lot for this guide, it helped me greatly, I have followed your instructions and everything seems to work fine, I am able to deploy software and updates to clients that already have the agent installed. However, when I go to windows Update on computers that do not have the client installed, I don't get the one update found, I only get a message telling me the computer is up to date.

 

I started with SCCM 2012 RTM and Windows Server 2008 R2, I recently updated to SCCM 2012 SP1 (did an in place upgrade), I applied the KBs WSUS-KB2720211-x64.exe and WSUS-KB2734608-x64.exe and after that my SUP reconnected with WSUS (everything is in one server) and was able to sync. even after the sync, my computers dont get the client via windows update.

 

How can I check if there is something I'm missing and it's impeding me to install the agent via Windows Update?

 

Thanks,

Didier Caamano

Share this post


Link to post
Share on other sites

Thanks for this great tutorial, this is my first experience with SCCM :)

 

I can't deploy the agent to my devices. There is no site code assigned to any device.

 

Looking into the ccmsetup.log file:

<![LOG[Failed to get DP locations as the expected version from MP 'http://W2012-SCCM02.company.local'. Error 0x87d00215]LOG]!>

<time="15:27:57.738-60" date="02-05-2013" component="ccmsetup" context="" type="2" thread="3932" file="ccmsetup.cpp:10926">
<![LOG[MP 'http://W2012-SCCM02.company.local' didn't return DP locations for client package with the expected version. Retrying in 30 minutes.]LOG]!>

<time="15:27:57.738-60" date="02-05-2013" component="ccmsetup" context="" type="2" thread="3932" file="ccmsetup.cpp:10752">

The SCCM Console

post-19056-0-22695600-1360076043_thumb.png


I have set-up my boundary groups

post-19056-0-70993800-1360076043_thumb.png

 

What am i doing wrong?

Share this post


Link to post
Share on other sites

I have two boundries in this group: 1 IP adress range, 1 AD Site. (both should contain the same devices).

 

The IP range boundary

post-19056-0-85958800-1360098044_thumb.png

The AD site boundary

post-19056-0-70239900-1360098047_thumb.png

 

 

The W2012-SCCM02 server is the server for my primary site. I have a host W2012-SCCM01 that hosts my CAS site.

Share this post


Link to post
Share on other sites

Hi Ivan,

 

I had a similar problem which was due to me not updating the client package in the Distribution Points.

 

Find your client package usually ID'd xxx00001 and redistribute it to your DP's.

 

Cian

Share this post


Link to post
Share on other sites

Hi All,

 

Great tutorial, keep up the good work.

 

I have a CAS 2012 on Win2k8 with the full WSUS 3 SP2. Now I have set it up to not download from windows as it is not connected to the internet.

 

Now the problem is on all my primary sites, I do not have the option to set the WSUS site to an alternate server.

 

Any Ideas.

 

Cian

Share this post


Link to post
Share on other sites

this guide does not work with SCCM SP1 and Server 2012.

Several key steps are not included

 

such as during the update role installation do you select WID or Database.

this guide also doesn't address the KB articles that several other guides say are pre-reqs before adding the SUP role on SCCM.

 

The IIS configuration is severely lacking for the post installation of WSUS.

Share this post


Link to post
Share on other sites

When I run Windows update on the clients I'm getting the no updates required message. I have searched my entire C and D drive but cannot find wuahandler.log. Any ideas??

Share this post


Link to post
Share on other sites

Hi,

I have 2012 SP1 trail , and following your this guide.

When I start sync, it failed, no Update Server found.

 

When I try to Redo it, I noticed that ACTIVE SETTINGS page is not available and hence I can not use or select the option "USE THIS SERVER AS ASCTIVE SOFTWARE UPDATE POINT"

You can see the attached for details.

post-4293-0-93559700-1361199674_thumb.png

post-4293-0-11634600-1361199680_thumb.png

WCM.log

wsyncmgr.log

post-4293-0-38726100-1361275572_thumb.png

Share this post


Link to post
Share on other sites

are you using a hierarchy of CAS plus Primary ? or just a standalone

Share this post


Link to post
Share on other sites

Standalone , actually I am using your Step by Step guides .... but I have installed SQL 2012 (SQLServer2012SP1-FullSlipstream-ENU-x64) and SCCM 2012 SP1 trial.

Share this post


Link to post
Share on other sites

Help please ... some posts shows the known issue with SP1

I have changed the port number to 8530 but still same result.

post-4293-0-28593300-1361804576_thumb.png

Share this post


Link to post
Share on other sites

Hi!

I'm trying to follow your guide, but I have a problem with the WSUS 3.0 Sp2 installation on Windows Server 2012, the install wizard will not open!.

I've also tried to install it manually but i get compitability issue.

Any ideas?

Share this post


Link to post
Share on other sites

Hi,

 

I have followed the same installation step configuring SCCM2012 , Everything went will , but i am not able to get the software updates to SCCM Server.

Below are my server configuration

 

i have standlone server for SCCM - Primary Server

 

Windows 2008 R2 Enterprise

IIS

SQL Server 2008 R2 with CU6

Framework

Silverlite

WSUS 3.0 SP2

 

I am using SCCM and WSUS Server in same machine.

 

i have only issues with getting software updates for microsoft , i do have good internet connecting assinged to server without any proxy settings.

 

Error: Synchronization failure alert for software update point

Sync failed: WSUS update source not found on site NIS. Please refer to WCM.log for configuration error details.. Source: getSiteUpdateSource

 

Wakeup for a polling cycle

 

Remote configuration failed on WSUS Server.

 

 

I have reinstalled , WSUS 3.0 SP2 , Windows Server Update Services, Software Updated Point role..

 

Looking forward for hearing the update.

Hope the details helps to assist me in finding the solution

 

Regards,

Lokesh K

Share this post


Link to post
Share on other sites

Have another question...I have a standalone primary with SQL 08R2 on the same server. Can I install the WSUS internal DB instead of using SQL 08R2? Or will I run into issues having the embedded version and 08R2 running together on the same box?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...