Jump to content


papagolf

Problems distributing packages to single DP in SCCM 2012

Recommended Posts

I'm having problems getting packages transfered to one of my distribution points, this is a newly built site with a central site server in our datacenter and distribution points in our two large offices.

 

Boundaries and groups have been created and one of the DPs is running fine, the other fails to receive certain packages.

The package that is causing me issues at the moment is a forefront definition package.

 

Both DPs were built from the same template (VMware template with customisation) and followed exactly the same steps and permissions.

 

Site status shows a critical on the Software update point on the broken DP.

 

 

On the non working DP the pxkgxfermgr.log I see entries that show the package is ready to send but transfer never starts.

Such as:

 

 

Send Request 2000FGG1~ Job: J6EGPK18 Destination: dplname~ State: Working Status: Active Action: None~ Total size: 0 k Remaining: 137518 k Heartbeat: 17:19~ Start: 12:00 Finish: 12:00 Retry: ~ SWD PkgID: GG100005 SWD Pkg Version: 2 SMS_PACKAGE_TRANSFER_MANAGER 01/01/1601 00:00:00 3988 (0x0F94)

 

On the DPL I see this in smsdpprov.log

 

[4F4][Wed 07/25/2012 17:19:41]:Missing file 722227D4A8291E14E42C524424EDDAE21D4DC942CDE6F89198E172CE6C0E7E0D

[4F4][Wed 07/25/2012 17:19:41]:CContentDefinition::AddFile failed; 0x80070002

[4F4][Wed 07/25/2012 17:19:41]:Failed to add file 'AM_Delta_Patch_9999.9999.9999.9999.exe' to content library. Error code: 0X80070002

 

As far as I can see permissions are correct but I'm not sure where else to look or what to do.

Any pointers or suggestions gratefully received.

Share this post


Link to post
Share on other sites


Hi,

The error code indicates "file not found", the same package works on the other DP?

are they in the same domain? Is it only this package?

 

Regards,

Jörgen

Share this post


Link to post
Share on other sites

Both DPs are in the same domain and it was only this package causing the error.

I think I've fixed it however, it was actually a share permissions issue, the share permissions were everyone - read only, sccm computer account and user account - full control.

With these settings the transfer would fail, however as soon as I changed the share permissions to everyone - full control and removed the other accounts the transfer worked perfectly.

Share this post


Link to post
Share on other sites

Hi,

 

When I an "Automatic Deployment Rule" it download a files called "AM_Delta_Patch_9999.9999.9999.9999.exe" to the sourcefile.

 

Why the strange name "AM_Delta_Patch_9999.9999.9999.9999.exe", files use to have some kind of version number?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...