Jump to content


anyweb

Hyper V problem with Virtual Machine Bus in Device Manager

Recommended Posts

I imported some VHD's from Microsoft Virtual PC to Hyper V, and I noticed that one of my VM's had a problem, I couldn't add a second network card to it (I could add it in settings, but it would never appear as a new device on the VM or in the VM's device manager), so I checked out the device manager, there was a device with a yellow exclamation mark on it called VMBus. Double clicking on that showed me the following error

 

This device cannot find enough free resources that it can use. (Code 12)

 

After some googling I found this post and the advice in there was spot on, I had already installed my Intergration Services Setup disk and rebooted, but my problem remained, the VMBus was now called Virtual Machine Bus but still no network, so I ran MSCONFIG, clicked on boot, then clicked on the advanced tab and put a checkmark in Detect HAL, I clicked ok and reboot, some windows drivers were redetected and lo and behold my problem disappeared !

 

detect_hal.jpg

 

cheers !

 

anyweb

  • Thanks 1

Share this post


Link to post
Share on other sites

This solved an issue for me that had been going on for months!! Windows Server 2019 Host, 32-bit Server 2008 Guest, time on the guest not only would not sync, but ran considerably slower than real-time. And the CPU constantly at 100%.

THANK YOU!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...


×
×
  • Create New...