Jump to content

Recommended Posts

I keep getting the following error when I try to edit SCCM reports.


I downloaded and installed reportbuilder 3.0 on my deployment server and my workstation. I changed the registry to point to 3.0, restarted server, and ran as admin.


Regkey that changed: “HKLM\Software\Wow6432Node\Microsoft\ConfigMgr10\AdminUI\Reporting\ReportBuilderApplicationManifestName”


I even reinstalled as the Local Admin account.

Same error. Anyone have any ideas on what else I may need to do?


Share this post

Link to post
Share on other sites

OK I solved this problem. Looks like I didnt have SQL 2008 R2 edition.


I have SQL 2008 SP2 which uses RB2, installed it.


Now I have a problem in trying to create Custome reports.



A connection was successfully established with the server, but then an error occurred during the pre-login handshake. (provider: SSL Provider, error: 0 - The certificate chain was issued by an authority that is not trusted.)


I confirmed in the file C:\WINDOWS\system32\cliconfg.exe. Under the General Tab, check out the disabled protocols. "force protocol encryption" was unchecked.


Changed TrustServerCertificate to Yes.


Closed/opened Report Builder. Same error.

Share this post

Link to post
Share on other sites

One thing that still fails for me is that the Variables do not populate anything so if I wanted for instance run a report:

Reporting\Reports\Software - Companies and Products - Computers with a specific product


It forces me to search for a variable instead of being able to Type in the name of the software but there isnt anything to choose from.


Wish I could figure that out!

Share this post

Link to post
Share on other sites

Yes, I exported the certificate on the SCCM server and imported it on the workstation where I am running the report. Are you familiar with using the certificates MMC? A quick summary:


To export the certificate on the SCCM server:

1. Open MMC on the SCCM server

2. Add the certificates snap-in for the local computer

3. Browse to the personal node

4. Find the machine certificate for the sccm server

5. Right click and choose export. No need to export the private key

6. Step through the wizard, saving the cert in CER format

7. Copy the exported certificate to your work station.


To import the certificate on you workstation, follow the basic process above to open MMC, add the certificates, snap-in, etc.

However, you want to import the certificate into the Trusted Root Certificate Authorities node.


I know those directions are a rough outline and assume some knowledge. Let me know if you need more details.





Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.