Jump to content


Aerobaticrug

Deploy Office 2010 as an application - user needs admin rights?

Recommended Posts

Followed this guide for deploying office 2012 as an application - http://blogs.technet.com/b/mniehaus/archive/2011/08/13/deploying-office-2010-with-configuration-manager-2012-beta-2.aspx

 

Works fine if your an admin, however if you are a normal user it states you need admin rights to install this application. How can I get this to work for users?

Share this post


Link to post
Share on other sites

Hi, yeah, deployed to all users collection and then users are supposed to be able to install it from the app catalog.

 

It gets as far downloads the app then goes to run it and fails with the "you need admin rights to install this application".

 

I'm pulling my hair out as obviously if I did it as a package you can tell it to run with admin rights, but can't figure out how as an application.

 

Other applications such as Firefox, 7 zip all install fine. Obviously they are native MSI files though. :unsure:

Share this post


Link to post
Share on other sites

Under administration, site configuration, sites, right click your site and select Configure Site Components then select Software Distribution. On the Network Access Account tab it will show the user that will be used to install apps from the catalog. If that user is not in the local admin group for the client then it will not work.

  • Like 1

Share this post


Link to post
Share on other sites

Also make sure the MSP file is in the Updates folder and the config.xml file is in the root with setup.exe. Your config.xml should look something like this.

 

<Configuration Product="SingleImage">

<Display Level="basic" CompletionNotice="yes" SuppressModal="yes" AcceptEula="yes" />

 

<!-- <Logging Type="standard" Path="%temp%" Template="Microsoft Office Single Image Setup(*).txt" /> -->

 

<!-- <USERNAME Value="Customer" /> -->

 

<!-- <COMPANYNAME Value="MyCompany" /> -->

 

<!-- <INSTALLLOCATION Value="%programfiles%\Microsoft Office" /> -->

 

<!-- <LIS CACHEACTION="CacheOnly" /> -->

 

<!-- <LIS SOURCELIST="\\server1\share\Office;\\server2\share\Office" /> -->

 

<!-- <DistributionPoint Location="\\server\share\Office" /> -->

 

<!-- <OptionState Id="OptionID" State="absent" Children="force" /> -->

 

<!-- <Setting Id="Reboot" Value="IfNeeded" /> -->

 

<!-- <Command Path="%windir%\system32\msiexec.exe" Args="/i \\server\share\my.msi" QuietArg="/q" ChainPosition="after" Execute="install" /> -->

</Configuration>

Share this post


Link to post
Share on other sites

I honestly don't remember exactly where the setting is (during package creation, or deployment), you can try "Run as Administrator" or something similar, and see what this does for you.

Also, can the users physically access the software share?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...


×
×
  • Create New...