Jump to content


how to get rid of abortpxe.com

Recommended Posts

Note: this works for me, your mileage may vary, it's worth a try, let me know if it helps.

if you've just started testing with SCCM you'll no doubt see this when imaging a client over and over, after you image the computer you cannot image it again until you right click on the computer in SCCM and choose 'clear last PXE advertisement'


when you do that, you should be able to image the computer again, which is great when you are testing clients over and over to get your Task Sequence working...

however, after doing this a few times it no longer works, the clear last PXE advertisement no longer works


and when you PXE boot the client you still see the abortpxe message

Downloaded WDSNBP

Architecture: x64

The details below show the information relating to the PXE boot request for this computer. Please provide these details to your Windows Deployment Services Administrator so that this request can be approved.

Pending Request ID: 45

Contacting Server:
TFTP Download: smsboot\x64\abortpxe.com

PXE Boot aborted. Booting to next device...

Those lines above have added to my grey hair content many times as I would try all sort of things to resolve this including

1. deleting the advertisement and re-advertising it
2. restarting WDS and DHCP service
3. restarting SCCM server
4. all of the above and then some....

until finally I tried the following method which appears to work just fine,

Step 1.Add a rule

Add a direct membership rule on the collection you are deploying to by right clicking on it and choose properties.


click on the Membership Rules tab


click on the blue computer icon to create a direct membership rule


when the wizard appears click next

change the drop down menus so they are like this

Resource Class: System Resource
Attribute name: Name

*you can choose Netbios Name also*


enter your computername that you want to remove the abortpxe.com feature from in lowercase or use wildcards eg: dell%


click next and leave the collection blank, click next again


and here's the fun part !!!

look at the list, theres TWO of the computers with the same name... select them both *or only one if one appears* and click next


click finish and then click ok at this screen


Step 2. Refresh the collection

Refresh the collection by selecting it and hitting F5

you should now see more than one of your original computers listed with the same name...


Step 3. You are done !

That's it, your advertisement will begin working again now as now SCCM 'sees' the computer again. If you want you can delete the obsolete computers listed, it really doesn't matter if you leave them there or delete them.


that's it smile.gif

abortpxe.com is kaboof !


related reading > http://blogs.msdn.com/b/steverac/archive/2013/10/03/delete-behavior-for-devices-in-configmgr-2012.aspx

Share this post

Link to post
Share on other sites

Hi Anyweb,

just wondering if this would be possible on a domain level.... like could i put a naming standard in instead of a hostname?


e.g. LXXXYYY* ?


going to test it today anyway ... let you know if i figure anything out...



yup works perfectly using L% or D%


FYI i set my collection to update at 15minute intervals (lab) and picked up the changes.....

Share this post

Link to post
Share on other sites

it worked for me too !

BUT, my problem was slightly different.


After creating a computer association a particular PC was refusing to appear in the OS deployment collection. I added it over and over again, all in vain!


I did your procedure but put % as the value of the atribute - resource name. Then the wizard found the troublesome PC! I checked it's box and viola! it appeared in the OSD collection. The aportPXE went away too!



Share this post

Link to post
Share on other sites

In my case I needed to search by MAC address to find my phantom machine to clear the pxe advertisement because the computer had a different name. It took a while to figure out how to add an item to a collection by mac address, so here's how:


  1. Right click the collection, select Properties
  2. Select the "Membership Rules" tab
  3. Click the orange silo button to add a Query Rule
  4. Give this query a name
  5. Select "System Resource" and click "Edit Query Statement"
  6. Select the "Criteria" tab and click the yellow * button
  7. Click the "Select..." button
  8. For Attribute class select "System Resource"
  9. For Attribute class select "MAC Address"
  10. Click OK. "Operator" should already be "is equal to"
  11. For "Value" enter your MAC Address, include the colons
  12. Click OK, OK, OK, OK to get out of the wizard.
  13. Right click the collection, "Update Collection Membership" and Refresh


Now you should be able to "Clear Last PXE Advertisement" and redeploy the OS to it. In the future you can just Update Collection Membership and it'll find the machine no matter what it's name is.

Share this post

Link to post
Share on other sites

Maybe I'm not reading this topic right or maybe my problem is something different.

I have the same issue and am able to PXE boot for some machines. However, there are some machines that get the abortpxe and refuse to take the PXE step.


However, I don't want to have to find these machines each time. Is there a way to auto drop these machines so that our PXE will work for them?

It appears that the database just has these machines in there and won't let go. I'm not sure that PXE-Filter is the way to go...


Any thoughts?

Share this post

Link to post
Share on other sites

The above fix works for me most of the time; however, sometimes I build a manual machine association using the MAC address because it is a “New” machine. I add them to the “All Systems” collection first and then do a “Direct Membership” (as illustrated above) using MAC or the name I gave it when I created it. The machine shows up in the collection after refreshing/updating membership. Sometimes these pick right up and get the advertisement; other times it takes an hour for them to be recognized. When I look at the PXE service point log it says “The SMS PXS Service Point encountered and unknown device. Device MAC Address: xx:xx:xx:xx:xx:xx SMBIOS GUID: <long number/letter combo>.” Because I do not (cannot due to security) have unknown computer support turned on the machine skips over the PXE process and boots normally. Sometime later and with no other changes it picks up the advertisement and does OSD great. Any ideas?

Share this post

Link to post
Share on other sites

in that scenario if you immediatly restart the wds service and try again does it work ?

what security issues are you facing for unknown computer support ?

Share this post

Link to post
Share on other sites

Anyweb, Thanks for all of the great advice you have given here, you have done a lot of work and I, as many others are very appreciative.

I will let you know as soon as I test the “restart WDS” theory; I do not have a machine acting up right now. What would be the solution if that is it? I mean we will be imaging 20~50 computers a day at various buildings on our CAN once we are 100%, this is the last hurdle, so monitoring that and restarting that service would not be a palatable option.

As for the unknown computer support, we are a large organization with dedicated IAO (Information Assurance Office) who decided that unknown computer support sounds scary and dangerous. (Even given the password that can be used) This is not that big of a deal because I build the association in SCCM, that way I don’t have to provide a computer name (It pulls the one I give it when I build the association) and then it uses that name when it joins the domain (Again here, I have to pre-populate AD with the computer object as no computers can join our domain unless the object already exists) Ahh, the many many hoops of IT. Thanks again!

Share this post

Link to post
Share on other sites

thanks for the kind words :) the wds service has a cache which tends to 'store' things related to pxe boots, this can be set via the registry, so restarting the WDS service is a test to see if it's worth setting this value, so please test it

Share this post

Link to post
Share on other sites

Ok, so we built 3 new machine associations using MAC and computer name and then made direct membership to a collection. Tried to PXE them and they gave the error "SMS PXE Service Point Encountered an Unknown Device"


I stopped and then started the WDS service on my PXE point and then immediately all three machines started working!


Thanks for any guidance you can provide from here.




To fix this, reduce the WDS cache size. Open regedit on the WDS server and navigate to HKEY_LOCAL_MACHINE\Software\Microsoft\SMS\PXE (or for 64-bit OS, head to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\SMS\PXE). Modify the CacheExpire DWORD and set it to a lower value, in my case I set it to decimal value of 1, meaning that cache will only last for 1 second.


Restart the WDS service.


Further info here – http://support.microsoft.com/kb/2019640


Kudos to Anyweb for the tip that led me in that direction!

Share this post

Link to post
Share on other sites

This is my scenario:

I have a group of computers (Usually the same model) that do not get the F12 option when booting to PXE, they get the abort message right before F12 option. I have found that if i clear the last PXE advertisement for the collections they are members of, in about five minutes later the problem is gone. These are computers that have not been reimaged at least in the last 24 hours. I want to find the cause of the problem. It does not happen with all of the computers in the collections. Any idea how to prevent this from happening will be appreciate it.

Share this post

Link to post
Share on other sites

what does the smspxe.log reveal about the probelm when you pxe those affected computers (hint: search for the mac address of the computer and not the messages)

Share this post

Link to post
Share on other sites

I am sorry i am getting back just now. I got sidetracked with other issues


When i take a look of the smspxe.log file, this is what i found for one of the computers where the "F12" line to boot to PXE is not present:


MAC=00:E0:4D:82:3A:1B SMBIOS GUID=03000200-0400-0500-0006-000700080009 > Device found in the database. MacCount=1 GuidCount=510 smspxe 10/7/2011 9:19:36 AM 5596 (0x15DC)

[] Recv From:[] Len:303 293f070 smspxe 10/7/2011 9:19:36 AM 5564 (0x15BC)

Executing GetBootAction(70085, SCCM) smspxe 10/7/2011 9:19:36 AM 5596 (0x15DC)

No Boot Action for Device (70085) found smspxe 10/7/2011 9:19:36 AM 5596 (0x15DC)

ProcessDatabaseReply: No Advertisement found in Db for device smspxe 10/7/2011 9:19:36 AM5596 (0x15DC)



Now, when i compare the log with a good known PXE boot object, this is what is in the log:


Advertisement results: OfferId:GCC2006E OfferTime:21/03/2011 07:54:00 PackageID:GCC00033 BootImageID:GCC00072 PackageVer: PackagePath:\\SCCM\SMSPXEIMAGES$\SMSPKG\GCC00072\ Mandatory:0



What could be different when both of objects are member of the same collection?



Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...