Jump to content


Sign in to follow this  
boyjaew2

TS failed 0x80004005 - while retrieving policy

Recommended Posts

log: DNS is working and certificates are not expired. PXE boots fine fails after entering password for task sequence - Help please....

 

 

 

 

LOGGING: Finalize process ID set to 824 TSBootShell 1/1/1980 1:27:12 AM 828 (0x033C)

==============================[ TSBootShell.exe ]============================== TSBootShell 1/1/1980 1:27:12 AM 828 (0x033C)

Succeeded loading resource DLL 'X:\sms\bin\x64\1033\TSRES.DLL' TSBootShell 1/1/1980 1:27:12 AM 828 (0x033C)

Debug shell is enabled TSBootShell 1/1/1980 1:27:12 AM 828 (0x033C)

Waiting for PNP initialization... TSBootShell 1/1/1980 1:27:12 AM 860 (0x035C)

Booted from network (PXE) TSBootShell 1/1/1980 1:27:12 AM 860 (0x035C)

Found config path X:\sms\data\ TSBootShell 1/1/1980 1:27:12 AM 860 (0x035C)

Booting from removable media, not restoring bootloaders on hard drive TSBootShell 1/1/1980 1:27:12 AM 860 (0x035C)

Executing command line: wpeinit.exe -winpe TSBootShell 1/1/1980 1:27:12 AM 860 (0x035C)

The command completed successfully. TSBootShell 1/1/1980 1:27:33 AM 860 (0x035C)

Starting DNS client service. TSBootShell 1/1/1980 1:27:33 AM 860 (0x035C)

Executing command line: X:\sms\bin\x64\TsmBootstrap.exe /env:WinPE /configpath:X:\sms\data\ TSBootShell 1/1/1980 1:27:34 AM 860 (0x035C)

The command completed successfully. TSBootShell 1/1/1980 1:27:34 AM 860 (0x035C)

==============================[ TSMBootStrap.exe ]============================== TSMBootstrap 1/1/1980 1:27:34 AM 908 (0x038C)

Command line: X:\sms\bin\x64\TsmBootstrap.exe /env:WinPE /configpath:X:\sms\data\ TSMBootstrap 1/1/1980 1:27:34 AM 908 (0x038C)

Succeeded loading resource DLL 'X:\sms\bin\x64\1033\TSRES.DLL' TSMBootstrap 1/1/1980 1:27:34 AM 908 (0x038C)

Succeeded loading resource DLL 'X:\sms\bin\x64\TSRESNLC.DLL' TSMBootstrap 1/1/1980 1:27:34 AM 908 (0x038C)

PXE Boot with Root = X:\ TSMBootstrap 1/1/1980 1:27:34 AM 908 (0x038C)

Executing from PXE in WinPE TSMBootstrap 1/1/1980 1:27:34 AM 908 (0x038C)

Loading TsPxe.dll from X:\sms\bin\x64\TsPxe.dll TSMBootstrap 1/1/1980 1:27:34 AM 908 (0x038C)

TsPxe.dll loaded TSPxe 1/1/1980 1:27:34 AM 908 (0x038C)

Device has PXE booted TSPxe 1/1/1980 1:27:34 AM 908 (0x038C)

Variable Path: \SMSTemp\2012.10.25.12.55.57.0003.{0F6519A1-2BAE-43A8-A600-ACEA47D69C8D}.boot.var TSPxe 1/1/1980 1:27:34 AM 908 (0x038C)

Succesfully added firewall rule for Tftp TSPxe 1/1/1980 1:27:34 AM 908 (0x038C)

Executing: X:\sms\bin\x64\smstftp.exe -i 10.10.10.51 get \SMSTemp\2012.10.25.12.55.57.0003.{0F6519A1-2BAE-43A8-A600-ACEA47D69C8D}.boot.var X:\sms\data\variables.dat TSPxe 1/1/1980 1:27:34 AM 908 (0x038C)

Command line for extension .exe is "%1" %* TSPxe 1/1/1980 1:27:34 AM 908 (0x038C)

Set command line: "X:\sms\bin\x64\smstftp.exe" -i 10.10.10.51 get \SMSTemp\2012.10.25.12.55.57.0003.{0F6519A1-2BAE-43A8-A600-ACEA47D69C8D}.boot.var X:\sms\data\variables.dat TSPxe 1/1/1980 1:27:34 AM 908 (0x038C)

Executing command line: "X:\sms\bin\x64\smstftp.exe" -i 10.10.10.51 get \SMSTemp\2012.10.25.12.55.57.0003.{0F6519A1-2BAE-43A8-A600-ACEA47D69C8D}.boot.var X:\sms\data\variables.dat TSPxe 1/1/1980 1:27:34 AM 908 (0x038C)

Process completed with exit code 0 TSPxe 1/1/1980 1:27:34 AM 908 (0x038C)

Succesfully removed firewall rule for Tftp TSPxe 1/1/1980 1:27:34 AM 908 (0x038C)

Successfully downloaded pxe variable file. TSPxe 1/1/1980 1:27:34 AM 908 (0x038C)

we are booted using PXE TSPxe 1/1/1980 1:27:34 AM 908 (0x038C)

we are booted using PXE and we don't use a password or the password is provided by the user TSPxe 1/1/1980 1:27:34 AM 908 (0x038C)

Found network adapter "Intel® 82579LM Gigabit Network Connection" with IP Address 10.10.10.152. TSPxe 1/1/1980 1:27:34 AM 908 (0x038C)

Run PXE Interactive TSPxe 1/1/1980 1:27:34 AM 908 (0x038C)

Running Wizard in Interactive mode TSPxe 1/1/1980 1:27:34 AM 908 (0x038C)

Loading Media Variables from "X:\sms\data\variables.dat" TSPxe 1/1/1980 1:27:34 AM 908 (0x038C)

CryptDecrypt (hKey, 0, 1, 0, pData, &dwDecryptedLen), HRESULT=80090005 (e:\nts_sccm_release\sms\framework\smscrypt\windes.cpp,150) TSPxe 1/1/1980 1:27:34 AM 908 (0x038C)

SMS::Crypto::DES::DecryptBuffer( (BYTE*)pszPassword, (DWORD)(wcslen(pszPassword)*sizeof(WCHAR)), encryptedBuffer.getBuffer(), (DWORD)encryptedBuffer.size(), pbDecryptedBuffer, dwDecryptedBufferSize ), HRESULT=80090005 (e:\nts_sccm_release\sms\framework\tscore\tsremovablemedia.cpp,387) TSPxe 1/1/1980 1:27:34 AM 908 (0x038C)

Activating Welcome Page. TSPxe 1/1/1980 1:27:34 AM 908 (0x038C)

Loading bitmap TSPxe 1/1/1980 1:27:34 AM 908 (0x038C)

WelcomePage::OnWizardNext() TSPxe 1/1/1980 1:29:40 AM 908 (0x038C)

Loading Media Variables from "X:\sms\data\variables.dat" TSPxe 1/1/1980 1:29:40 AM 908 (0x038C)

CryptDecrypt (hKey, 0, 1, 0, pData, &dwDecryptedLen), HRESULT=80090005 (e:\nts_sccm_release\sms\framework\smscrypt\windes.cpp,150) TSPxe 1/1/1980 1:29:40 AM 908 (0x038C)

SMS::Crypto::DES::DecryptBuffer( (BYTE*)pszPassword, (DWORD)(wcslen(pszPassword)*sizeof(WCHAR)), encryptedBuffer.getBuffer(), (DWORD)encryptedBuffer.size(), pbDecryptedBuffer, dwDecryptedBufferSize ), HRESULT=80090005 (e:\nts_sccm_release\sms\framework\tscore\tsremovablemedia.cpp,387) TSPxe 1/1/1980 1:29:40 AM 908 (0x038C)

Loading Media Variables from "X:\sms\data\variables.dat" TSPxe 1/1/1980 1:29:40 AM 908 (0x038C)

CryptDecrypt (hKey, 0, 1, 0, pData, &dwDecryptedLen), HRESULT=80090005 (e:\nts_sccm_release\sms\framework\smscrypt\windes.cpp,150) TSPxe 1/1/1980 1:29:40 AM 908 (0x038C)

SMS::Crypto::DES::DecryptBuffer( (BYTE*)pszPassword, (DWORD)(wcslen(pszPassword)*sizeof(WCHAR)), encryptedBuffer.getBuffer(), (DWORD)encryptedBuffer.size(), pbDecryptedBuffer, dwDecryptedBufferSize ), HRESULT=80090005 (e:\nts_sccm_release\sms\framework\tscore\tsremovablemedia.cpp,387) TSPxe 1/1/1980 1:29:40 AM 908 (0x038C)

Verifying media password. TSPxe 1/1/1980 1:29:40 AM 908 (0x038C)

Loading Media Variables from "X:\sms\data\variables.dat" TSPxe 1/1/1980 1:29:40 AM 908 (0x038C)

Spawned thread 1004 to download policy. TSPxe 1/1/1980 1:29:40 AM 908 (0x038C)

Entering TSMediaWizardControl::GetPolicy. TSPxe 1/1/1980 1:29:40 AM 1004 (0x03EC)

Environment scope "Global\{51A016B6-F0DE-4752-B97C-54E6F386A912}" successfully created TSPxe 1/1/1980 1:29:40 AM 1004 (0x03EC)

Environment scope "Global\{BA3A3900-CA6D-4ac1-8C28-5073AFC22B03}" successfully created TSPxe 1/1/1980 1:29:40 AM 1004 (0x03EC)

Setting LogMaxSize to 1000000 TSPxe 1/1/1980 1:29:40 AM 1004 (0x03EC)

Setting LogMaxHistory to 1 TSPxe 1/1/1980 1:29:40 AM 1004 (0x03EC)

Setting LogLevel to 0 TSPxe 1/1/1980 1:29:40 AM 1004 (0x03EC)

Setting LogEnabled to 1 TSPxe 1/1/1980 1:29:40 AM 1004 (0x03EC)

Setting LogDebug to 1 TSPxe 1/1/1980 1:29:40 AM 1004 (0x03EC)

Loading variables from the Task Sequencing Removable Media. TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Loading Media Variables from "X:\sms\data\variables.dat" TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Setting SMSTSMP TS environment variable TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Setting _SMSMediaGuid TS environment variable TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Setting _SMSTSBootMediaPackageID TS environment variable TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Setting _SMSTSHTTPPort TS environment variable TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Setting _SMSTSHTTPSPort TS environment variable TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Setting _SMSTSIISSSLState TS environment variable TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Setting _SMSTSLaunchMode TS environment variable TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Setting _SMSTSMediaPFX TS environment variable TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Setting _SMSTSPublicRootKey TS environment variable TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Setting _SMSTSSiteCode TS environment variable TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Setting _SMSTSSiteSigningCertificate TS environment variable TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Setting _SMSTSUseFirstCert TS environment variable TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Setting _SMSTSx64UnknownMachineGUID TS environment variable TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Setting _SMSTSx86UnknownMachineGUID TS environment variable TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Root CA Public Certs= TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Missing root CA environment variable from variables file TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Custom hook from X:\\TSConfig.INI is TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

No hook is found to be executed before downloading policy TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Authenticator from the environment is empty. TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Need to create Authenticator Info using PFX TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Set media certificate in transport TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Set authenticator in transport TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

CLibSMSMessageWinHttpTransport::Send: URL: sccm12.trihydro.com:80 GET /SMS_MP/.sms_aut?MPKEYINFORMATION TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Request was succesful. TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Default CSP is Microsoft Enhanced RSA and AES Cryptographic Provider TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Default CSP Type is 24 TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

New settings: TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

site=CCM,CCM, MP=http://sccm12.trihydro.com, ports: http=80,https=443 TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

certificates are received from MP. TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Getting MP time information TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Set authenticator in transport TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Requesting client identity TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Setting message signatures. TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Setting the authenticator. TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

CLibSMSMessageWinHttpTransport::Send: URL: sccm12.trihydro.com:80 CCM_POST /ccm_system/request TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Request was succesful. TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

pNext != NULL, HRESULT=80004005 (e:\nts_sccm_release\sms\framework\osdmessaging\libsmsmessaging.cpp,1967) TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

reply has no message header marker TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

DoRequest (sReply, true), HRESULT=80004005 (e:\nts_sccm_release\sms\framework\osdmessaging\libsmsmessaging.cpp,5709) TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Failed to get client identity (80004005) TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

ClientIdentity.RequestClientIdentity (), HRESULT=80004005 (e:\nts_sccm_release\sms\client\tasksequence\tsmbootstrap\tsmediawizardcontrol.cpp,1036) TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

failed to request for client TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Exiting TSMediaWizardControl::GetPolicy. TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

pWelcomePage->m_pTSMediaWizardControl->GetPolicy(), HRESULT=80004005 (e:\nts_sccm_release\sms\client\tasksequence\tsmbootstrap\tsmediawelcomepage.cpp,303) TSPxe 1/1/1980 1:29:41 AM 1004 (0x03EC)

Setting wizard error: An error occurred while retrieving policy for this computer (0x80004005). For more information, contact your system administrator or helpdesk operator. TSPxe 1/1/1980 1:29:41 AM 908 (0x038C)

WelcomePage::OnWizardNext() TSPxe 1/1/1980 1:29:41 AM 908 (0x038C)

Skipping Confirmation Page. TSPxe 1/1/1980 1:29:41 AM 908 (0x038C)

Skipping Task Sequence Selection Page. TSPxe 1/1/1980 1:29:41 AM 908 (0x038C)

Skipping Variables Selection Page. TSPxe 1/1/1980 1:29:41 AM 908 (0x038C)

Skipping Resolve Progress Page. TSPxe 1/1/1980 1:29:41 AM 908 (0x038C)

Activating Finish Page. TSPxe 1/1/1980 1:29:41 AM 908 (0x038C)

Initializing the countdown timer. TSPxe 1/1/1980 1:29:41 AM 908 (0x038C)

Loading bitmap TSPxe 1/1/1980 1:29:41 AM 908 (0x038C)

Executing command line: X:\WINDOWS\system32\cmd.exe /k TSBootShell 1/1/1980 1:29:47 AM 828 (0x033C)

The command completed successfully. TSBootShell 1/1/1980 1:29:47 AM 828 (0x033C)

Successfully launched command shell. TSBootShell 1/1/1980 1:29:47 AM 828 (0x033C)

Share this post


Link to post
Share on other sites

Okay, here we go, turns out the freakin' time and date on this particular laptop was WAY off. It had nothing to do with SCCM at all. Once I went into the BIOS and changed the date and time it PXE'd and ran the task TS as expected.So, check you BIOS time I guess.

Share this post


Link to post
Share on other sites

Has anyone else had this issue?

 

I'm having the same issue, trying to OSD deploy to a Hyper V Client.

 

It's quite random, some times it'll install the OS fine, however it never reports "successful". (basic TS with only windows image)

other times it'll fail at getting the policy information for the TS

other times it'll fail at getting all the reference information.

 

 

I've checked.

 

all packages are distributed to all distributions points.

i don't have any overlapping boundary's. - they are configured as AD sites.

Network access account is a local admin on all SCCM servers.

No Certs are blocked

 

PXE boot seems to work fine.

looking at the smsts log when a TS fails shows no obvious errors of any kind.

 

 

I've increased the amount of RAM on my VM to see if that has any affect.

 

I"m not sure what else to check...

Share this post


Link to post
Share on other sites

I'm having the same thing now in a Hyper-V VM that I'm trying to build and capture Server 2008 R2. I get the error during the Apply Operating System portion but when it happens it is too fast for me to see if it slips by that portion to the next or not. I cannot F8 for some reason even though the command testing is checked. Don't know if that's related to Hyper-V or not.

 

Since I can't get to the log I'm sort of stuck.

Share this post


Link to post
Share on other sites

Hi all,

 

I am currently facing same error code when deploying windows 7 enterprise to a vm, Network acces has been configured in sccm and the user has full permission on the folder sources. i can't figure out where the issue is. please fin log file for SMSPXE below:

 

 

PXE::MP_InitializeTransport failed; 0x80004005 SMSPXE 1/28/2014 12:02:30 AM 4360 (0x1108)
PXE::MP_LookupDevice failed; 0x80004005 SMSPXE 1/28/2014 12:02:30 AM 4360 (0x1108)
RequestMPKeyInformation: Send() failed. SMSPXE 1/28/2014 12:02:30 AM 4360 (0x1108)
Failed to get information for MP: http://SCCMSEERVER.sccm.local. 80004005. SMSPXE 1/28/2014 12:02:30 AM 4360 (0x1108)
PXE::MP_InitializeTransport failed; 0x80004005 SMSPXE 1/28/2014 12:02:30 AM 4360 (0x1108)
PXE::MP_ReportStatus failed; 0x80004005 SMSPXE 1/28/2014 12:02:30 AM 4360 (0x1108)
PXE Provider failed to process message.
Unspecified error (Error: 80004005; Source: Windows) SMSPXE 1/28/2014 12:02:30 AM 4360 (0x1108)
00:15:5D:0B:0A:0F, 0614150E-39C2-41FF-A4D7-63E32D3904DB: Not serviced. SMSPXE 1/28/2014 12:02:30 AM 4360 (0x1108)
RequestMPKeyInformation: Send() failed. SMSPXE 1/28/2014 12:02:34 AM 4360 (0x1108)
Failed to get information for MP: http://SCCMSEERVER.sccm.local. 80004005. SMSPXE 1/28/2014 12:02:34 AM 4360 (0x1108)
PXE::MP_InitializeTransport failed; 0x80004005 SMSPXE 1/28/2014 12:02:34 AM 4360 (0x1108)
PXE::MP_LookupDevice failed; 0x80004005 SMSPXE 1/28/2014 12:02:34 AM 4360 (0x1108)
RequestMPKeyInformation: Send() failed. SMSPXE 1/28/2014 12:02:34 AM 4360 (0x1108)
Failed to get information for MP: http://SCCMSEERVER.sccm.local. 80004005. SMSPXE 1/28/2014 12:02:34 AM 4360 (0x1108)
PXE::MP_InitializeTransport failed; 0x80004005 SMSPXE 1/28/2014 12:02:34 AM 4360 (0x1108)
PXE::MP_ReportStatus failed; 0x80004005 SMSPXE 1/28/2014 12:02:34 AM 4360 (0x1108)
PXE Provider failed to process message.
Unspecified error (Error: 80004005; Source: Windows) SMSPXE 1/28/2014 12:02:34 AM 4360 (0x1108)

 

 

 

 

 

Share this post


Link to post
Share on other sites

For future researchers: I ran into this problem yesterday, with these errors in smsts.log:

 

reply has no message header marker TSPxe 7/13/2016 11:34:08 AM 1644 (0x066C)
DoRequest (sReply, false), HRESULT=80004005 (e:\nts_sccm_release\sms\framework\osdmessaging\libsmsmessaging.cpp,7299) TSPxe 7/13/2016 11:34:08 AM 1644 (0x066C)
SendReport (L"mp:[http]MP_DdrEndpoint", L"MP_DdrEndpoint", L"{00000000-0000-0000-0000-000000000003}", 0, true, sReportBody.c_str()), HRESULT=80004005 (e:\nts_sccm_release\sms\framework\osdmessaging\libsmsmessaging.cpp,7704) TSPxe 7/13/2016 11:34:08 AM 1644 (0x066C)
oClientDDR.SendDDR(), HRESULT=80004005 (e:\nts_sccm_release\sms\framework\tscore\tspolicy.cpp,568) TSPxe 7/13/2016 11:34:08 AM 1644 (0x066C)
Failed to send DDR (0x80004005) TSPxe 7/13/2016 11:34:08 AM 1644 (0x066C)
SendDDR (&m_oHttpTransport, m_sSiteCode.c_str(), sMediaGuid.c_str(), m_sClientIdentity), HRESULT=80004005 (e:\nts_sccm_release\sms\framework\tscore\tspolicy.cpp,952) TSPxe 7/13/2016 11:34:08 AM 1644 (0x066C)
failed to send the DDR (0x80004005) TSPxe 7/13/2016 11:34:08 AM 1644 (0x066C)

 

In our case, it had nothing to do with the time or certs. The database was out of disk space! Expanded the disk and all is well this morning. Too bad the error isn't a little more helpful about the problem...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...