Jump to content


surferstylee

Cannot import Dell CAB drivers into SCCM2012

Recommended Posts

I am attempting to import Dell E6510 CAB drivers into SCCM 2012 but everyone of them fails except for the ST Micro driver. Upon completing the import wizard the failure gives the following error:

 

The selected file is not a valid Windows device driver.

 

In the DriverCatalog.log on the SCCM server I see the following:

 

This driver does not have a valid version signature.

Failed to initialize driver digest. Code 0xe0000102

 

Is there a setting in SCCM to accept unsigned drivers during the import process or something that I am missing?

 

Any help would be greatly appreciated!

Share this post


Link to post
Share on other sites


I've had the same problem with the E6510 in the beginning. Some drivers cannot be imported into sccm. I know there are some problems with soundcards and biometric devices. For them you need to take the hardware id and search for a more appropriate driver elseware and test if it's the good one.

Not all drivers from the computer brand are good. I know because I had the problem with Dell and Lenovo computers.

 

For the ST micro driver look for R257449 (version 1.0.0.3), the dell driver works for me. (2007 SP2 R3)

Share this post


Link to post
Share on other sites

I am attempting to import Dell E6510 CAB drivers into SCCM 2012 but everyone of them fails except for the ST Micro driver. Upon completing the import wizard the failure gives the following error:

 

The selected file is not a valid Windows device driver.

 

In the DriverCatalog.log on the SCCM server I see the following:

 

This driver does not have a valid version signature.

Failed to initialize driver digest. Code 0xe0000102

 

Is there a setting in SCCM to accept unsigned drivers during the import process or something that I am missing?

 

Any help would be greatly appreciated!

 

can you post the link to the CAB file you downloaded and i can test it here

Share this post


Link to post
Share on other sites

Thank you for the replies gentlemen. The link to the .CAB I was trying to use is: http://en.community.dell.com/techcenter/enterprise-client/w/wiki/2090.latitude-e6510-windows-7-driver-cab.aspx

 

The ST Micro driver in this CAB is the ONLY one that worked for me.Every single driver other than that one failed. I just find it hard to believe that nothing else in that CAB is legit

 

Niall:

 

I look forward to your results!!!

Share this post


Link to post
Share on other sites

From a response to a post i have on TechNet:

 

I've just downloaded the latest version and imported the drivers to my lab.

All drivers was imported successfully. (I only tested Windows 7 x64 drivers).

What OS version did you import drivers for?

 

I have not verified he used the same CAB I was trying but I awaiting a reply regarding this. I am going to test other models to see if this is isolated to the E6510

Share this post


Link to post
Share on other sites

***UPDATE***

 

So I tried importing the Optiplex 390 CAB and received the same failure for every single driver; however, when importing the Optiplex 380....every driver imported perfectly, except for 1 that failed. This would lead me to believe it to be an issue with the CAB drivers for these particular models.... As soon as I can find out which CAB file and model the gentleman on TechNet was able to successfully import I should be able to validate this.

Share this post


Link to post
Share on other sites

Kingskawn: Yes, if you are referring to the drivercatalog.log. from initial post:

 

In the DriverCatalog.log on the SCCM server I see the following:

This driver does not have a valid version signature.

Failed to initialize driver digest. Code 0xe0000102

 

Oneone Yes, using 7-zip. i thought maybe using a different utility might be part of it but I had complete success with the 380 CAB using the exact same process....

Share this post


Link to post
Share on other sites

I have imported both sets of these model specific driver packages(Optiplex 390 and E6510 x86 only) from the same resource without any errors........Have you since tried the new multi-combo pack??

 

http://en.community.dell.com/techcenter/enterprise-client/w/wiki/2171.windows-7-notebook-combo-driver-cab.aspx

 

NoteBooks/Laptops

Latitude

--------

2110,2120,5420m,5520m,E4200,E4300,E4310,E5400,E5410,E5420,E5430,E5500,E5510,E5520,E5530,E6220,E6230,E6320,E6330,E6400,E6410,E6420,E6430,E6430s

E6500,E6510,E6520,E6530,XT2,XT3,Z600

 

Precision

---------

M2400,M4400,M4500,M4600,M4700,M6400,M6500,M6600,M6700

 

 

 

Desktops:

http://en.community.dell.com/techcenter/enterprise-client/w/wiki/2172.windows-7-desktop-combo-driver-cab.aspx

 

Optiplex

--------

360,380,390,760,780,790,960,980,990,3010,7010,9010,9010aio,XE

 

Precision

---------

R5400,R5500,T1600,T1650,T3500,T3600,T5500,T5600,T7500,T7600

 

These are only fairly new driver packages but I have tested them and imported them on 3 seperate single primary sites and with success.You may not need them all but if it works for you it will let you carry on!

 

Rocket Man

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...