Jump to content


kemi

Problem with full unattend WDS deployment / also have prob with multicasting

Recommended Posts

Okey, the first problem is solved!

<Filename>win7.wim</Filename> was wrong, because the captured win7.wim getting renamed - when WDS adding install image - to win7install.wim

 

In this video you can see the setup asks me to press next at the select operation system stage.

How can i automate that?

 

http://www.youtube.com/watch?v=BcwJ-7baJRQ

 

virtual box 4.2.6

Win2k8r2

Install-wim from syspreped win7

boot.wim from win7 install cd

 

 

WDSunattend.xml

 

<?xml version="1.0" encoding="utf-8"?>

<unattend xmlns="urn:schemas-microsoft-com:unattend">

<settings pass="windowsPE">

<component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.micro...fig/2002/State" xmlns:xsi="http://www.w3.org/20...hema-instance">

<SetupUILanguage>

<UILanguage>hu-hu</UILanguage>

</SetupUILanguage>

<InputLocale>hu-hu</InputLocale>

<SystemLocale>hu-hu</SystemLocale>

<UILanguage>hu-hu</UILanguage>

<UILanguageFallback>hu-hu</UILanguageFallback>

<UserLocale>hu-hu</UserLocale>

</component>

<component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.micro...fig/2002/State" xmlns:xsi="http://www.w3.org/20...hema-instance">

<UserData>

<ProductKey>

<Key>XXXXX-XXXXX-XXXXX-XXXXX-XXXXX</Key>

<WillShowUI>onerror</WillShowUI>

</ProductKey>

<AcceptEula>true</AcceptEula>

</UserData>

<DiskConfiguration>

<Disk wcm:action="add">

<CreatePartitions>

<CreatePartition wcm:action="add">

<Extend>true</Extend>

<Order>1</Order>

<Type>Primary</Type>

</CreatePartition>

</CreatePartitions>

<ModifyPartitions>

<ModifyPartition wcm:action="add">

<Active>true</Active>

<Format>NTFS</Format>

<Order>1</Order>

<PartitionID>1</PartitionID>

<Label>Windows</Label>

<Letter>C</Letter>

</ModifyPartition>

</ModifyPartitions>

<DiskID>0</DiskID>

<WillWipeDisk>true</WillWipeDisk>

</Disk>

<WillShowUI>onerror</WillShowUI>

</DiskConfiguration>

<ImageInstall>

<OSImage>

<InstallTo>

<PartitionID>1</PartitionID>

</InstallTo>

</OSImage>

</ImageInstall>

<WindowsDeploymentServices>

<Login>

<Credentials>

<Domain>iroda.local</Domain>

<Password>********</Password>

<Username>Administrator</Username>

</Credentials>

</Login>

<ImageSelection>

<InstallTo>

<DiskID>0</DiskID>

<PartitionID>1</PartitionID>

</InstallTo>

<InstallImage>

<Filename>win7.wim</Filename>

<ImageGroup>OS</ImageGroup>

<ImageName>Windows7Ultimate</ImageName>

</InstallImage>

</ImageSelection>

</WindowsDeploymentServices>

</component>

</settings>

<settings pass="specialize">

<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.micro...fig/2002/State" xmlns:xsi="http://www.w3.org/20...hema-instance">

<ComputerName>*</ComputerName>

<TimeZone>GTM+1</TimeZone>

</component>

</settings>

<settings pass="oobeSystem">

<component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.micro...fig/2002/State" xmlns:xsi="http://www.w3.org/20...hema-instance">

<InputLocale>hu-hu</InputLocale>

<SystemLocale>hu-hu</SystemLocale>

<UILanguage>hu-hu</UILanguage>

<UserLocale>hu-hu</UserLocale>

</component>

<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.micro...fig/2002/State" xmlns:xsi="http://www.w3.org/20...hema-instance">

<OOBE>

<HideEULAPage>true</HideEULAPage>

<HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>

<NetworkLocation>Home</NetworkLocation>

<ProtectYourPC>1</ProtectYourPC>

</OOBE>

<UserAccounts>

<AdministratorPassword>

<Value>MQAyADMANAA1AEEAZABtAGkAbgBpAHMAdAByAGEAdABvAHIAUABhAHMAcwB3AG8AcgBkAA==</Value>

<PlainText>false</PlainText>

</AdministratorPassword>

<LocalAccounts>

<LocalAccount wcm:action="add">

<Password>

<Value>MQAyADMANAA1AFAAYQBzAHMAdwBvAHIAZAA=</Value>

<PlainText>false</PlainText>

</Password>

<DisplayName>Admin</DisplayName>

<Group>Administrators</Group>

<Name>Administrator</Name>

</LocalAccount>

</LocalAccounts>

</UserAccounts>

<TimeZone>GTM+1</TimeZone>

</component>

</settings>

<cpi:offlineImage cpi:source="catalog://vboxsvr/installcd/install_windows 7 ultimate.clg" xmlns:cpi="urn:schemas-microsoft-com:cpi" />

</unattend>

 

 

and here is the second answer file it works just file

 

 

<?xml version="1.0" encoding="utf-8"?>

<unattend xmlns="urn:schemas-microsoft-com:unattend">

<settings pass="oobeSystem">

<component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.micro...fig/2002/State" xmlns:xsi="http://www.w3.org/20...hema-instance">

<InputLocale>hu-hu</InputLocale>

<SystemLocale>hu-hu</SystemLocale>

<UILanguage>hu-hu</UILanguage>

<UserLocale>hu-hu</UserLocale>

</component>

<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.micro...fig/2002/State" xmlns:xsi="http://www.w3.org/20...hema-instance">

<OOBE>

<HideEULAPage>true</HideEULAPage>

<NetworkLocation>Home</NetworkLocation>

<ProtectYourPC>1</ProtectYourPC>

</OOBE>

<UserAccounts>

<LocalAccounts>

<LocalAccount wcm:action="add">

<Password>

<Value>MQAyADMAUABhAHMAcwB3AG8AcgBkAA==</Value>

<PlainText>false</PlainText>

</Password>

<Description>first admin user</Description>

<DisplayName>user</DisplayName>

<Group>administrators</Group>

<Name>user</Name>

</LocalAccount>

</LocalAccounts>

</UserAccounts>

<TimeZone>Central Europe Standard Time</TimeZone>

</component>

</settings>

<settings pass="specialize">

<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.micro...fig/2002/State" xmlns:xsi="http://www.w3.org/20...hema-instance">

<ComputerName>*</ComputerName>

<ProductKey>xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx</ProductKey>

</component>

<component name="Microsoft-Windows-UnattendedJoin" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.micro...fig/2002/State" xmlns:xsi="http://www.w3.org/20...hema-instance">

<Identification>

<Credentials>

<Domain>iroda.local</Domain>

<Password>********</Password>

<Username>Administrator</Username>

</Credentials>

<JoinDomain>iroda.local</JoinDomain>

</Identification>

</component>

</settings>

<cpi:offlineImage cpi:source="catalog://kem-pc/cinstallcd/sources/install_windows 7 ultimate.clg" xmlns:cpi="urn:schemas-microsoft-com:cpi" />

</unattend>

 

 

I also have problem with multicasting. I am using VirtualBox to simulate deploying multiple windows7's.

When 2 clients are loaded and the setup ask me to press next at the select operation system stage as before it stops with "system can't find the hard disk to store temp install files".

If i close one client and press the next on the other one it will continue to install.

 

590autocast_tn.jpg

Share this post


Link to post
Share on other sites


the first parth is solved, but i still got this error

the first one is failed, the second one is good

what is the problem?

 

 

okey, now it is solved too

i had to expand the virtual hard disk, i also reduced the amount of RAM per virtual machine

it is strange because i could install win7 to the smaller virtual disk before, but not with multicasting

 

 

782multicast.png

Share this post


Link to post
Share on other sites

First off, congrats on solving your deployment issue. However, when reading your two posts, I thought of another solution that you may find beneficial for deployment. In addition to using WDS and unattend files for automating your deployments, you might also want to checkout MDT, the Microsoft Deployment Toolkit, which is a free utility provided by Microsoft and can help automate all deployments from Windows XP, Windows Vista, Windows 7, Windows 8, Windows Server 2003, Windows Server 2008, Windows Server 2008 R2, and Windows Server 2012. Using MDT, you can create hardware independent images and add drivers as well as applications to a deployment share and then create a task sequence tailored to your deployment needs. Creating an unattend file and deploying a captured image using WDS is a great method but it couldn’t hurt to also see if MDT would also be able to meet your needs. Perhaps one of my favorite things about MDT is that it can even be used in conjunction with WDS.

 

To become more familiar with MDT as a stand-alone product as well as in conjunction with WDS, I recommend the following 3 videos from the Springboard Series page on TechNet:

 

· Deployment Day Session 1: Introduction to MDT 2012

· Deployment Day Session 2: MDT 2012 Advanced

· Deployment Day Session 3: Deployment using WDS

 

Anyway, again, I am glad you were able to get your deployment working in your virtual environment. Feel free to reach out with any questions.

 

Jessica
Windows Outreach Team – IT Pro

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...