Jump to content


Recommended Posts

Hello,

 

I running with a new 2012 build: Windows 2012 STD, SQL 2012 (CU5), and SCCM 2012 SP1. I installed WSUS and then SUP and most of the updates are downloading. Sporadically the wsyncmgr.log is showing : Failed to sync update “xxxxxxxx-xxxx-xxxx-xxxxxxxxxxxx”. Error: The Microsoft Software License Terms have not been completely downloaded and cannot be accepted. Source: Microsoft.UpdateServices.Internal.BaseApi.SoapExceptionProcessor.DeserializeAndThrow.

I have looked at a lot of the solutions out there and of them none appear to apply. Permisisons in the DB and folders are good. WSUS path is good in SQL.

 

Thank you!

 

 

One side note: SUP had only English selected as my choice but when I was reviewing the settings in the WSUS console it was set to download all languages.

Share this post


Link to post
Share on other sites


Got it! I unselected all Classisfications in SUP, ran wsusutil reset, ran another sync, re-added Classifications, and the flood gates opened.

  • Like 2

Share this post


Link to post
Share on other sites

Thank you so much for posting your solution here. It didn't work exactly as you have listed for me, I had to do an extra sync between unselecting the classifications in SUP and running the reset command - but I did manage to get it working again thanks to you! Bravo!

Share this post


Link to post
Share on other sites

I am having the same issue but just recently. SCCM 2012 sp1, running on Server 2008 R2, WSUS version 3.0 SP2 3.2.7600.226. I have 3 updates with download errors of the Microsoft Software License Terms, all others are good. I have done the suggested fix un-selected SUP classifications, ran wsusutil reset, manual sync, which did timeout, selected SUP classifications, ran manual sync and still same results. So with the failed sync my SUP is syncing every hour instead of on the configured schedule. My SCCM server has been up since Oct. 2012,

 

Prior to running wsusutil reset Event viewer error

Source - SMS Server

WSUS Synchronization failed. Message: WSUS server not configured. Please refer to WCM.log for configuration error details..Source: CWSyncMgr::DoSync.The operating system reported error 2147500037: Unspecified error

 

After the reset Event viewer error

Source - SMS server

WSUS Synchronization failed.
Message: Failed to sync some of the updates.
Source: Microsoft.SystemsManagementServer.SoftwareUpdatesManagement.WsusSyncAction.WSyncAction.SyncUpdates.
The operating system reported error 2148734208:
Source - Windows Server Update Services
Content file download failed. Reason: HTTP status 401: The requested resource requires user authentication.
Source File: /msdownload/update/v5/eula.......
So progress but not resolved. A side note, I had been off for a few weeks and upon returning I found that the C drive was almost full, I found over 19 GB of logs in C:\inetpub\logs\LogFiles\W3SVC1 & W3SVC388031976. I deleted all older than 6 months. So WSUS services had all sorts of errors along with other services in the event viewer about the low disk space. The server has 2 drives, the WSUS content folders reside on a second drive which has over 20 GB of free space.
I have read about some issues with Server 2012 requiring a patch of WSUS to fix a similar issue, could there be a patch for 2008 R2 as well?

 

Share this post


Link to post
Share on other sites

Got it! I unselected all Classisfications in SUP, ran wsusutil reset, ran another sync, re-added Classifications, and the flood gates opened.

This worked for me, thanks for posting.

Share this post


Link to post
Share on other sites

Got it! I unselected all Classisfications in SUP, ran wsusutil reset, ran another sync, re-added Classifications, and the flood gates opened.

 

I had the very same issue, Fixed it for me. Many thanks.

Share this post


Link to post
Share on other sites

worked for me as well!

 

For the newer techs to SCCM, you can find the SUP settings under Administration > Site Configuration > Sites > Configure Site Components > Software Update Point > Classifications

Share this post


Link to post
Share on other sites

worked for me as well!

 

For the newer techs to SCCM, you can find the SUP settings under Administration > Site Configuration > Sites > Configure Site Components > Software Update Point > Classifications

Worked for me as well - Thanks for pointing me in the right direction. I had gone to WSUS to remove classifications and found out that approach isn't possible

Share this post


Link to post
Share on other sites

Hi all,

 

I'm new to the site and new to SCCM (essentially a desktop support guy with an opportunity to learn network admin).

I'm trying Matt160's advice...

Got it! I unselected all Classisfications in SUP, ran wsusutil reset, ran another sync, re-added Classifications, and the flood gates opened.

 

.....to solve the prob, and can do most but i'm stuggling on how 'ran another sync' works. Is this though right click tools?

 

Thanks all.

Share this post


Link to post
Share on other sites

I am having the same issue but just recently. SCCM 2012 sp1, running on Server 2008 R2, WSUS version 3.0 SP2 3.2.7600.226. I have 3 updates with download errors of the Microsoft Software License Terms, all others are good. I have done the suggested fix un-selected SUP classifications, ran wsusutil reset, manual sync, which did timeout, selected SUP classifications, ran manual sync and still same results. So with the failed sync my SUP is syncing every hour instead of on the configured schedule. My SCCM server has been up since Oct. 2012,

 

Prior to running wsusutil reset Event viewer error

Source - SMS Server

WSUS Synchronization failed. Message: WSUS server not configured. Please refer to WCM.log for configuration error details..Source: CWSyncMgr::DoSync.The operating system reported error 2147500037: Unspecified error

 

After the reset Event viewer error

Source - SMS server

WSUS Synchronization failed.
Message: Failed to sync some of the updates.
Source: Microsoft.SystemsManagementServer.SoftwareUpdatesManagement.WsusSyncAction.WSyncAction.SyncUpdates.
The operating system reported error 2148734208:
Source - Windows Server Update Services
Content file download failed. Reason: HTTP status 401: The requested resource requires user authentication.
Source File: /msdownload/update/v5/eula.......
So progress but not resolved. A side note, I had been off for a few weeks and upon returning I found that the C drive was almost full, I found over 19 GB of logs in C:\inetpub\logs\LogFiles\W3SVC1 & W3SVC388031976. I deleted all older than 6 months. So WSUS services had all sorts of errors along with other services in the event viewer about the low disk space. The server has 2 drives, the WSUS content folders reside on a second drive which has over 20 GB of free space.
I have read about some issues with Server 2012 requiring a patch of WSUS to fix a similar issue, could there be a patch for 2008 R2 as well?

 

 

Ive been investigating in to this issue. Not sure if anyone had a resolve to your specific issue but my environment was showing very similar symptoms.

 

To resolve, start with matt160's suggestion, then mine below:

 

matt160, on 19 Feb 2013 - 6:50 PM, said:snapback.png

Got it! I unselected all Classisfications in SUP, ran wsusutil reset, ran another sync, re-added Classifications, and the flood gates opened.

 

...............then from your wsyncmgr.log locate the failed patches (mine)

 

Update 67856245-12e4-4b31-8e96-5ff01bc42741 not synced due to pending EULA download
Update 69dbc468-a036-4dfc-af8c-10367a212b5e not synced due to pending EULA download
Update bbac09b6-ea87-455f-9161-261354d9120b not synced due to pending EULA download

Log on to the WSUS server

Search for the EULA updates (mentioned above)

Approve the Updates

On the 1st patch approval I received a MS EULA to accept <click accept>. The consecutive updates did not.

Re-run another synch

100% completed

 

Hope this helps the avid few!

Edited by Tango

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...