Jump to content


Sign in to follow this  
stevehoot

SCCM 2012: OSD puts Windows on drive D. Variable works but breaks the CCM client!

Recommended Posts

Hi Guys,

 

Following the tutorial documentation done (very good by the way - thank you!), in particular around SCCM 2012 SP1 for OSD's.

 

Followed the guide, built and captured my image, all working well. However if I try to deploy the image I captured (via the build and capture process) then I end up with a working system but have the system partition on D: rather than C:.

 

I understand this is a common issue, and is to do with the original media being built in a particular way. (Although I used the only Win7 Enterprise ISO on our volume licence website, build and capture to make it and then deployed using a standard deploy task....)

Workaround seems to be to use OSDPreserveDriveLetter as a variable, which does the trick fine. Problem is that whilst the system is then set to use C:, the CM agent doesn't work. Fails to find a site (even if I specify it manually). If I remove the OSDPreserveDriveLetter variable then the client installs fine, life is good but I have Windows on D:\.

 

 

SMSTS shows:

<![LOG[==========[ TsProgressUI started in process 1344 ]==========]LOG]!><time="17:28:28.908+00" date="03-19-2013" component="TsProgressUI" context="" type="1" thread="1340" file="winmain.cpp:330">
<![LOG[Registering COM classes]LOG]!><time="17:28:28.908+00" date="03-19-2013" component="TsProgressUI" context="" type="1" thread="1340" file="winmain.cpp:187">
<![LOG[sbModulePath = C:\WINDOWS\system32\_SMSOSDSetup\TsProgressUI.exe]LOG]!><time="17:28:28.908+00" date="03-19-2013" component="TsProgressUI" context="" type="1" thread="1340" file="tsprogressuiclass.cpp:625">
<![LOG[shutdown complete.]LOG]!><time="17:28:28.940+00" date="03-19-2013" component="TsProgressUI" context="" type="1" thread="1340" file="winmain.cpp:512">
<![LOG[Process completed with exit code 0]LOG]!><time="17:28:28.955+00" date="03-19-2013" component="OSDSetupHook" context="" type="1" thread="1624" file="commandline.cpp:1123">
<![LOG[successfully registered TS Progress UI.]LOG]!><time="17:28:28.955+00" date="03-19-2013" component="OSDSetupHook" context="" type="1" thread="1624" file="utils.cpp:2279">
<![LOG[Executing command line: "C:\_SMSTaskSequence\OSD\00100010\ccmsetup.exe" /useronly /source:C:\_SMSTaskSequence\OSD\00100010 /config:MobileClient.TCF /status:584]LOG]!><time="17:28:29.283+00" date="03-19-2013" component="OSDSetupHook" context="" type="1" thread="1624" file="commandline.cpp:827">
<![LOG[Process completed with exit code 1]LOG]!><time="17:32:46.643+00" date="03-19-2013" component="OSDSetupHook" context="" type="1" thread="1624" file="commandline.cpp:1123">
<![LOG[Client installation failed, code 1]LOG]!><time="17:32:46.643+00" date="03-19-2013" component="OSDSetupHook" context="" type="3" thread="1624" file="installclient.cpp:1151">
<![LOG[set authenticator in transport]LOG]!><time="17:32:46.659+00" date="03-19-2013" component="OSDSetupHook" context="" type="0" thread="1624" file="libsmsmessaging.cpp:7751">
<![LOG[Non fatal error 0x80070057 in sending task sequence execution status message to MP]LOG]!><time="17:32:46.768+00" date="03-19-2013" component="OSDSetupHook" context="" type="2" thread="1624" file="utils.cpp:5811">
<![LOG[set authenticator in transport]LOG]!><time="17:32:46.783+00" date="03-19-2013" component="OSDSetupHook" context="" type="0" thread="1624" file="libsmsmessaging.cpp:7751">
<![LOG[Non fatal error 0x80070057 in sending task sequence execution status message to MP]LOG]!><time="17:32:46.799+00" date="03-19-2013" component="OSDSetupHook" context="" type="2" thread="1624" file="utils.cpp:5811">
<![LOG[Executing command line: "C:\WINDOWS\system32\_SMSOSDSetup\TsProgressUI.exe" /Unregister]LOG]!><time="17:32:47.811+00" date="03-19-2013" component="OSDSetupHook" context="" type="1" thread="1624" file="commandline.cpp:827">
<![LOG[==========[ TsProgressUI started in process 1848 ]==========]LOG]!><time="17:32:47.811+00" date="03-19-2013" component="TsProgressUI" context="" type="1" thread="2964" file="winmain.cpp:330">
<![LOG[unregistering COM classes]LOG]!><time="17:32:47.811+00" date="03-19-2013" component="TsProgressUI" context="" type="1" thread="2964" file="winmain.cpp:204">
<![LOG[shutdown complete.]LOG]!><time="17:32:47.811+00" date="03-19-2013" component="TsProgressUI" context="" type="1" thread="2964" file="winmain.cpp:512">
<![LOG[Process completed with exit code 0]LOG]!><time="17:32:47.811+00" date="03-19-2013" component="OSDSetupHook" context="" type="1" thread="1624" file="commandline.cpp:1123">
<![LOG[successfully unregistered TS Progress UI.]LOG]!><time="17:32:47.811+00" date="03-19-2013" component="OSDSetupHook" context="" type="1" thread="1624" file="utils.cpp:2320">
<![LOG[Failed to install SMS Client (0x80004005)]LOG]!><time="17:32:47.811+00" date="03-19-2013" component="OSDSetupHook" context="" type="3" thread="1624" file="basesetuphook.cpp:1476">
<![LOG[uninstalling Setup Hook]LOG]!><time="17:32:47.826+00" date="03-19-2013" component="OSDSetupHook" context="" type="1" thread="1624" file="basesetuphook.cpp:1566">
<![LOG[Removing setup hook from registry.]LOG]!><time="17:32:47.826+00" date="03-19-2013" component="OSDSetupHook" context="" type="0" thread="1624" file="vistasetuphook.cpp:143">
<![LOG[successfully removed C:\WINDOWS\system32\OSDGINA.DLL]LOG]!><time="17:32:47.826+00" date="03-19-2013" component="OSDSetupHook" context="" type="1" thread="1624" file="basesetuphook.cpp:1312">
<![LOG[successfully removed C:\WINDOWS\system32\OSDSETUPHOOK.EXE]LOG]!><time="17:32:47.826+00" date="03-19-2013" component="OSDSetupHook" context="" type="1" thread="1624" file="basesetuphook.cpp:1312">
<![LOG[successfully removed C:\WINDOWS\system32\_SMSOSDSetup]LOG]!><time="17:32:47.826+00" date="03-19-2013" component="OSDSetupHook" context="" type="1" thread="1624" file="basesetuphook.cpp:1349">
<![LOG[RegQueryValueExW failed for Software\Microsoft\SMS\Task Sequence, SMSTSEndProgram]LOG]!><time="17:32:47.857+00" date="03-19-2013" component="OSDSetupHook" context="" type="2" thread="1624" file="utils.cpp:261">
<![LOG[GetTsRegValue() failed. 0x80070002.]LOG]!><time="17:32:47.857+00" date="03-19-2013" component="OSDSetupHook" context="" type="2" thread="1624" file="utils.cpp:279">
<![LOG[End program: ]LOG]!><time="17:32:47.857+00" date="03-19-2013" component="OSDSetupHook" context="" type="1" thread="1624" file="basesetuphook.cpp:1580">
<![LOG[successfully finalized logs to SMS client log directory from C:\WINDOWS\CCM\Logs]LOG]!><time="17:32:47.857+00" date="03-19-2013" component="OSDSetupHook" context="" type="1" thread="1624" file="tslogging.cpp:1542">
<![LOG[Cleaning up task sequence folder]LOG]!><time="17:32:47.857+00" date="03-19-2013" component="OSDSetupHook" context="" type="1" thread="1624" file="utils.cpp:1746">
<![LOG[Deleting volume ID file C:\_SMSTSVolumeID.7159644d-f741-45d5-ab29-0ad8aa4771ca ...]LOG]!><time="17:32:48.542+00" date="03-19-2013" component="OSDSetupHook" context="" type="1" thread="1624" file="resolvesource.cpp:519">
<![LOG[Failed to execute task sequence (0x80004005)]LOG]!><time="17:32:48.542+00" date="03-19-2013" component="OSDSetupHook" context="" type="3" thread="1624" file="osdsetuphook.cpp:284">



 

 

The CCMSetup.log file doesn't appear to be much help, but I have attached it to the post along with Client.msi.log.

 

Any suggestions or help would be appreciated. Happy to completely rebuild the image file but obviously I'm doing something wrong. As above, I imported from our volume licence Win7 Ent with SP1 media into SCCM, used it on a build and capture, then imported the captured .WIM into SCCM and finally did a deployment with the newly captured image.


As logical as that seems, obviously it's not quite right, and trying the workaround of the OSDDriveLetter seems to break my SCCM client install done as part of the task sequence.

 

Thanks in advanced guys!

 

 

Steve

CCMSetup.txt

Client.msi.txt

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...