Jump to content


SCCM 2012 SP1 Reporting Services Server Instance is Blank

Recommended Posts

I'm tryin to setup the report services point site system role on my SCCM 2012 SP1 primary site. However when I get the configuring the settings the "Reporting Services server instance" is blank, and I'm not able enter anything inside that box. I verified my reporting services configuration manager that report server is setup properly. I see other threads posting similar issues but many of them has to do with SQL 2008.


Current SCCM 2012 SP1 configuration is below....


Primary Site Server: SCCM 2012 SP1


SQL Server(separate remote server) SQL Server 2012 CU2


***SMSAdmin Account has local admin rights on the sql server***







Share this post

Link to post
Share on other sites

Check to see if you have to install any service packs for the SQL instance. I had the same problem and I had to reinstall the SQL service pack onto the Database Instance. This is a protection feature of Microsoft even if you upgrade the whole server you will need to re-install the service pack on the actual database instance for Reporting Services possibly.

Share this post

Link to post
Share on other sites

Running into a similar problem when trying to add a Reporting services point. SCCM 2012 SP1, SQL 2012 CU7 (have also tried CU2-CU6). One physical server used as a stand-alone Primary site. Report instance is blank - here is what I've tried.


SRS info - running as local system

IP address - All assigned



database running with domain admin creds



* Uninstalling and re installing SRS 2012

* Installing as a separate instance

* Uninstalling and re installing SQL 2012

* HKLM>software>microsoft>microsoft sql server>instance names>rs>shows current reportingservices instance

* Tried renaming SRS virtual directory and renaming them back

Share this post

Link to post
Share on other sites

UPDATE: A Microsoft case was opened for this issue after trying many different avenues found online (see last post on this thread). After having Microsoft SCCM and SQL teams review settings, configs and installations, current environment and system logs. They were unable to resolve my issue, they say they've never experienced this issue before (I'm skeptical). Because this was for PROD time was critical so it was faster for me to re-format everything and rebuild. Instead of using the 2012 OS and SQL, I took a step back and used 2008 R2 SP1 OS and 2008 R2 SP2 CU6 - working like a charm now.

Share this post

Link to post
Share on other sites

This is due to the fact that reporting services has not been properly configured. The answer to this solution is actually very simple. I have encountered the same issue and could solve it following this procedure http://myitforum.com/myitforumwp/2012/10/10/reporting-services-site-role-setup-instance-blankempty/


Have fun ! :)


This worked for me :)

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.