Jump to content


abhi1411

Enable PXE for SCCM 2012

Recommended Posts

Hi,

 

I have SCCM 2012 installed in my environment, I had configured distrubution point on same SCCM server. I had captured an image by using MDT2012 and uploaded the same to SCCM 2012 server. Created the Task sequence and published on the new collection.

 

Now I had made 1 new system a member of that collection by using import computer option. Now I am trying to pxe boot new system. but getting PXE-E53 error message. My DHCP server is installed on different server. Please suggest what i need to do, do i need to configure DHCP server scope for enabling PXE boot or something else is required.

Share this post


Link to post
Share on other sites


Hi,

 

I have SCCM 2012 installed in my environment, I had configured distrubution point on same SCCM server. I had captured an image by using MDT2012 and uploaded the same to SCCM 2012 server. Created the Task sequence and published on the new collection.

 

Now I had made 1 new system a member of that collection by using import computer option. Now I am trying to pxe boot new system. but getting PXE-E53 error message. My DHCP server is installed on different server. Please suggest what i need to do, do i need to configure DHCP server scope for enabling PXE boot or something else is required.

 

Hi. While the smarter guys are still working / sleeping I hope I can push you to the right direction by giving best guesses.

 

Edit 2. I assume that

  • in SCCM you have in the DP's properties enabled PXE and that
  • SCCM has thus also installed and configured WDS role on your server and that
  • you have distributed the boot images with the checkbox "Deploy this boot image from the PXE service point" and that
  • there actually are some boot files automatically created into SCCMSERVER\RemInst\SMSBoot\x86 and \x64 (Edit 3: fixed the folder name...)
  • For source, as I can't find a Windows Noob tutorial right now, see for example this or this, or

Ok then. I think that you need to configure your DHCP to tell this PXE client (or all PXE clients in a certain network) that the PXE server's IP is your SCCM2012/WDS-server's IP and that the boot files can be found in "SMSboot\x86\wdsnbp.com". But I don't know DHCP enough to tell you technically the steps that this requires.

 

Edit 1: It has something to do with DHCP option 66 (boot server host name) & DHCP option 67 (boot file name).

 

 

Cheers!

 

-MPT-

  • Like 1

Share this post


Link to post
Share on other sites

Edit 1: It has something to do with DHCP option 66 (boot server host name) & DHCP option 67 (boot file name).

 

 

This is correct. Option 66 should be the FQDN of your PXE/DP server and option 67 is the location of the bootfiles.

How ever if your DHCP server is residing on a seperate server than that of your PXE/DP and also the whole network is on the standard default VLAN then there should be no need to configure these options.

 

If your network has more than one VLAN then you will have to configure these options along with IP Helpers/DHCP relays, network engineers should point you in the right path as to what extra configurations other than the basic DHCP options are needed to be specified in the ACLs'.

Share this post


Link to post
Share on other sites

Hi,

I would recommend that you only configure IP Helpers and NOT any DHCP options, so your IP helpers are pointing to both your DHCP server and your PXE server, then you will have a dynamic solution. Configuring DHCP options is not relay support by MS and it is not best practice and configuring both is not needed at all.

 

Regards,
Jörgen

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...