Jump to content

  • 0

WMI Query returns "Lenovo Product" as ThinkCentre's model




Edit 5. I have created the same thread at forums.lenovo.com as they may have more insight into this matter.


Anyway, it seems that my ThinkCentre has forgotten who he is.


I have a ThinkCentre M72e (3267-BZ5). I deployed Win7 ENT x64 and tried to install driver packages with conditions. I have googled quite a bit and most sites seem to say the same. "Lenovo has a little bit different way of storing model type, it can be found in Win32_ComputerSystemProduct.Version...


But those conditions failed, none were matched. After I got the target computer up and running, I checked and the computer has the following property values in Win32_ComputerSystemProduct:

Win32_ComputerSystemProduct.Version="Lenovo Computer"

All other properties in Win32_ComputerSystemProduct are NULL


Additonal info:

For now I did not copy all the ThinkCentre drivers into my driver store but only those that were needed because Windows 7 media would not identify those devices. So some chipset drivers may be windows generic and not from the manufacturers.


BUT after the OSD I have

- installed Lenovo software and updated all drivers and rebooted - no change

- updated BIOS also (chose NOT to manually update the model name - no change


and the WMI query still returns the same result as above.


I am a little lost at where to go next, as in my mind this information should be somewhere in the computer hardware?





Share this post

Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

This happened to me once while running the BIOS update with the wrong options. Had the same effect, that the version field was filled with "lenovo product". The field service replaced the mainboard for this machine, which was less expensive and less stress than discussing the problem with lenovo support.




Share this post

Link to post
Share on other sites

  • 0


I agree with Peter, the only scenario I have seen this is when a field engiener reaplced the mainboard in the computer and didn't set the properties when he did so..

Are you seeing this on more than one computer?



Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...