Jump to content


arr0ww

Software Updates - Stuck at Downloading (0% complete)

Recommended Posts

Hi Guys,

 

Recently my updates stopped being able to be downloaded by the clients. They all sit at 0% Complete and will not download the content. My OSD and Applications Deployment work 100%.

 

I cannot find any SCCM errors on the server or the client, I can only find the following in my IIS logs:

 

2013-06-20 16:53:37 10.10.116.204 PROPFIND /SMS_DP_SMSPKG$/9bbbd8f2-72e2-4a58-acae-dcc3715715f2 - 80 - 10.10.116.69 SMS+CCM+5.0 - 404 0 0 2
2013-06-20 16:53:37 10.10.116.204 PROPFIND /SMS_DP_SMSPKG$/3e474f15-a3d3-4139-8ce2-f6e0b59bd450 - 80 - 10.10.116.69 SMS+CCM+5.0 - 404 0 0 3
2013-06-20 16:53:37 10.10.116.204 PROPFIND /SMS_DP_SMSPKG$/287ac60f-34a5-4177-9862-000c29ae592c - 80 - 10.10.116.69 SMS+CCM+5.0 - 404 0 0 6
2013-06-20 16:53:37 10.10.116.204 PROPFIND /SMS_DP_SMSPKG$/3ce40413-5c19-44e4-8e9f-7d520e1f649c - 80 - 10.10.116.69 SMS+CCM+5.0 - 404 0 0 5
2013-06-20 16:53:37 10.10.116.204 PROPFIND /SMS_DP_SMSPKG$/421ccb65-9806-4593-a15d-09bfe6aa20fb - 80 - 10.10.116.69 SMS+CCM+5.0 - 404 0 0 3
This seems to be telling me that the content is not found. I have verified that the content is in the SCCMContentLib/DataLib, and it's also been downloaded in my Sources folder for my Update Groups.
I am guessing there is something funny with IIS?? Can anyone help? I'm pretty stuck.
Thanks!

Share this post


Link to post
Share on other sites

Restarted IIS multiple times.

 

Found some errors in DataTransferService.log

 

Successfully sent location services HTTP failure message. DataTransferService 6/20/2013 2:43:43 PM 7948 (0x1F0C)
Error sending DAV request. HTTP code 404, status 'Not Found' DataTransferService 6/20/2013 2:43:43 PM 7948 (0x1F0C)
GetDirectoryList_HTTP('http://AM8.twu.ca:80/SMS_DP_SMSPKG$/Content_7dbb8176-ab2e-4d02-b5db-c27814435dff.1') failed with code 0x87d0027e. DataTransferService 6/20/2013 2:43:43 PM 7948 (0x1F0C)
Non-recoverable error retrieving manifest (0x87d0027e). DataTransferService 6/20/2013 2:43:43 PM 7948 (0x1F0C)
Here you can see that my content has "supposedly" been distributed properly in DIstmg.log
Start updating the package on server ["Display=\\AM8.twu.ca\"]MSWNET:["SMS_SITE=P01"]\\AM8.twu.ca\... SMS_DISTRIBUTION_MANAGER 6/20/2013 2:53:30 PM 7080 (0x1BA8)
Will wait for 1 threads to end. SMS_DISTRIBUTION_MANAGER 6/20/2013 2:53:30 PM 7080 (0x1BA8)
Thread Handle = 00000000000019C4 SMS_DISTRIBUTION_MANAGER 6/20/2013 2:53:30 PM 7080 (0x1BA8)
Attempting to add or update a package on a distribution point. SMS_DISTRIBUTION_MANAGER 6/20/2013 2:53:30 PM 4836 (0x12E4)
The distribution point is on the siteserver and the package is a content type package. There is nothing to be copied over. SMS_DISTRIBUTION_MANAGER 6/20/2013 2:53:30 PM 4836 (0x12E4)
STATMSG: ID=2342 SEV=I LEV=M SOURCE="SMS Server" COMP="SMS_DISTRIBUTION_MANAGER" SYS=AM8.twu.ca SITE=P01 PID=1876 TID=4836 GMTDATE=Thu Jun 20 21:53:30.699 2013 ISTR0="Mozilla Firefox (en-US)" ISTR1="["Display=\\AM8.twu.ca\"]MSWNET:["SMS_SITE=P01"]\\AM8.twu.ca\" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=2 AID0=400 AVAL0="P0100056" AID1=404 AVAL1="["Display=\\AM8.twu.ca\"]MSWNET:["SMS_SITE=P01"]\\AM8.twu.ca\" SMS_DISTRIBUTION_MANAGER 6/20/2013 2:53:30 PM 4836 (0x12E4)
The current user context will be used for connecting to ["Display=\\AM8.twu.ca\"]MSWNET:["SMS_SITE=P01"]\\AM8.twu.ca\. SMS_DISTRIBUTION_MANAGER 6/20/2013 2:53:31 PM 4836 (0x12E4)
No network connection is needed to ["Display=\\AM8.twu.ca\"]MSWNET:["SMS_SITE=P01"]\\AM8.twu.ca\ as this is the local machine. SMS_DISTRIBUTION_MANAGER 6/20/2013 2:53:31 PM 4836 (0x12E4)
CreateSignatureShare, connecting to DP SMS_DISTRIBUTION_MANAGER 6/20/2013 2:53:31 PM 4836 (0x12E4)
Signature share exists on distribution point path \\AM8.twu.ca\SMSSIG$ SMS_DISTRIBUTION_MANAGER 6/20/2013 2:53:31 PM 4836 (0x12E4)
Set share security on share \\AM8.twu.ca\SMSSIG$ SMS_DISTRIBUTION_MANAGER 6/20/2013 2:53:31 PM 4836 (0x12E4)
Share SMSPKGD$ exists on distribution point \\AM8.twu.ca\SMSPKGD$ SMS_DISTRIBUTION_MANAGER 6/20/2013 2:53:31 PM 4836 (0x12E4)
Set share security on share \\AM8.twu.ca\SMSPKGD$ SMS_DISTRIBUTION_MANAGER 6/20/2013 2:53:31 PM 4836 (0x12E4)
Creating, reading and or updating Operations Management server role registry keys for a Distribution Point ... SMS_DISTRIBUTION_MANAGER 6/20/2013 2:53:31 PM 4836 (0x12E4)
Set share security on share \\AM8.twu.ca\SCCMContentLib$ SMS_DISTRIBUTION_MANAGER 6/20/2013 2:53:31 PM 4836 (0x12E4)
Set share security on share \\AM8.twu.ca\SCCMContentLib$ SMS_DISTRIBUTION_MANAGER 6/20/2013 2:53:31 PM 4836 (0x12E4)
Copying content signatures for package P0100056 SMS_DISTRIBUTION_MANAGER 6/20/2013 2:53:31 PM 4836 (0x12E4)
Setting permissions on file MSWNET:["SMS_SITE=P01"]\\AM8.twu.ca\SMSSIG$\Content_7dbb8176-ab2e-4d02-b5db-c27814435dff.1.tar. SMS_DISTRIBUTION_MANAGER 6/20/2013 2:53:31 PM 4836 (0x12E4)
STATMSG: ID=2303 SEV=I LEV=M SOURCE="SMS Server" COMP="SMS_DISTRIBUTION_MANAGER" SYS=AM8.twu.ca SITE=P01 PID=1876 TID=4836 GMTDATE=Thu Jun 20 21:53:31.464 2013 ISTR0="P0100056" ISTR1="["Display=\\AM8.twu.ca\"]MSWNET:["SMS_SITE=P01"]\\AM8.twu.ca\" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=2 AID0=400 AVAL0="P0100056" AID1=404 AVAL1="["Display=\\AM8.twu.ca\"]MSWNET:["SMS_SITE=P01"]\\AM8.twu.ca\" SMS_DISTRIBUTION_MANAGER 6/20/2013 2:53:31 PM 4836 (0x12E4)
Successfully created/updated the package server in the data source SMS_DISTRIBUTION_MANAGER 6/20/2013 2:53:31 PM 4836 (0x12E4)
Performing cleanup prior to returning. SMS_DISTRIBUTION_MANAGER 6/20/2013 2:53:31 PM 4836 (0x12E4)
DP thread with array index 0 ended. SMS_DISTRIBUTION_MANAGER 6/20/2013 2:53:31 PM 7080 (0x1BA8)
DP thread with thread handle 00000000000019C4 and thread ID 4836 ended. SMS_DISTRIBUTION_MANAGER 6/20/2013 2:53:31 PM 7080 (0x1BA8)
Package P0100056 does not have a preferred sender. SMS_DISTRIBUTION_MANAGER 6/20/2013 2:53:31 PM 7080 (0x1BA8)
Package P0100056 is new or has changed, replicating to all applicable sites. SMS_DISTRIBUTION_MANAGER 6/20/2013 2:53:31 PM 7080 (0x1BA8)
CDistributionSrcSQL::UpdateAvailableVersion PackageID=P0100056, Version=1, Status=2301 SMS_DISTRIBUTION_MANAGER 6/20/2013 2:53:31 PM 7080 (0x1BA8)
StoredPkgVersion (1) of package P0100056. StoredPkgVersion in database is 1. SMS_DISTRIBUTION_MANAGER 6/20/2013 2:53:31 PM 7080 (0x1BA8)
SourceVersion (1) of package P0100056. SourceVersion in database is 1. SMS_DISTRIBUTION_MANAGER 6/20/2013 2:53:31 PM 7080 (0x1BA8)
STATMSG: ID=2301 SEV=I LEV=M SOURCE="SMS Server" COMP="SMS_DISTRIBUTION_MANAGER" SYS=AM8.twu.ca SITE=P01 PID=1876 TID=7080 GMTDATE=Thu Jun 20 21:53:32.014 2013 ISTR0="Mozilla Firefox (en-US)" ISTR1="P0100056" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=1 AID0=400 AVAL0="P0100056" SMS_DISTRIBUTION_MANAGER 6/20/2013 2:53:32 PM 7080 (0x1BA8)
Exiting package processing thread. SMS_DISTRIBUTION_MANAGER 6/20/2013 2:53:32 PM 7080 (0x1BA8)

Share this post


Link to post
Share on other sites

I have a similar issue with EndPoint Protection definition updates that run every 8 hours via an ADR tied to my Software Update Point sync schedule which is set for 8 hours. I look at the distmgr.log and the package is successfully processed, but about 50% of clients show "Calling back with empty distribution points list" when they are looking for the package. If I perform and "Update Content" for the EndPoint Protection package, they all pick up the location and install the updates within the hour. Not sure what this is all about. It doesn't even happen all the time. Usually my morning Definition Update causes the most problems and runs at 5:30am.

Share this post


Link to post
Share on other sites

Sorry to bump an old post, but I wanted to share my solution to this same issue. While the solutions above didn't resolve my problem, it sure helped me find it!

 

I recently had a handful of users report that a single software update was stuck deploying. It was hanging at the 0% downloaded phase. I couldn't really find any errors, but that may just be me looking in the wrong log.

 

Anyway -- back in the sccm console, I did a quick search for software updates. I looked for everything that was deployed but not downloaded, and guess what I found -- this update was the only one that met my query.

 

Apparently the download never happened but the update was deployed. When the clients tried to download the file, it didn't have anything to download!

  • Like 1

Share this post


Link to post
Share on other sites

Sorry to bump an old post, but I wanted to share my solution to this same issue. While the solutions above didn't resolve my problem, it sure helped me find it!

 

I recently had a handful of users report that a single software update was stuck deploying. It was hanging at the 0% downloaded phase. I couldn't really find any errors, but that may just be me looking in the wrong log.

 

Anyway -- back in the sccm console, I did a quick search for software updates. I looked for everything that was deployed but not downloaded, and guess what I found -- this update was the only one that met my query.

 

Apparently the download never happened but the update was deployed. When the clients tried to download the file, it didn't have anything to download!

heh, i ran into the same situation in my test lab. :-) simple mistake caused hours of troubleshooting!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...


×
×
  • Create New...