Jump to content


Following SP1 Upgrade, SCCM 2012 would not install deployed software

Recommended Posts

Hi Guys,


I just wanted to share what I had learned following my SP1 upgrade.

I have been quite lucky with my upgrade, as it seemed that nothing went wrong, and all is working...Until...


I thought I would test the Software Distribution as following my SP1 upgrade, yesterday, I hadn't had a chance.


So, I have a Windows 7 SP1 and Windows XP SP3 PC, both running the SCCM SP1 clients.


When I opened the Software Center, everything looked fine. Things were actually a little better than before. I chose to install a program as a test (in this instance, both Visio Viewer and VLC Player (one is MSI other EXE).

When I did, I recieved the error:


(Not my image, from: http://weikingteh.files.wordpress.com/. I didn't screen shot mine sadly, exactly the same though!).


Obviously, I was a little disgruntled.

I then decided to check the Application Calatlogue through Software Center. All seemed okay there too, so I decided to try and install from there. Firefox this time.

Nope. Wouldn't let me. Another error exactly the same as this one. (No screenshot again. I wasn't ready to start posting about it, so I didn't take any lol).


Anyway, through a bit of research, I found that I had to change the following, and they both worked:


Firstly, for the Software Center error, I went in to the applications, removed the quotes from around the command line (which SCCM added on it's own in the first place).

Secondly, I went in to my Client Settings for the whole site (the Default Device Settings as Anyweb puts it in his guide), and changed the Computer Agent "Default Application website point" to a custom URL:






I changed it to add the port number in.


So rather than:



It is now:



Following those changes, I am now able install and deploy applications just like before, with no errors at all. And speed has increased too, but that's down to SP1 I think lol.


Anyway, I hope this helps, and I hope it wasn't just me that this fixed the error for!




Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.