Jump to content


jrekkedal

Task Sequence failed 0x80004005 - Build and Capture

Recommended Posts

I am at my wits end on troubleshooting this issue. I am trying to do a simple build and capture of Windows 7 SP1 x64 and can't seem to install even one application (let alone get to the part where I can install updates).

 

If this is a simple deploy/build of a workstation that joins the domain then the applications install without any problem at all; however, I really want to build/capture that doesn't require me to join the domain then join a workgroup just to prep the OS/install apps.

 

I am running SCCM 2012 SP1 CU3 on my server with is pulling the duty of a DP, MP and a host of others.

 

The task sequence was built using the wizard, so nothing too outrageous there. The sequence goes normally and IMMEDIATELY bombs out when it gets to "Install Applications".

 

Things I have checked/verified already:

  • The application does have the checkbox enabled for "Allow this application to be installed from the ...."
  • Boundary is setup for the machine I am working on via an IP address range that covers my entire subnet.
  • Checked that SMSMP=myserver.mydomain.com is set for my Management Point in the TS for "Setup Windows and Configuration Manager"
  • I read a blog posting that mentioned installing a hotfix in the task sequence, rebooting and then it should work, but I get the same error even on a package.
  • My Network Access Account does have permissions to the applications share (I even temporarily changed it to my own account as I am a domain admin)

Checking in my smsts.log file doesn't yield much either (I'll post it later because I want to completely delete SCCM from my server/memory over this), but I at least wanted to get a thread going to see if anyone had any other ideas to check?

Share this post


Link to post
Share on other sites

I've seen something about Norton anti virus when I Google it. Are you running that?

 

Also, I've had random errors like this if the RAM has been faulty, or even from a funny DVD drive. I change the RAM and unplugged the DVD drive and it worked fine sometimes for me in the past.

Share this post


Link to post
Share on other sites

In my experience, the 0x80004005 message means that it cannot find/access the content. So you need to check the drivers NIC on the client side, and the access permissions & DP setup (boundaries etc.) on the server side. It looks like you've checked most of this already. See if you can ping the DP from the client when it gets to the failure point.

Share this post


Link to post
Share on other sites

It looks like I finally figured it out as an application successfully installed and I'm watching the image capture as I write this. I'm doing my part in making sure I update the thread so in the case some other poor soul finds his/her way here they might get an answer faster than I did.

 

I did some research over the weekend (i.e. Google) and start broadening my search terms a bit from failing to run applications to also Software Updates. Long story short, on the Distribution point Properties page (Administration > Site Configuration > Servers and Site System Roles > Highlight the DP > Right-click DP role > Properties) you need to check the box "Allow clients to connect anonymously" on the General tab in order for things to fully work. I'm guessing this is because a workgroup machine not only uses the NAA, but the DP has to also be prepared to get requests from anonymous machines.

 

Granted, that sounds like a no-brainer but I never found that setting in any of the guides posted on this site, or others, so it was a lucky hit as far as I am concerned.

 

Thanks to conorofarrell and Edenost for the replies as I know taking time out of your day for a random forum posting can be a big deal.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...


×
×
  • Create New...