Jump to content


Sign in to follow this  
Ronvanloo

Slow App-v package installation within Software Center

Recommended Posts

Hello

We have a strange problem at our SCCM 2012 CB 1806 ( for Windows 10 clients) environment.
The SCCM server hosts a lot of App-V packages and a user can install these App-v packages using Software Center on a client device.
The problem is the delay before the installation is ready. Sometime I have to wait voor almost 4 minutes.
When we install the same package on our "older" SCCM 2012 R2 Sp1 (for Windows 8.1 clients) environment there is no delay. Within 5 secondes te installation is ready and application can start.

The steps I did to solve the problem so far:

- Update the App-v anti malware exclusions.
- Uninstall all software on the endpoint, like SAP, AppSense\Ivanti etc.
- Move the device to an OU in AD so no policy is active.
- Disable Windows defender.

None of these steps did solve the delay.

When Ik look at the AppEnforce.log I see the Powershel commands executing without any error but with a delay. The only command which has no delay is the Publish-Appvclientpackage.

I also used Powershell and entered the Powershell commands for installing and publish a App-V package. Then there is no delay at all. App-V packages install within 5 secondes.
But when I use Software Center to install the same App-v package I have to wait almost 4 minutes.
I tested this with several App-V packages. App-v packages created on a Windows 8.1 sequencer or App-v packages created on a Windows 10 sequencer. There is no difference.

Installing an MSI package within Software Center had no delay.

So at the moment I have no clue what is causing this problem.
 

Regards,

Ron

 

Share this post


Link to post
Share on other sites


We found the solution.

In SCCM 1806 CB there is a new feature you can adjust.

Go to Administration  - Hierarchy Configuration - Boundary Groups

Open a boundary group and go to the tab Options

We unchecked the "allow peer......." checkbox

After this all App-v packages streamed very fast.

 

The explination of this is that we use the App-V packages in stream mode.

But when you enable this option a workspace will look for all other workspaces who installed the package. So it tries to install the package form another workspace instead of the SCCM DP.

Because we stream a App-v package there is no packages at de local cache to install. So there the waiting begins. 

When you monitor the VirtualApp.log on the workspace you can see alle the other workspaces it tries to communicate with. I think this is a bug because if you are using App-v in streaming mode this option should be unmarked by default.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...