Jump to content


Recommended Posts

Hey Guys,

 

I have image a few hundred machine with SCCM and some are unable to use and plug and play devices like USB's

 

the event logs say

 

The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID
{05D1D5D8-18D1-4B83-85ED-A0F99D53C885}
and APPID

{AD65A69D-3831-40D7-9629-9B0B50A93843}

to the user NT AUTHORITY\SYSTEM SID (S-1-5-18) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.

 

Any Ideas?

Share this post


Link to post
Share on other sites

Hey Guys,

 

I have image a few hundred machine with SCCM and some are unable to use and plug and play devices like USB's

 

the event logs say

 

The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID

{05D1D5D8-18D1-4B83-85ED-A0F99D53C885}

and APPID

{AD65A69D-3831-40D7-9629-9B0B50A93843}

to the user NT AUTHORITY\SYSTEM SID (S-1-5-18) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.

 

Any Ideas?

I see the same issue on some of my systems too. No idea why. Did you ever find out anything on this?

Share this post


Link to post
Share on other sites

Not sure if it's an SCCM problem. I found this here: http://social.technet.microsoft.com/Forums/systemcenter/en-US/dfc465bc-7bbd-483e-b98b-2ba56fa98313/the-applicationspecific-permission-settings-do-not-grant-local-launch-permission-for-the-com-server

 

(I have modified it slightly to included the App ID in the error you provided:

 

1. Click Start -> Run -> Type -> dcomcnfg, expand Component Services -> Computers -> My Computer -> DCOM Config.
2. Click View -> Detail -> Now you will get Application Name and Application ID in right side.
3. Scroll down and find the application ID {AD65A69D-3831-40D7-9629-9B0B50A93843} -> Right Click -> Properties and select the Security tab.
3. Click Customize under "Launch & Activation Permission" -> click Edit -> Add in the account NT AUTHORITY\SYSTEM and set local launch and local activation.
4. Restart the application Service linked to this Application ID or restart the server and monitor

Share this post


Link to post
Share on other sites

Not sure if it's an SCCM problem. I found this here: http://social.technet.microsoft.com/Forums/systemcenter/en-US/dfc465bc-7bbd-483e-b98b-2ba56fa98313/the-applicationspecific-permission-settings-do-not-grant-local-launch-permission-for-the-com-server

 

(I have modified it slightly to included the App ID in the error you provided:

 

1. Click Start -> Run -> Type -> dcomcnfg, expand Component Services -> Computers -> My Computer -> DCOM Config.

2. Click View -> Detail -> Now you will get Application Name and Application ID in right side.

3. Scroll down and find the application ID {AD65A69D-3831-40D7-9629-9B0B50A93843} -> Right Click -> Properties and select the Security tab.

3. Click Customize under "Launch & Activation Permission" -> click Edit -> Add in the account NT AUTHORITY\SYSTEM and set local launch and local activation.

4. Restart the application Service linked to this Application ID or restart the server and monitor

 

i found this as well and tried it but no difference. The reason I think it may be an SCCM issue is because the APPID refers to the SMS Agent Host and its only started since I have been using SCCM.

Share this post


Link to post
Share on other sites
Still testing ArmitageID but it seems it may be due to windows updates, once windows updates are installed the plug and play still doesn't work but if you tell one device to check for drivers it seems to work and then from there on all devices auto look for drivers and install. Ill update more when ive done more testing.

Share this post


Link to post
Share on other sites

Hi. I have the same problem. I just did in-place upgrade of site system server from 2008 R2 to 2012 R2 and now I cannot open SCCM Console and have same error logged in event viewer.

Did you manage to solve this problem? If yes then how?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...