Jump to content


Sign in to follow this  
OliAdams

SCCM will not connect to SQL Server.

Recommended Posts

After one of the updates hanging on sharing content. I restarted the sql service and now sccm cannot connect. I have tried running modify sql server connection on the setup wizard hta but I get the error attached. When I run a UDL file test it connects using windows authentication but not when I enter the credentials of the user I am actually logged on as. Any ideas?

Capture.JPG

 

The smsexec.log states *** [28000][18456][Microsoft]

[SQL Server]Login failed for user


Here the user account has not changed and is still the same. It is the computer account of the site system server.

Share this post


Link to post
Share on other sites


Is the SQL service running using the built-in system accounts or an AD service account? Under "administration --> overview --> security --> Administrative Users" does the service account have the appropriate permissions there?  For example, I have a service account called "domain\svc_sccm" that has "Full Administrator" permissions.  If you are logged into the admin console of the server, does it connect during that interactive session?  In short, these couple tests will help rule out general Windows server connectivity behavior.  If the SQL still fails after validating the above, it may be something else.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...