Jump to content

Recommended Posts

I've been asked to uninstall any version of Citrix Workspace, prior to 2210, from all of our devices but I'm not sure on the best way to do this.

I managed to find a Powershell script which, when copied to a machine and ran from Powershell, seems to work fine but I can't get it to work when running from MECM - a copy of which I've attached.

I tried creating a Task Sequence and adding a line to run a Powershell script. I then edited the script, pasted in the above and selected to Bypass the execution policy but, when the Task Sequence is deployed, it says it is running but doesn't seem to do anything, having left it for 30 minutes.

I've also tried creating a batch file to check for the instance of a particular folder and then, if present, to run an uninstall command, a sample of which is below. This also works when ran directly from the machine but not from MECM - I have attached a section of the batch file.

I created a Package, pointing to the source folder where the batch file is held, and then, in a Task Sequence, added a Run Command Line and entered the filename and then selected the Package created earlier. The Task Sequence then fails saying the system cannot find the file specified.

Is anyone able to advise where I'm going wrong or what would be a better way of doing this? 

Batch File.png

Powershell Script.png

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...