Jump to content


ddccsartoris

broken WDS ... help!?

Recommended Posts

WDS stopped working over the weekend for no apparent reason. Came in Monday to find that we can't PXE boot to image our machines from SCCM2007. All machines we attempt to image simply report "no boot image available".

 

WDS is cranky and unstable at the best of times. I've seen this error enough that I thought I knew what to do. I removed the PXE distribution points from SCCM, removed the PXE service point, un-installed WDS, renamed the RemoteInstall folder, rebooted a couple times, re-installed WDS, re-installed the PXE service point, re-created the PXE distribution points...

 

And it's still broken.

 

WDS starts up OK... I'm not getting the usual 1067 error.

 

Instead, WDS starts up and I get one error (ID 258) and one warning (ID 512) logged.

 

I've un-installed and re-installed WDS (as well as the PXE service point) at least a dozen times now. I've re-created boot images, task sequences, and everything. I've tweaked the registry to disable multi-threading, I've double-checked with our network guys to make sure they didn't change anything interesting.

 

Frankly, at this point, I'm stumped.

 

The error text from the WDSIMGSRV/258 error makes me think that some component isn't installing correctly... But I'm not entirely sure what to do about that. Maybe REGSRVR some DLL?

 

Absolutely any assistance in resolving this issue would be greatly appreciated.

 

Log Name:	  Application
Source:		WDSServer
Date:		  5/14/2012 3:58:43 PM
Event ID:	  512
Task Category: WDSServer
Level:		 Warning
Keywords:	  Classic
User:		  N/A
Computer:	  REDACTED
Description:
An error occurred while trying to initialize provider WdsImgSrv from C:\Windows\system32\WdsImgSrv.dll. Since this provider is not marked as critical, Windows Deployment Services server will  continue.

Error Information: 0xC1030104

 

Log Name:	  Application
Source:		WDSIMGSRV
Date:		  5/14/2012 3:58:43 PM
Event ID:	  258
Task Category: (1)
Level:		 Error
Keywords:	  Classic
User:		  N/A
Computer:	  REDACTED
Description:
The description for Event ID 258 from source WDSIMGSRV cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.
If the event originated on another computer, the display information had to be saved with the event.
The following information was included with the event:
0xC1030104

post-16064-0-24311500-1337086850_thumb.png

Share this post


Link to post
Share on other sites


Hi,

 

I got this exact error, after uninstalling WAIK, I know it's a bit late, but hopefully it can assist people in the future.

 

Have a look if Waik is healthy, ie, can you access Os images(Import them to sccm).

Also check if the wds service is started, and set to start when the computer starts.

Note, you can heck this by clicking "start", typing "Msconfig.msc", and pressing enter, and then navigating to the "Services" tab.

Share this post


Link to post
Share on other sites

I have fix the issue....there is a .WIM corrupt....you need to delete it from the server and after it deleted RE-UPDATE your DP

how to find it? open the smspxe.log the path is right there

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...