Jump to content


vks1

Application Import Errors after moving DB

Recommended Posts

Hi,

I am getting "SMS Provider reported an Error" message when trying to import an application into Config Manager.

 

 

03-09-2012 14-16-44.bmp

 

I have looked at the SMSProv.log and its showing the following 'red' items

 

*~*~[24000][0][Microsoft]

Invalid cursor state   [24000][0][Microsoft][sql Server Native Client 10.0]Invalid cursor state  ThreadID : 6088 , DbError: 0 , Sev: 0~*~*

 

*~*~e:\nts_sccm_release\sms\siteserver\sdk_provider\smsprov\ssputility.cpp(2105) : SQL command failed: if (object_id('tempdb..#sp_setupci_resultstr') IS NOT NULL) drop table #sp_setupci_resultstr;~ SQL Error: [24000][0][Microsoft][sql Server Native Client 10.0]Invalid cursor state~*~*

 

ERROR: SQL command failed: if (object_id('tempdb..#sp_setupci_resultstr') IS NOT NULL) drop table #sp_setupci_resultstr;

 

I have gone through and checked the DB and locations and all looks ok, even done the ALTER DATABASE commands but I am still getting this error message.

 

Urgently need to get this up and running and this is a massive stumbling block and cant find what to do on the net anywhere :(

Share this post


Link to post
Share on other sites

Got it working in the end, I had installed SQL in Single mode and needed to have it running in Mixed mode, enabled and then enabled the SA account and then run again and it all worked fine following the instructions below:

 

http://support.microsoft.com/kb/2709082/de

 

To resolve this issue complete the following steps:

1. Manually set the property back to ON by running the following command against your CM database:

ALTER DATABASE <ConfigMgr DB> SET TRUSTWORTHY ON

2. Ensure that the database that was moved is owned by SA.

3. Ensure that Isolation Level is set to 'READ_COMMITTED_SNAPSHOT'

- To check the Isolation Level run 'DBCC USEROPTIONS'

- If it is set to anything else then 'READ COMMITTED SNAPSHOT', please run following commands:

ALTER DATABASE <ConfigMgr DB>

SET ALLOW_SNAPSHOT_ISOLATION ON

ALTER DATABASE <ConfigMgr DB>

SET READ_COMMITTED_SNAPSHOT ON

Note: You might have to switch the SQL DB to Single User mode before running the two commands in previous step. Once done, please change it back to Multi User mode.

Also make sure that all properties are set correctly under Database Properties - Options

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...