Jump to content




Sign in to follow this  
mrbios

Multicast 0x80091007 error - Unicast works fine



Recommended Posts

Multicast disabled:

Imaging process works fine, I've done over 300 machines this way so far. I can always return to unicast and everything will work again after failing with mutlicast.

 

Multicast enabled:

Image bombs out with the 0x80091007 error at the very start, it says "creating a multicast session" then errors at the exact same moment it tries to start the applying operating system part. Unsure whether the multicast session even gets created though, because i never see any multicast routes appear on my router. (I'm not even sure if i should be able to, I assume though that something should show up in either "show ip mroute" or "show ip pim mroute" - this is a HP 8206zl) but at the same time the box behind switches to "Apply operating system" which leads me to believe it does.

 

Here's the section from the log:

<![LOG[Successfully completed the action (Partition Disk 0) with the exit win32 code 0]LOG]!><time="20:24:12.400-60" date="08-09-2013" component="TSManager" context="" type="1" thread="1620" file="instruction.cxx:3038">
<![LOG[MP server http://configmgr.Archway.local. Ports 80,443. CRL=false.]LOG]!><time="20:24:12.400-60" date="08-09-2013" component="TSManager" context="" type="1" thread="1620" file="utils.cpp:5300">
<![LOG[Setting authenticator]LOG]!><time="20:24:12.400-60" date="08-09-2013" component="TSManager" context="" type="1" thread="1620" file="utils.cpp:5322">
<![LOG[Set authenticator in transport]LOG]!><time="20:24:12.400-60" date="08-09-2013" component="TSManager" context="" type="0" thread="1620" file="libsmsmessaging.cpp:7751">
<![LOG[Sending StatusMessage]LOG]!><time="20:24:12.422-60" date="08-09-2013" component="TSManager" context="" type="1" thread="1620" file="libsmsmessaging.cpp:4025">
<![LOG[Setting message signatures.]LOG]!><time="20:24:12.422-60" date="08-09-2013" component="TSManager" context="" type="0" thread="1620" file="libsmsmessaging.cpp:1297">
<![LOG[Setting the authenticator.]LOG]!><time="20:24:12.422-60" date="08-09-2013" component="TSManager" context="" type="0" thread="1620" file="libsmsmessaging.cpp:1327">
<![LOG[CLibSMSMessageWinHttpTransport::Send: URL: configmgr.Archway.local:80  CCM_POST /ccm_system/request]LOG]!><time="20:24:12.422-60" date="08-09-2013" component="TSManager" context="" type="1" thread="1620" file="libsmsmessaging.cpp:8621">
<![LOG[Request was succesful.]LOG]!><time="20:24:12.442-60" date="08-09-2013" component="TSManager" context="" type="0" thread="1620" file="libsmsmessaging.cpp:8956">
<![LOG[Set a global environment variable _SMSTSLastActionRetCode=0]LOG]!><time="20:24:12.442-60" date="08-09-2013" component="TSManager" context="" type="0" thread="1620" file="executionenv.cxx:668">
<![LOG[Set a global environment variable _SMSTSLastActionSucceeded=true]LOG]!><time="20:24:12.442-60" date="08-09-2013" component="TSManager" context="" type="0" thread="1620" file="executionenv.cxx:668">
<![LOG[Expand a string: %_SMSTSMDataPath%\Logs]LOG]!><time="20:24:12.442-60" date="08-09-2013" component="TSManager" context="" type="0" thread="1620" file="executionenv.cxx:782">

I've tried all the tricks of restarting services, restarting the server, updating the distribution point and validating everything involved. I'm using Server 2008R2 and my SCCM server is a vmware ESX5.1 VM, and i have SP1 installed.

 

I've tried the suggestsions posted here: http://henkhoogendoorn.blogspot.co.uk/2013/02/multicast-error-0x80091007-during.html?

and i've gone through my multicast setup with a fine toothcomb using the guide here: http://bizsupport1.austin.hp.com/bc/docs/support/SupportManual/c02610033/c02610033.pdf

 

Here's the running configuration of my router just in case i have made any mistakes in the multicast setup that anyone can point out (this is the only router in the environment, SCCM server is on vlan 4, the machines I'm using to test multicast are on vlan 5)

; J9477A Configuration Editor; Created on release #K.15.04.0007
; Ver #01:00:01

hostname "ProCurve Switch 8206zl"
max-vlans 32
time daylight-time-rule Western-Europe
module 1 type J8705A
module 2 type J8705A
trunk A21-A24 Trk1 Trunk
trunk B21 Trk3 Trunk
trunk B17,B19 Trk5 Trunk
trunk B18,B20 Trk6 Trunk
ip default-gateway 172.18.66.253
ip routing
vlan 1
name "IP_BACKBONE"
forbid A2
ip address 172.18.64.251 255.255.255.0
no untagged A1-A20,B1-B16,B22-B24,Trk1,Trk3,Trk5-Trk6
exit
vlan 4
name "INFRASTRUCT"
forbid A2
untagged A1,A12,A14,A17-A19,B1-B2,B5-B9,B13-B16
ip address 172.18.66.1 255.255.255.0
tagged B22,Trk1
ip igmp
exit
vlan 2
name "B_BLOCK"
forbid A2
untagged B24
ip address 172.18.76.1 255.255.255.0
tagged B1-B2,B8-B9,B13-B16
ip igmp
exit
vlan 3
name "A_BLOCK"
forbid A2
untagged A5-A10,A13,B10
ip address 172.18.68.1 255.255.255.0
tagged B1-B2,B8-B9,B13-B16
ip igmp
exit
vlan 5
name "ICT"
forbid A2
untagged A11
ip address 172.18.65.1 255.255.255.0
tagged B1-B2,B8-B9,B13-B16
ip igmp
exit
vlan 6
name "iSCSI0"
forbid A2
ip address 172.18.67.1 255.255.255.0
tagged Trk1
exit
vlan 7
name "MEDIA_CENTRE"
forbid A2
untagged Trk3
ip address 172.18.70.1 255.255.255.0
tagged A11,B1-B2,B8-B9,B13-B16
ip igmp
exit
vlan 8
name "VIDEO"
forbid A2
untagged A20
ip address 172.18.79.1 255.255.255.0
tagged A5-A9,A11,B22-B24,Trk1,Trk3
ip igmp
exit
vlan 9
name "iSCSI2"
forbid A2
untagged A15,Trk5
ip address 172.18.69.1 255.255.255.0
tagged Trk1
exit
vlan 11
name "D_BLOCK"
forbid A2
untagged B23
ip address 172.18.74.1 255.255.255.0
tagged B1-B2,B8-B9,B13-B16
ip igmp
exit
vlan 12
name "PRINT"
forbid A2
ip address 172.18.71.1 255.255.255.0
tagged A5-A9,B13-B16,B22-B24,Trk1,Trk3
exit
vlan 14
name "WIRELESS"
forbid A2
untagged A4
ip address 172.18.77.1 255.255.255.0
tagged A5-A11,B1-B2,B8-B9,B13-B16,B22-B24,Trk1,Trk3
exit
vlan 10
name "F_BLOCK"
forbid A2
untagged B22
ip address 172.18.72.1 255.255.255.0
tagged B1-B2,B8-B9,B13-B16
ip igmp
exit
vlan 15
name "iSCSI1"
forbid A2
ip address 172.18.78.1 255.255.255.0
tagged B13-B16
exit
vlan 16
name "iSCSI3"
forbid A2
untagged A16,Trk6
ip address 172.18.73.1 255.255.255.0
tagged B13-B16,Trk1
exit
vlan 17
name "DOOR_SYSTEM"
forbid A2
ip address 172.18.75.1 255.255.255.0
tagged A8-A9,A11,B1-B2,B8-B9,B13-B16,B22-B24,Trk1,Trk3
exit
vlan 18
name "TBlock"
forbid A2
untagged Trk1
ip address 172.18.80.1 255.255.255.0
tagged B1-B2,B8-B9,B13-B16
ip igmp
exit
vlan 20
name "DMZ"
forbid A1,A3-A20,B3-B7,B10-B12,B22-B24,Trk3,Trk5-Trk6
untagged A2
tagged B1-B2,B8-B9,B13-B16,Trk1
no ip address
exit
vlan 21
name "vMotion"
forbid A2
untagged B3-B4,B11-B12
ip address 172.18.84.1 255.255.255.0
exit
vlan 22
name "GUEST_WIRELESS"
forbid A2
untagged A3
tagged A4-A11,B1-B2,B8-B9,B13-B16,B22-B24,Trk1,Trk3
no ip address
exit
igmp-proxy-domain "WDS" 172.18.66.1 224.0.1.0 239.255.255.255
igmp-proxy-domain "Video" 172.18.79.1 239.192.79.10 239.192.79.10
power-over-ethernet pre-std-detect
timesync sntp
sntp unicast
sntp server priority 1 172.18.66.25
ip route 10.7.116.0 255.255.252.0 172.18.66.12
ip route 192.168.11.2 255.255.255.255 172.18.66.253
ip route 195.137.89.208 255.255.255.252 172.18.66.253
ip route 213.18.249.18 255.255.255.255 172.18.66.12
ip route 213.129.90.244 255.255.255.255 172.18.66.12
ip multicast-routing
router pim
exit
interface A21
flow-control
exit
interface A22
flow-control
exit
interface A23
flow-control
exit
interface A24
flow-control
exit
snmp-server community "public" unrestricted
snmp-server host 172.18.66.16 community "public"
snmp-server host 172.18.66.22 community "public"
snmp-server host 172.18.75.3 community "public"
snmp-server host 169.254.101.158 community "public"
snmp-server host 172.18.66.26 community "public"
snmp-server location "A Block Server Room"
spanning-tree Trk1 priority 4
spanning-tree Trk3 priority 4
spanning-tree Trk5 priority 4
spanning-tree Trk6 priority 4
vlan 2
ip pim-dense
ip-addr any
exit
exit
vlan 3
ip pim-dense
ip-addr any
exit
exit
vlan 4
ip pim-dense
ip-addr any
exit
igmp-proxy "WDS"
exit
vlan 5
ip pim-dense
ip-addr any
exit
igmp-proxy "WDS"
exit
vlan 7
ip pim-dense
ip-addr any
exit
exit
vlan 10
ip pim-dense
ip-addr any
exit
igmp-proxy "WDS"
exit
vlan 11
ip pim-dense
ip-addr any
exit
exit
vlan 18
ip pim-dense
ip-addr any
exit
exit

Thanks for any help on this, seems a lot of people are getting this problem and are unable to solve.

Share this post


Link to post
Share on other sites


We've exact the same problems as mrbios describes I've done everythyng but MC won't work, unicast still working fine. Build a smaller image 2GB instead of 8GB.

Tests with a multicast packages tester shows tha MC is allowed through VLAN's.

Share this post


Link to post
Share on other sites

i have been getting this same error with multicast enabled DPs.

 

it only occurs when my server is on one domain and the DHCP suffix for the machine i am imaging is on another.

 

i have been able to get partial success:

 

1. dism mount the boot images
2. update the windows\system32\drivers\etc\hosts
a. add all the IP and shortnames only of all SCCM servers NO FQDN example 10.10.10.10 sccmserver1
3. dism commit

4. dism mount

5. redistribute

 

this only seems to work on multicast enabled VLANs, i still get the hash error on other VLANs if its a mixed site.

 

 

hopefully this helps a few in further testing, let me know if you have a further workaround!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×