Jump to content


bunce

Established Members
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

0 Neutral

About bunce

  • Rank
    Newbie
  1. Hi all. Attempting to install 2012 SP1 and it appears the pre-req checks for the Deployment Tools and PE are performed on the server that is specified for the SMS provider, rather than the SCCM server itself. Please refer screenshot below where the ADK tests are being undertaken on the DB server for some reason. SCCM Server: ADL-SCCM02.ourdomain.com (Win 2k8 R2) DB Server: ADL-SCDB01.ourdomain.com (SQL 2012 with cU2) The deployment kit has been installed on ADL-SCCM02 (including WinPE, Deployment Kit, etc), however the pre-req check is testing the database server (ADL-SCDB01). We opted to install the SMS provider on the database server (ADL-SCDB01) so suspected this could be related. As a troubleshooting step, I switched the SMS provider to ADL-SCCM02 and the pre-req's passed, presumably as the pre-req tests were correctly undertaken on the SCCM server instead of the DB server. The log file from a failed check is below. Extract: <01-09-2013 20:13:00> <<<CategoryDesc: Checking dependent components for ConfigMgr...>>> <01-09-2013 20:13:00> ADL-SCDB01.mydomain.com; Windows Deployment Tools installed; Error; The Windows Deployment Tools component of the Assessment and Deployment Kit (ADK) is required and must be installed before Setup can continue. See http://go.microsoft.com/fwlink/?LinkID=252874 <01-09-2013 20:13:00> INFO: CheckAdkWinPeInstalled on ADL-SCDB01.mydomain.com. <01-09-2013 20:13:01> ADL-SCDB01.mydomain.com; Windows Preinstallation Environment installed; Error; The Windows Preinstallation Environment component of the Assessment and Deployment Kit (ADK) is required and must be installed before Setup can continue. See http://go.microsoft.com/fwlink/?LinkID=252874 <01-09-2013 20:13:01> ADL-SCDB01.mydomain.com; SMS Provider machine has same domain as site server; Passed I'm not aware of any link or dependancy between the SMS provider and the ADK, so assume this is a bug in the pre-req checker where a variable is not updated from the SMS or DB check and is passed to the ADK check. I'm about to try again after removing the other warnings, which shouldn't be critical (just windows auth on sql box) but could possible cause a logic error in the wizard. BTW I recall back in 2007 that the pre-req checker didn't correctly check permissions on the System container when applying via security group (with machine account a member) rather than the machine account itself - looks like this is still the case (hence one of our warnings)? Any other suggestions? We could of course install the SMS provider on the SCCM box and be done with it, however we're going to have a number of console installed across our support staff etc, and so it seems more efficient to install the provider on the DB to prevent the double hop and optimise performance.. Thanks in advance.
×
×
  • Create New...