Jump to content


Recommended Posts

Hi all,

SCCM 2012 r2 and WSUS are becomming my enemy.

 

I followed the steps posted by "anyweb" is his "Using System Center 2012 Configuration Manager - part 5"

 

First things first when you add the SUP, the option to choose http and https is greyed out during the wizard. I have found other posts where users have the problem. So I guess thats not Isolated to me.

So I go to SSCM console -> Administration -> Site Configuration -> Sites. bring the properties of the primary site and set "HTTPS or HTTP".

I have also checked that iis 8.5 doesn't have https for wsus.

 

I have setup everything on one server, we are small site. Windows 2012 r2, SCCM 2012, SQL 2012.

 

After some tinkering I finally got WSUS to to work. the clients now have the Configuration Manager Client (5.00.7804.1000) availble in Windows update.

But it keeps failing to install. I traced the error and discovered it was access denied. So I setup CMtrace on the client and discovered this:

 

============================================================================================

<![LOG[MapNLMCostDataToCCMCost() returning Cost 0x1]LOG]!><time="07:42:01.130-120" date="01-30-2015" component="ccmsetup" context="" type="1" thread="4944" file="ccmutillib.cpp:5377">
<![LOG[Client is not allowed to use PKI issued certificate thus it can not talk to HTTPS server.]LOG]!><time="07:42:01.132-120" date="01-30-2015" component="ccmsetup" context="" type="3" thread="4944" file="httphelper.cpp:800">
<![LOG[GetHttpRequestObjects failed for verb: 'GET', url: 'https://SENTINAL.NORTHRIDGE.LOCAL/CCM_Client/ccmsetup.cab]LOG]!><time="07:42:01.133-120" date="01-30-2015" component="ccmsetup" context="" type="3" thread="4944" file="httphelper.cpp:947">
<![LOG[DownloadFileByWinHTTP failed with error 0x80004005]LOG]!><time="07:42:01.133-120" date="01-30-2015" component="ccmsetup" context="" type="3" thread="4944" file="httphelper.cpp:1081">
<![LOG[CcmSetup failed with error code 0x80004005]LOG]!><time="07:42:01.138-120" date="01-30-2015" component="ccmsetup" context="" type="1" thread="4944" file="ccmsetup.cpp:10544">

===========================================================================================

error 0x80004005 - according to ther posts I have read via google, this means access denied. and it due to the system looking for a valid PKI cert and the URL is https?

 

Why is the system still trying to use https?

How to i fix this?

 

 

Share this post


Link to post
Share on other sites


Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...