Jump to content


Sign in to follow this  
ikkhatri

Microsoft Exchange 2016

Recommended Posts

Hi,

 

I have installed MS Exchange 2016 in my lab.

 

I can send emails internally just fine but not able to send emails externally.

 

My AD Domain: Domain.com

My Public Domain: DomainInc.com.au

 

Error message I get when I send emails externally meaning to gmail, aol or yahoo:

 

Generating server: EXCH-SRV01.domain.com

username@aol.com
Remote Server returned '400 4.4.7 Message delayed'

Original message headers:

Received: from EXCH-SRV01.domain.com (10.X.X.X) by EXCH-SRV01.domain.com (10.X.X.X) with Microsoft SMTP Server (TLS) id 15.1.225.42; Sat, 27 Feb 2016 04:56:17 -0800Received: from EXCH-SRV01.domain.com ([::1]) by EXCH-SRV01.domain.com ([::1]) with mapi id 15.01.0225.041; Sat, 27 Feb 2016 04:56:17 -0800From: Exchange Admin Account <adm_exchange@domain.com>To: username@aol.com username@aol.comSubject: testThread-Topic: testThread-Index: AQHRcV47KRzLbFmdUEagAG9gVscc+A==Date: Sat, 27 Feb 2016 12:56:16 +0000Message-ID: <5c6080469f5a41c3b2e8bc8be3a3d88b@genesys.com>Accept-Language: en-USContent-Language: en-USX-MS-Has-Attach: yesX-MS-TNEF-Correlator:x-originating-ip: [10.X.X.X]Content-Type: multipart/related;	boundary="_004_5c6080469f5a41c3b2e8bc8be3a3d88bgenesyscom_";	type="multipart/alternative"MIME-Version: 1.0

I have registered a domain with crazydomains and also purchased a dns and email address to verify my domain for SSL certificates.

 

Created an A Record : mail.domainname.com.au --> pointing to my public domain ip address.

Created another A Record: autodiscover.domainname.com.au --> pointing to my exchange server EXCH-SRV01.domain.com (AD Domain)

Created an MX record: mail.domainname.com.au --> pointing to mail.domainname.com.au

 

My SSL Certificate has the following under Subject Alternative Name:

 

DNS Name=mail.domainname.com.au

DNS Name=autodiscover.domainname.com.au

DNS Name=domainname.com.au

 

 

 

Is this configured incorrectly?

 

I have been stuck with this for a while and tried many google searches to find a resolution with no luck.

 

Any help would be appreciated.

 

Thanks.

Share this post


Link to post
Share on other sites


Just wanted to share this with others that may have this issue (I was scratching my head for over 2 weeks)

 

Finally I got it to work. Thanks for the RDNS tip Saligia.

 

I haven't fully configured everything. Just wanted to get inbound and outbound mail going for now (internal and external), so here is what I did to get it working

 

1. Got my ISP to provide me with Reverse DNS --> Pointing to mail.publicdomain.com.au (Public domain: IE: Godaddy, Crazydomains and etc)

2. Logged in to my Public domain providers site and performed the following (Note: You may need to purchase DNS Premium service - I did! )

3. In the DNS section:

- Created A Record: Mail.publicdomain.com.au --> pointed it to my public IP address (if you don't know login to your router or call your ISP)

- Created CNAME Record: autodiscover.publicdomain.com.au --> pointed it to mail.publicdomain.com.au

- Created MX Record: publicdomain.com.au --> pointed it to mail.publicdomain.com.au

4. Logged in to my router and added 2 port mappings:

- WAN and LAN Port: 443 (HTTPS) This will allow you to access OWA from outside of your organization/domain

- WAN and LAN Port: 25 (SMTP)

(Hopefully your ISP allows port forwarding)

5. In your Domain Controller or wherever you have a DNS server installed open it up and create an Mail Exchange (MX) record under DC---->Forward Lookup Zones----->Contoso.com.

- Right Click Contoso.com and click New Mail Exchanger (MX).

- Host or child domain: put in your exchange server hostname (IE: exch-srv001)

- FQDN: exch-srv001.contoso.com

- FQDN of Mail Server: mail.publicdomain.com.au (or dot com or whatever you have purchased)

- Mail Server Priority: I kept it as default (10)

- Hit OK.

 

Also if you are looking for an SSL certificate. I got my free one from StartSSL.

- My SSL Cert included autodiscover.publicdomain.com.au and mail.publicdomain.com.au only.

 

I hope this helps someone.

 

Again, I'm not a pro at this as I'm still learning however the above method worked well for me.

 

Thanks for the help

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...