Jump to content


smaunsell

Windows 10 Offline Files GPO

Recommended Posts

I'm trying to force offline files for laptops. I have 2x GPOs - one for computer and one for user.

 

GPO settings are below. With this configured files are not automatically available offline. The users' folders are redirected via another GPO to \\domain.com\users\users\%username%\ and this is configured in the user GPO under 'Specify administratively assigned offline files'.

 

When going to 'Sync Center' in Control Panel and clicking 'Manage Offline Files' it says 'Offline Files is currently disabled' and there is a button to 'Enable offline files'. Sure, if the user selects this then files are synced but they shouldn't have to do this - it should be automatic.

 

What's missing to automate this for the users?

 

gpo_settings01.png

 

gpo_settings02.png

 

 

 

gpo_settings03.png

Share this post


Link to post
Share on other sites


After a LOT of Googling I finally came across this. Some call it a "bug", some call it a "feature". It has only just stopped working in build 1511.

 

It appears that 'Offline Files' is not the way to go. It looks like the way forward is with 'Work Folders' so I'll need to do some reading on that.

 

UPDATE: It doesn't look like this is the issue. The 'Continuous Availability' setting is on W2K12 but I've got W2K8R2. I've checked the shares anyway and the offline ability is enabled. The CA issue also says that offline files can't be enabled manually but I can do that - the issue is that I can't get it to enable automatically. The use of 'Work Folders' is quite different and would require some deep investigstation and configuration.

 

As 'Offline Files' works but only when enabled manually there appears to be a problem with the automatic configuration of this in Win10 (specifically I'm using 10586.494 - July 2016 update).

 

Anyone come across this issue and got 'Offline Files' working? Or have any thoughts?

 

UPDATE: Some more Googling found lots of references to failing to start the service eg this but the registry change still doesn't resolve the issue.

 

I got the Win10Edu ISO and built a basic laptop and offline files worked. I added it to the domain and it worked. I applied the GPOs and it worked. So something in the SCCM WIM is causing the problem. The reports about the service failing to start mention the offline files must be disabled before capturing the image but I don't think this is the case as the registry entry should resolve it. I suspect something has been disabled/removed before the capture was taken and I'll need to follow up with who did that to find out more.

 

UPDATE: So, building with a base ISO and building with a previous WIM both work so there's something in the latest WIM that is stopping Offline Files from working. But......despite these builds working as far as enabling Offline Files things like automatic sync don't work. In Sync Centre the sync partnership is created but a full sync is not done. And despite th GPO configured for sync during logon/logoff/suspend this is not done. A manual setup for a sync schedule is able to be done but the settings differ from what is possible in the GPO - the schedule has logon (but no logoff), idle timeout, lock and unlock. This sync schedule doesn't create anything in Task Scheduler so they can't be copied from there and distrubuted to other PCs. Speaking of Task Scheduler there are 2 entries in there (in LIbrary/Microsoft/Windows/Offline Files) for background and logon but they're disabled.

 

Has anyone been able to successfully configure Offline Files on Win10 via GPO????

Share this post


Link to post
Share on other sites

Soooooooo, it appears that GPOs for Offline Files are all but useless in Win10. Computer Policy can enable/disable and that's about it. The User Policy does nothing - the settings for sync only apply to old OSs.

 

I've had to use a logon script to add the locations that need to be synced:









The Computer Policy setting to 'Configure Background Sync' creates a scheduled task. Anther scheduled task is created (how??) to sync on logon (delayed by 4mins). But that's about all that can be done.

#Get current username
$username = [Environment]::UserName 
#Pin AppData
$path = \\mydomain.com\AppData\$username
$objWMI = [wmiclass]\\.\root\cimv2:win32_offlinefilescache
$objWMI.Pin($path, 0x00001221, $true)
#Pin MyDocuments
$path = "\\mydomain.com\users\$username"
$objWMI = [wmiclass]\\.\root\cimv2:win32_offlinefilescache
$objWMI.Pin($path, 0x00001221, $true)





 

Work Folders are only able to sync users documents. It can't be used to sync AppData or anything else. It's designed for syncing files that can then be accessed across different user devices (Android/iOS phones etc). Sp it appears that Microsoft have made Offline Files all but useless and have not provided any real replacement. And there appears to be little information about what's going on. I'vr searched everywhere and no one has any details. And I've posted a few places and no one has been able to provide any answers.

 

There's a Registry setting to try and handle conflict resolution but it doesn't appear to work:

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\NetCache\SyncConflictHandling
REG_EXPAND_SZ
\\mydomain.com\AppData\
1

Anyone have any idea to get conflict resolution working?

Share this post


Link to post
Share on other sites

Not an offline files solution per say but installing Windows 10 into my environment I had an issues with Windows saving to particular storage medium.

The solution in my case was to use 'onedrive' as replacement for the documents area with a folder redirection group policy which created the necessary folder structure within OneDrive/Office365.    

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...