Jump to content

  • 0

Apply OSDComputerName during OSD in CB


This should be easy. I've done it dozens of times, through CM2007 and CM2012R2. Now, with CB, my brain isn't working.

Environment variable OSDComputerName created on Unknown Computers collection and no value assigned - Check!
TS step Set Task Sequence Variable after Apply Operating System Image with Variable: OSDComputerName and Value:%_SMSTSMachineName% - Check!
TS Prompts me for OSDComputerName value prior to starting up and I enter it - Check!
OSDBackground pops up and there is my OSDComputerName value on the screen - Check!

During deployment, after rebooting, OSDComputerName changes to MININT-XXXXXX, and the value I input when starting the TS is overwritten. This tells me that _SMSTSMachineName is overriding OSDComputerName instead of vice versa. Looking back at the TS in my old 2012R2 environment I have the Set Task Sequence Variable step set the same way.

Where have I gone wrong?



Share this post

Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Never mind. Don't need to set TS variable in the TS when you set it before execution. At least not when MDT is integrated. That's the only thing I can think of that is different between environments. OSDComputerName gets applied just fine during Apply Windows Settings without additional intervention.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.