Jump to content


Sign in to follow this  
iamrufus

Deployed applications not installing

Recommended Posts

Hi All,

First time poster here :)

Currently running SCCM version 1706 and I am having an issue trying to get applications to install when deployed to a specific device collection. I am still learning my way around SCCM so please bare with me here.

I have setup the application foxit reader to deploy to 1 test collection. I set it up to be available rather than required. The test machine is a VM, its has software centre installed. I don't seem to be able to view an application catalogue though which is where I thought this deployment might show up. There is a link to the application catalogue under Installation Status but this is greyed out. (image attached)

EDIT - I think the reason I am seeing the website catalogue greyed out is because I currently don't have either of the 'Application catalogue web service point' or 'Application catalogue website point' roles installed. Are either of these roles actually required to deploy applications to collections rather than through a task sequence?

My next though was the log files, i looked for the appenforce log (not sure if this is the right one) its the log I have seen people mention but it doesn't appear to be on the client machine. I have attached all the logs that are present for reference.

I am just a bit lost to what to try next, I'd be so grateful if someone could lend me a hand or point me in the right direction.

Thanks so much

 

software center.PNG

client logs.zip

Edited by iamrufus

Share this post


Link to post
Share on other sites


Hi,

The appenforce.log is the correct log to monitor application installation when monitoring application model deployments. When the installation starts that's the log that shows the process running and exit code etc

Try adding in a second application and push it to the same device.

From a glance at your logs it hasn't received the software via policy yet, the second link is the one you want.

Does the client look healthy? if you open control panel there is a Configuration Manager applet. In the actions tab are there more than 2 listed?

You are correct about the catalogue, you need the role installed to be able to use it. But you do not need it for software deployments. Software center will be fine.

https://blogs.technet.microsoft.com/manageabilityguys/2013/10/01/configmgr-2012-tracking-application-model-installations-on-clients/

https://web.archive.org/web/20160422151315/http://www.moyerteam.com/2013/10/troubleshooting-configmgr-application-deployments-detailed-log-file-analysis/

Share this post


Link to post
Share on other sites

Many thanks for the kind response,

Randomley I have just logged back into the client and the Foxit reader application was showing in the software centre so i cliked intsall and it seemed to work just fine. Dont quite know what the delay was there. I have attached the app logs just to clarify that these are the right ones I would need to look at for future issues. I have just created a new deployment for 7zip which I have pushed to the same device collection but this time I have set it as required, will see if and how long it takes to pick this up.

The client looks healthy seems to be showing quite a bit of info (image attached). Thanks for those links as well, i will check them out for sure.

Just to add something else if thats ok, I added the install of foxit reader to my task sequence which install windows 10. When it gets to the part of intsalling it it seems to fail. I have attached the smstg.log file for this as I was just wondering if you might be able to shed some light on it for me? I actually tried installing it using the exact commands that SCCM has setup for it in the deployment in the command line on the client and it installed without issue. 

EDIT - Had a bit of a breakthrough with why it failed in the task sequence. I had to add a reboot of the machine after the configmgr install into the TS as i had the dreaded welcome whirl spinning for hours otherwise and it was also setup as a work group TS. I then  changed it to join the domain instead and it worked first time!

Cheers mate

configmgr client.PNG

Application install logs.zip

smsts.zip

Edited by iamrufus

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...