Jump to content


Sign in to follow this  
Loganater

Deploying Java 6 update 21

Recommended Posts

I am having trouble deploying java 6 update 21 to Windows 7. I have ran the same command line manually on the machine and it runs silenty with no problems. Here is what I have done:

 

1. Created java 6 update 21 package

2. Listed package in distribution

3. Created task sequence

4. Added a new program under java with the command line code - jre-6u7-windows-i586-p-s.exe /passive IEXPLORER=1

 

When the task sequence runs on the computer I receive error: 0x80070653

 

Any help would be greatly appreciated.

 

Thank you

Share this post


Link to post
Share on other sites


I'm using the extracted msi-Version with the command line

 

MsiExec /i "jre1.6.0_21.msi" AUTOUPDATECHECK="0" IEXPLORER="1" JAVAUPDATE="0" JU="0" REBOOT=REALLYSUPPRESS ALLUSERS=1 /quiet

Share this post


Link to post
Share on other sites

I'm using the extracted msi-Version with the command line

 

MsiExec /i "jre1.6.0_21.msi" AUTOUPDATECHECK="0" IEXPLORER="1" JAVAUPDATE="0" JU="0" REBOOT=REALLYSUPPRESS ALLUSERS=1 /quiet

 

I followed the above procedure with a MSI and I am still receiving a error 0x80070643 is there anyway I can check a log to see what is failing?

Share this post


Link to post
Share on other sites

I followed the above procedure with a MSI and I am still receiving a error 0x80070643 is there anyway I can check a log to see what is failing?

There were two reason I received this error:

 

1. I was pointing to the file instead of the folder when creating a package.

 

2. I was using the 32BIT version on a x64 OS.

 

Thank you all for helping out I have resolved the problem!

  • Like 1

Share this post


Link to post
Share on other sites

I'm using the extracted msi-Version with the command line

 

MsiExec /i "jre1.6.0_21.msi" AUTOUPDATECHECK="0" IEXPLORER="1" JAVAUPDATE="0" JU="0" REBOOT=REALLYSUPPRESS ALLUSERS=1 /quiet

Does this uninstall previous versions of Java like the EXE install does?

 

I've seen reports of people having problems with the MSI installs e.g. saying it installed successfully but it actually didn't... If its re-run on the same computer it removes all files but leaves the entry in Add/Remove Programs etc...

 

Also to note... You need to install 32bit JRE on 64bit machines as most applications that use Java are still 32bit.

 

Cheers!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...