Jump to content


BRO-T

Unable to sysprep the machine 0x00004005

Recommended Posts

Hi there,

 

I'm new to SCCM and I've inherited a working implementation which now has a few issues.

 

I ahve started by building my own collections, OS images etc followign the website. I have got to the stage where i have PXEboot my 1st machine to build and capture the XP image. It gets so far, installs the OS, sofwtare, drivers, I believe it is failing on the sysprep task which is almost the last task.

 

Can somebody please help, below is a sample of the SMSTS log file

 

 

Administrator account name = 'Administrator' PrepareOS 21/10/2010 15:15:38 280 (0x0118)

Successfully retrieved the original password policy settings PrepareOS 21/10/2010 15:15:38 280 (0x0118)

Succesfully reset password policy settings on local machine PrepareOS 21/10/2010 15:15:38 280 (0x0118)

nStatus == NERR_Success, HRESULT=80004005 (e:\nts_sms_fre\sms\client\osdeployment\prepareos\prepareos.cpp,797) PrepareOS 21/10/2010 15:15:38 280 (0x0118)

Failed to reset the administrative password, NetAPI Error = 2245 PrepareOS 21/10/2010 15:15:38 280 (0x0118)

ResetAdminPassword(), HRESULT=80004005 (e:\nts_sms_fre\sms\client\osdeployment\prepareos\prepareos.cpp,1368) PrepareOS 21/10/2010 15:15:38 280 (0x0118)

Unable to sysprep the machine, hr=80004005 PrepareOS 21/10/2010 15:15:38 280 (0x0118)

pCmd->Sysprep(bActivate, bMsd), HRESULT=80004005 (e:\nts_sms_fre\sms\client\osdeployment\prepareos\main.cpp,270) PrepareOS 21/10/2010 15:15:38 280 (0x0118)

Sysprep'ing the machine failed, hr=80004005 PrepareOS 21/10/2010 15:15:38 280 (0x0118)

De-Initialization successful PrepareOS 21/10/2010 15:15:38 280 (0x0118)

Exiting with error code 16389 PrepareOS 21/10/2010 15:15:38 280 (0x0118)

Process completed with exit code 16389 TSManager 21/10/2010 15:15:38 244 (0x00F4)

!--------------------------------------------------------------------------------------------! TSManager 21/10/2010 15:15:38 244 (0x00F4)

Failed to run the action: Prepare OS.

Unknown error (Error: 00004005; Source: Unknown) TSManager 21/10/2010 15:15:38 244 (0x00F4)

Sending status message . . . TSManager 21/10/2010 15:15:38 244 (0x00F4)

Send a task execution status message SMS_TSExecution_ActionFailError TSManager 21/10/2010 15:15:38 244 (0x00F4)

Share this post


Link to post
Share on other sites

Had the same problem.

Found this http://blogs.technet.com/b/smsandmom/archive/2008/08/18/configmgr-2007-osd-fails-with-sysprep-did-not-complete-successfully-error-when-capturing-a-windows-vista-image.aspx

 

I solved the problem

 

Resolution: There are two possible solutions or workarounds to this problem:

 

Use the above described method in building the Windows Vista image from scratch each time by using a task sequence. Anytime you need to make changes to the image, change the task sequence and allow the image to be built from scratch again. This is the preferred method

 

 

Everytime I perform a build and capture (Windows 7 - to install latest patches) - I use an untouched version of Windows 7 - and NOT one, that I have previously patched

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...


×
×
  • Create New...