Jump to content




Sign in to follow this  
phyler

Restore State not working



Recommended Posts

Well, it seems like this is a somewhat common issue but for some reason, the common solutions have not worked for me. Here is the scenario:

 

Windows 2008 R2

SCCM 2007 SP2 R3 in Mixed mode

MDT 2010 installed and integrated but not trying to use MDT task sequences right now.

 

Trying to do hardlinks (just trying to get USMT to work period, whether by hardlinks or not). I have followed the offline guide here, this Technet blog and Peter's blog's.

 

I had one issue where sflistw7.dat was not being found. I found one article that suggested just copying that from the Windows 7 media. I did that and now I get the following in the loadstate logs:

 

2010-12-14 13:01:36, Warning [0x08046b] Cannot expand LDID in file list record: 10.old\windows\system32\locale.nls

2010-12-14 13:01:36, Warning [0x08046b] Cannot expand LDID in file list record: 10.old\windows\winsxs\amd64_microsoft-windows-i..nal-core-locale-nls_31bf3856ad364e35_6.1.6913.0_none_0ea7705d61bb185f\locale.nls

 

 

I get this warning in the scanstate log (I have changed the name of the domain by hand here just to protect the innocent):

 

2010-12-13 21:48:34, Warning [0x080462] CListSysFileFilter::BuildTree: could not create FileList object for \\DENSCCM1.DOMAIN.LOCAL\SMSPKGE$\DEN00013\x86\SFLISTXP.DAT: Win32Exception: \\?\UNC\DENSCCM1.DOMAIN.LOCAL\SMSPKGE$\DEN00013\x86\SFLISTXP.DAT: The system cannot find the file specified. [0x00000002] __thiscall UnBCL::FileStream::FileStream(const class UnBCL::String *,enum UnBCL::FileMode,enum UnBCL::FileAccess,enum UnBCL::FileShare,unsigned long)

 

Here are a few pieces that I found interesting in the smsts log:

 

<![LOG[Failed to run the action: Install "KB977384 - Advanced Client Hotfix - DEN-KB977384 - Advanced Client Patch Install".

Unknown error (Error: 80040215; Source: Unknown)]LOG]!><time="12:52:52.076+480" date="11-12-2010" component="TSManager" context="" type="3" thread="3268" file="instruction.cxx:3101">

 

<![LOG[Failed to run the action: Restore User Files and Settings.

Reached the end of the file. (Error: 80070026; Source: Windows)]LOG]!><time="22:15:23.749+420" date="12-13-2010" component="TSManager" context="" type="3" thread="2704" file="instruction.cxx:3101">

 

 

When I do the offline method, instead of the "Reached the end of the file" error I get an Out of Space error. My issue there is I have a 50GB drive with a base XP install (~10GB) and I'm just trying to place a base Windows 7 image down that takes up only about 20GB total. If 30GB total free isn't enough, I'm not sure what is. Here is that error message:

 

<![LOG[Failed to run the action: Error in the task sequence.

Not enough storage is available to complete this operation. (Error: 8007000E; Source: Windows)]LOG]!><time="13:02:23.448+480" date="12-14-2010" component="TSManager" context="" type="3" thread="696" file="instruction.cxx:3101">

 

 

I can post more logs, I tried to get what I thought was important here. I have run the patch that is supposed to fix the KB974571 issue as well.

 

Hopefully this is enough info for someone to point me in the right direction.

 

Thanks.

Share this post


Link to post
Share on other sites


Are all the files of the USMT Package still available?

 

As in, are they still on the computer after the restore fails? No. When I do Niall's example, the USMTBits directory is gone by the time I get to log back in. I was under the impression that they get removed automatically at the end, is that not the case?

 

Thanks.

Share this post


Link to post
Share on other sites

Ok, well, even though I looked for it in the past and couldn't find it installed on the system, today I look and I see that KB974571 was installed. I even had the patch that supposedly fixes this issue in there as that is what I originally looked at.

 

As much as it burns me up that this was the issue, I'm glad it is fixed. Now I just have to figure out why when I use USMT and the SMP then re-partition the drive it always gives me a D: drive instead of a C: drive. Love the challenges.

Share this post


Link to post
Share on other sites

Are you, by any change, using the standard install.wim? If so, then capture your own image, because the standard install.wim will always install on D:

 

Yep, that was exactly the issue.

 

So, strange thing, I can successfully do a demo of Hardlinks but as soon as I use my captured "Gold" image that has all my apps installed, the hardlinks fail with the errors that I stated earlier. This is a fresh build that I captured and double-checked that it didn't have 974571 on it. Weird.

 

If I try to do a load without hardlinks just using the SMP I get a 00004005 error (which I'm assuming is a permission denied error based on the 4005). I've set the permissions on the share and file system for that directory to be Everyone-Full Control. More trouble-shooting to come on that.

 

Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


×