Jump to content


Sign in to follow this  
qaisar

Remote Desktop does not save windows positions

Recommended Posts

Hi

 

I have Windows 7 Enterprise (32bit) PC at work with two 19" monitors (screen resolution 1280 x 1024 on each). The display is extended.

 

My home PC is a Win 7 Ultimate (32bit) on a Laptop, screen resolution 1280 x 800.

 

On my work PC I keep some apps open (for example, IE, Outlook etc) on primary monitor and some (like Word, Excel, Adobe etc)on the secondary monitor. The problem is after I RDP from home to my Work PC and then when I get to work all my apps are re-positioned to my Primary monitor. I have tried several things like change the screen resolution on both work and home PCs, changed the primary/secondary monitors etc but Windows 7 just does not seem to remember the last application windows position after the RDP connection is made and disconnected.

I also tried the Desktop Layout Restor utility but it only restores the Desktop icons and not the applications window position.

 

Any help in this regards is greatly appreciated.

Share this post


Link to post
Share on other sites


Hi qaisar,

 

I don't think there is a fix for this issue but don't quote me on this.

 

If it helps you can use the Windows Button on your keyboard and the arrows to rapidly switch the window from screen 1 to screen 2.

 

Win key + up = Full screen

Win Key + Left = Aero Snap Left

Win Key + Right = Aero Snap Right

Win Key + Bottom = Minimize Window

 

If you have a second monitor on your left, you can use the Win Key + Left to snap the window on the left side of the screen, if you use the same combination of keys again the window will go on the second monitor.

 

I don't know if this will help or if this is what u need.

Good luck and let us know if you found a better solution.

 

Kosinas,

 

Sorry for my poor English.

Share this post


Link to post
Share on other sites

The solution is very simple. The mstsc is not detecting all the monitors. Use mstsc /admin to connect to work pc. before you connect click on options >display tab > check the checkbox which says use all my monitors.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...