Jump to content


rwle

Deploy Windows XP - not finishing the Task Sequence

Recommended Posts

Greetings! I have been working with SCCM 2007 R3 (Windows 2008 server) for almost 2 years. We have capture Windows 7 x86 images without issues and install them in about 300 computers without issues but now because of an application that will not run in Windows 7 (Avaya CTI), we need to create a base image for Windows XP SP3. Here is what I have accomplished so far:

 

* Create the base windows xp image (including Office 2007 and all windows updates)

* Capture the base image and added to SCCM

* Create a new Task Sequence for this image

* Advertise it and run it on a new bare metal computer (HP 8200 EUSD)

- The process starts and install the image correctly

- Run the process of conecting the computer to the domain

- After, restarts and stop for me to log in to the computer without installing all other apps from the Task Sequence

 

At first, try to connect to the computer using my domain account but the computer told me that could not log me in because it the domain was not available. When I verify the AD the computer was created and added, had to remove it and added it again for the computer to see the domain.

 

Now I am stock here, any suggestions or recomendations?

 

xp task sequence.xml

PolicyAgentProvider.log

smscliui.log

Share this post


Link to post
Share on other sites

SMSTS.log file please, as well as a screenshot of your task sequence.

  • Are you using the network service account to join to the domain?
  • Are you asking the TS to join the domain via the task sequence "Apply Network Settings" step?
  • Is the image sysprepped and are you integrating a sysprep.inf file in the "Apply Operating System" step?

Share this post


Link to post
Share on other sites

Here is the task sequence:

 

<?xml version="1.0" ?>

<
SmsTaskSequencePackage
xmlns:xsi
="
-instance'>
-instance
"
xmlns:xsd
="
">

 

<
BootImageID
>
KEN00001
</
BootImageID
>

<
Category
/>

<
DependentProgram
/>

<
Description
/>

<
Duration
>
360
</
Duration
>

<
Name
>
x86 Base XP Image 8200
</
Name
>

<
ProgramFlags
>
152084496
</
ProgramFlags
>

<
SequenceData
>

 

<
sequence version
="
3.00
">

 

<
referenceList
>

 

<
reference
package
="
KEN000B5
" />

<
reference
package
="
KEN000BA
"
program
="
Network Drivers XP
" />

<
reference
package
="
KEN00036
" />

<
reference
package
="
KEN0008B
"
program
="
Client Install
" />

<
reference
package
="
KEN00098
"
program
="
Install Client
" />

<
reference
package
="
KEN0008C
"
program
="
Install x86
" />

<
reference
package
="
KEN0008E
"
program
="
Install Flash
" />

<
reference
package
="
KEN0008F
"
program
="
Install Shockwave
" />

<
reference
package
="
KEN00087
"
program
="
MP 2011 Build 2705 Production
" />

<
reference
package
="
KEN00085
"
program
="
NAC 32bit Install
" />

<
reference
package
="
KEN00088
"
program
="
Agent Installation
" />

<
reference
package
="
KEN00089
"
program
="
Anti Virus Installation
" />

<
reference
package
="
KEN0002C
"
program
="
MS Visual C++ 2008
" />

<
reference
package
="
KEN00012
"
program
="
Client Side
" />

<
reference
package
="
KEN00014
"
program
="
Thick Client
" />

<
reference
package
="
KEN0002A
"
program
="
On Base Virtual Printer
" />

</
referenceList
>

<
globalVarList
>

 

<
variable name
="
OSDEnableTCPIPFiltering
"
property
="
EnableTCPIPFiltering
">
false
</
variable
>

<
variable name
="
OSDAdapterCount
"
property
="
NumAdapters
">
0
</
variable
>

</
globalVarList
>

<
group name
="
Install Operating System
"
description
="
Actions to run in Windows PE to install and configure the image
">

 

<
step type
="
SMS_TaskSequence_RebootAction
"
name
="
Restart in Windows PE
"
description
=""
runIn
="
WinPEandFullOS
"
successCodeList
="
0
">

 

<
condition
>

 

<
expression type
="
SMS_TaskSequence_VariableConditionExpression
">

 

<
variable name
="
Operator
">
equals
</
variable
>

<
variable name
="
Value
">
false
</
variable
>

<
variable name
="
Variable
">
_SMSTSInWinPE
</
variable
>

</
expression
>

</
condition
>

<
action
>
smsboot.exe /target:WinPE
</
action
>

<
defaultVarList
>

 

<
variable name
="
SMSRebootMessage
"
property
="
Message
">
A new Microsoft Windows operating system is being installed. The computer must reboot to continue.
</
variable
>

<
variable name
="
SMSRebootTimeout
"
property
="
MessageTimeout
">
10
</
variable
>

<
variable name
="
SMSRebootTarget
"
property
="
Target
"
hidden
="
true
">
WinPE
</
variable
>

</
defaultVarList
>

</
step
>

<
step type
="
SMS_TaskSequence_PartitionDiskAction
"
name
="
Partition Disk 0
"
description
="
Actions to partition and format the new machine
"
runIn
="
WinPE
"
successCodeList
="
0
">

 

<
condition
>

 

<
expression type
="
SMS_TaskSequence_VariableConditionExpression
">

 

<
variable name
="
Operator
">
notExists
</
variable
>

<
variable name
="
Variable
">
_SMSTSClientCache
</
variable
>

</
expression
>

</
condition
>

<
action
>
osddiskpart.exe
</
action
>

<
defaultVarList
>

 

<
variable name
="
OSDDiskIndex
"
property
="
DiskIndex
">
0
</
variable
>

<
variable name
="
OSDDiskType
"
property
="
DiskType
">
Basic
</
variable
>

<
variable name
="
OSDDiskpartBiosCompatibilityMode
"
property
="
DiskpartBiosCompatibilityMode
">
false
</
variable
>

<
variable name
="
OSDGPTBootDisk
"
property
="
GPTBootDisk
">
false
</
variable
>

<
variable name
="
OSDPartitionStyle
"
property
="
PartitionStyle
">
MBR
</
variable
>

<
variable name
="
OSDPartitions
"
property
="
Partitions
"
hidden
="
true
">
1
</
variable
>

<
variable name
="
OSDPartitions0Bootable
"
property
="
Partitions0Bootable
">
true
</
variable
>

<
variable name
="
OSDPartitions0FileSystem
"
property
="
Partitions0FileSystem
">
NTFS
</
variable
>

<
variable name
="
OSDPartitions0QuickFormat
"
property
="
Partitions0QuickFormat
">
true
</
variable
>

<
variable name
="
OSDPartitions0Size
"
property
="
Partitions0Size
">
100
</
variable
>

<
variable name
="
OSDPartitions0SizeUnits
"
property
="
Partitions0SizeUnits
">
PERCENT
</
variable
>

<
variable name
="
OSDPartitions0Type
"
property
="
Partitions0Type
">
PRIMARY
</
variable
>

<
variable
name
="
OSDPartitions0VolumeLetterVariable
"
property
="
Partitions0VolumeLetterVariable
" />

<
variable name
="
OSDPartitions0VolumeName
"
property
="
Partitions0VolumeName
">
Default
</
variable
>

</
defaultVarList
>

</
step
>

<
step type
="
SMS_TaskSequence_ApplyOperatingSystemAction
"
name
="
Apply Operating System
"
description
="
Actions to apply operating system
"
runIn
="
WinPE
"
successCodeList
="
0
">

 

<
action
>
OSDApplyOS.exe /image:KEN000B5,%OSDImageIndex%
</
action
>

<
defaultVarList
>

 

<
variable name
="
OSDImageIndex
"
property
="
ImageIndex
">
1
</
variable
>

<
variable name
="
ImagePackageID
"
property
="
ImagePackageID
"
hidden
="
true
">
KEN000B5
</
variable
>

</
defaultVarList
>

</
step
>

<
step type
="
SMS_TaskSequence_ApplyWindowsSettingsAction
"
name
="
Apply Windows Settings
"
description
="
Actions to apply windows settings
"
runIn
="
WinPE
"
successCodeList
="
0
">

 

<
action
>
osdwinsettings.exe /config
</
action
>

<
defaultVarList
>

 

<
variable
name
="
OSDLocalAdminPassword
"
property
="
AdminPassword
" />

<
variable name
="
OSDComputerName
"
property
="
ComputerName
">
%_SMSTSMachineName%
</
variable
>

<
variable
name
="
OSDProductKey
"
property
="
ProductKey
" />

<
variable name
="
OSDRandomAdminPassword
"
property
="
RandomAdminPassword
">
false
</
variable
>

<
variable name
="
OSDRegisteredOrgName
"
property
="
RegisteredOrgName
">
3DOVETREE21
</
variable
>

<
variable name
="
OSDRegisteredUserName
"
property
="
RegisteredUserName
">
rlitzenberger
</
variable
>

<
variable name
="
OSDServerLicenseConnectionLimit
"
property
="
ServerLicenseConnectionLimit
">
5
</
variable
>

<
variable name
="
OSDServerLicenseMode
"
property
="
ServerLicenseMode
">
PerSeat
</
variable
>

<
variable name
="
OSDTimeZone
"
property
="
TimeZone
">
SA Western Standard Time
</
variable
>

</
defaultVarList
>

</
step
>

<
step type
="
SMS_TaskSequence_AutoApplyAction
"
name
="
Auto Apply Drivers
"
description
=""
continueOnError
="
true
"
runIn
="
WinPE
"
successCodeList
="
0
">

 

<
action
>
osddriverclient.exe /auto /bestmatch:%OSDAutoApplyDriverBestMatch% /unsigned:%OSDAllowUnsignedDriver%
</
action
>

<
defaultVarList
>

 

<
variable name
="
OSDAutoApplyDriverBestMatch
"
property
="
BestMatch
">
true
</
variable
>

<
variable name
="
OSDAllowUnsignedDriver
"
property
="
UnsignedDriver
">
true
</
variable
>

</
defaultVarList
>

</
step
>

<
step type
="
SMS_TaskSequence_InstallSoftwareAction
"
name
="
Install Network Driver
"
description
=""
continueOnError
="
true
"
runIn
="
FullOS
"
successCodeList
="
0
">

 

<
action
>
smsswd.exe /pkg:KEN000BA /install /basevar: /continueOnError:
</
action
>

<
defaultVarList
>

 

<
variable name
="
PackageID
"
property
="
PackageID
"
hidden
="
true
">
KEN000BA
</
variable
>

<
variable name
="
_SMSSWDProgramName
"
property
="
ProgramName
">
Network Drivers XP
</
variable
>

</
defaultVarList
>

</
step
>

<
step type
="
SMS_TaskSequence_RebootAction
"
name
="
Restart Computer
"
description
=""
runIn
="
WinPEandFullOS
"
successCodeList
="
0
">

 

<
action
>
smsboot.exe /target:WinPE
</
action
>

<
defaultVarList
>

 

<
variable name
="
SMSRebootMessage
"
property
="
Message
">
A new Microsoft Windows operating system is being installed. The computer must restart to continue.
</
variable
>

<
variable name
="
SMSRebootTimeout
"
property
="
MessageTimeout
">
15
</
variable
>

<
variable name
="
SMSRebootTarget
"
property
="
Target
"
hidden
="
true
">
WinPE
</
variable
>

</
defaultVarList
>

</
step
>

<
step type
="
SMS_TaskSequence_ApplyNetworkSettingsAction
"
name
="
Apply Network Settings
"
description
="
Actions to configure network settings
"
runIn
="
WinPEandFullOS
"
successCodeList
="
0
">

 

<
action
>
osdnetsettings.exe configure
</
action
>

<
defaultVarList
>

 

<
variable name
="
OSDDomainName
"
property
="
DomainName
">
pr.mmmhc.com
</
variable
>

<
variable name
="
OSDDomainOUName
"
property
="
DomainOUName
">
LDAP://OU=Domain Computers,DC=pr,DC=mmmhc,DC=com
</
variable
>

<
variable
name
="
OSDJoinPassword
"
property
="
DomainPassword
" />

<
variable name
="
OSDJoinAccount
"
property
="
DomainUsername
">
mmmhc\sccmsa
</
variable
>

<
variable name
="
OSDEnableTCPIPFiltering
"
property
="
EnableTCPIPFiltering
"
hidden
="
true
">
false
</
variable
>

<
variable name
="
OSDNetworkJoinType
"
property
="
NetworkJoinType
">
0
</
variable
>

<
variable name
="
OSDAdapterCount
"
property
="
NumAdapters
"
hidden
="
true
">
0
</
variable
>

</
defaultVarList
>

</
step
>

</
group
>

<
group name
="
Setup Operating System
"
description
="
Setup Operating System
">

 

<
step type
="
SMS_TaskSequence_SetupWindowsAndSMSAction
"
name
="
Setup windows and ConfigMgr
"
description
="
Actions to setup windows and ConfigMgr client
"
runIn
="
WinPEandFullOS
"
successCodeList
="
0
">

 

<
action
>
OSDSetupWindows.exe
</
action
>

<
defaultVarList
>

 

<
variable name
="
SMSClientInstallProperties
"
property
="
ClientInstallProperties
">
SMSSLP=3dovetree21 FSP=3dovetree21
</
variable
>

<
variable name
="
_SMSClientPackageID
"
property
="
ClientPackageID
">
KEN00036
</
variable
>

</
defaultVarList
>

</
step
>

<
step type
="
SMS_TaskSequence_InstallUpdateAction
"
name
="
Install Updates
"
description
=""
continueOnError
="
true
"
runIn
="
FullOS
"
successCodeList
="
0
">

 

<
condition
>

 

<
expression type
="
SMS_TaskSequence_VariableConditionExpression
">

 

<
variable name
="
Operator
">
notEquals
</
variable
>

<
variable name
="
Value
">
FullMedia
</
variable
>

<
variable name
="
Variable
">
_SMSTSMediaType
</
variable
>

</
expression
>

</
condition
>

<
action
>
TSInstallSWUpdate.exe /target:%SMSInstallUpdateTarget%
</
action
>

<
defaultVarList
>

 

<
variable name
="
SMSInstallUpdateTarget
"
property
="
Target
">
All
</
variable
>

</
defaultVarList
>

</
step
>

</
group
>

<
group name
="
Install Applications
"
description
="">

 

<
step type
="
SMS_TaskSequence_InstallSoftwareAction
"
name
="
Install Spharos Client
"
description
=""
continueOnError
="
true
"
runIn
="
FullOS
"
successCodeList
="
0
">

 

<
action
>
smsswd.exe /pkg:KEN0008B /install /basevar: /continueOnError:
</
action
>

<
defaultVarList
>

 

<
variable name
="
PackageID
"
property
="
PackageID
"
hidden
="
true
">
KEN0008B
</
variable
>

<
variable name
="
_SMSSWDProgramName
"
property
="
ProgramName
">
Client Install
</
variable
>

</
defaultVarList
>

</
step
>

<
step type
="
SMS_TaskSequence_InstallSoftwareAction
"
name
="
Install Oracle Client
"
description
=""
continueOnError
="
true
"
runIn
="
FullOS
"
successCodeList
="
0
">

 

<
action
>
smsswd.exe /pkg:KEN00098 /install /basevar: /continueOnError:
</
action
>

<
defaultVarList
>

 

<
variable name
="
PackageID
"
property
="
PackageID
"
hidden
="
true
">
KEN00098
</
variable
>

<
variable name
="
_SMSSWDProgramName
"
property
="
ProgramName
">
Install Client
</
variable
>

</
defaultVarList
>

</
step
>

<
step type
="
SMS_TaskSequence_InstallSoftwareAction
"
name
="
Install Java RE
"
description
=""
continueOnError
="
true
"
runIn
="
FullOS
"
successCodeList
="
0
">

 

<
action
>
smsswd.exe /pkg:KEN0008C /install /basevar: /continueOnError:
</
action
>

<
defaultVarList
>

 

<
variable name
="
PackageID
"
property
="
PackageID
"
hidden
="
true
">
KEN0008C
</
variable
>

<
variable name
="
_SMSSWDProgramName
"
property
="
ProgramName
">
Install x86
</
variable
>

</
defaultVarList
>

</
step
>

<
step type
="
SMS_TaskSequence_InstallSoftwareAction
"
name
="
Install Adobe Flash Player
"
description
=""
continueOnError
="
true
"
runIn
="
FullOS
"
successCodeList
="
0
">

 

<
action
>
smsswd.exe /pkg:KEN0008E /install /basevar: /continueOnError:
</
action
>

<
defaultVarList
>

 

<
variable name
="
PackageID
"
property
="
PackageID
"
hidden
="
true
">
KEN0008E
</
variable
>

<
variable name
="
_SMSSWDProgramName
"
property
="
ProgramName
">
Install Flash
</
variable
>

</
defaultVarList
>

</
step
>

<
step type
="
SMS_TaskSequence_InstallSoftwareAction
"
name
="
Install Adobe Shockwave
"
description
=""
continueOnError
="
true
"
runIn
="
FullOS
"
successCodeList
="
0
">

 

<
action
>
smsswd.exe /pkg:KEN0008F /install /basevar: /continueOnError:
</
action
>

<
defaultVarList
>

 

<
variable name
="
PackageID
"
property
="
PackageID
"
hidden
="
true
">
KEN0008F
</
variable
>

<
variable name
="
_SMSSWDProgramName
"
property
="
ProgramName
">
Install Shockwave
</
variable
>

</
defaultVarList
>

</
step
>

<
step type
="
SMS_TaskSequence_InstallSoftwareAction
"
name
="
Install Market Prominence
"
description
=""
continueOnError
="
true
"
runIn
="
FullOS
"
successCodeList
="
0
">

 

<
action
>
smsswd.exe /pkg:KEN00087 /install /basevar: /continueOnError:
</
action
>

<
defaultVarList
>

 

<
variable name
="
PackageID
"
property
="
PackageID
"
hidden
="
true
">
KEN00087
</
variable
>

<
variable name
="
_SMSSWDProgramName
"
property
="
ProgramName
">
MP 2011 Build 2705 Production
</
variable
>

</
defaultVarList
>

</
step
>

<
step type
="
SMS_TaskSequence_InstallSoftwareAction
"
name
="
Install Symantec NAC Agent
"
description
=""
continueOnError
="
true
"
runIn
="
FullOS
"
successCodeList
="
0
">

 

<
action
>
smsswd.exe /pkg:KEN00085 /install /basevar: /continueOnError:
</
action
>

<
defaultVarList
>

 

<
variable name
="
PackageID
"
property
="
PackageID
"
hidden
="
true
">
KEN00085
</
variable
>

<
variable name
="
_SMSSWDProgramName
"
property
="
ProgramName
">
NAC 32bit Install
</
variable
>

</
defaultVarList
>

</
step
>

<
step type
="
SMS_TaskSequence_InstallSoftwareAction
"
name
="
Install McAfee Agent
"
description
=""
continueOnError
="
true
"
runIn
="
FullOS
"
successCodeList
="
0
">

 

<
action
>
smsswd.exe /pkg:KEN00088 /install /basevar: /continueOnError:
</
action
>

<
defaultVarList
>

 

<
variable name
="
PackageID
"
property
="
PackageID
"
hidden
="
true
">
KEN00088
</
variable
>

<
variable name
="
_SMSSWDProgramName
"
property
="
ProgramName
">
Agent Installation
</
variable
>

</
defaultVarList
>

</
step
>

<
step type
="
SMS_TaskSequence_InstallSoftwareAction
"
name
="
Install MCAfee AV
"
description
=""
continueOnError
="
true
"
runIn
="
FullOS
"
successCodeList
="
0
">

 

<
action
>
smsswd.exe /pkg:KEN00089 /install /basevar: /continueOnError:
</
action
>

<
defaultVarList
>

 

<
variable name
="
PackageID
"
property
="
PackageID
"
hidden
="
true
">
KEN00089
</
variable
>

<
variable name
="
_SMSSWDProgramName
"
property
="
ProgramName
">
Anti Virus Installation
</
variable
>

</
defaultVarList
>

</
step
>

<
step type
="
SMS_TaskSequence_InstallSoftwareAction
"
name
="
Install MS Visual C++ 2008 RED
"
description
=""
continueOnError
="
true
"
runIn
="
FullOS
"
successCodeList
="
0
">

 

<
action
>
smsswd.exe /pkg:KEN0002C /install /basevar: /continueOnError:
</
action
>

<
defaultVarList
>

 

<
variable name
="
PackageID
"
property
="
PackageID
"
hidden
="
true
">
KEN0002C
</
variable
>

<
variable name
="
_SMSSWDProgramName
"
property
="
ProgramName
">
MS Visual C++ 2008
</
variable
>

</
defaultVarList
>

</
step
>

<
step type
="
SMS_TaskSequence_InstallSoftwareAction
"
name
="
Install Hyland Client Side
"
description
=""
continueOnError
="
true
"
runIn
="
FullOS
"
successCodeList
="
0
">

 

<
action
>
smsswd.exe /pkg:KEN00012 /install /basevar: /continueOnError:
</
action
>

<
defaultVarList
>

 

<
variable name
="
PackageID
"
property
="
PackageID
"
hidden
="
true
">
KEN00012
</
variable
>

<
variable name
="
_SMSSWDProgramName
"
property
="
ProgramName
">
Client Side
</
variable
>

</
defaultVarList
>

</
step
>

<
step type
="
SMS_TaskSequence_InstallSoftwareAction
"
name
="
Install Hyland Thick Client
"
description
=""
continueOnError
="
true
"
runIn
="
FullOS
"
successCodeList
="
0
">

 

<
action
>
smsswd.exe /pkg:KEN00014 /install /basevar: /continueOnError:
</
action
>

<
defaultVarList
>

 

<
variable name
="
PackageID
"
property
="
PackageID
"
hidden
="
true
">
KEN00014
</
variable
>

<
variable name
="
_SMSSWDProgramName
"
property
="
ProgramName
">
Thick Client
</
variable
>

</
defaultVarList
>

</
step
>

<
step type
="
SMS_TaskSequence_RebootAction
"
name
="
Restart Computer
"
description
=""
continueOnError
="
true
"
runIn
="
WinPEandFullOS
"
successCodeList
="
0
">

 

<
action
>
smsboot.exe /target:WinPE
</
action
>

<
defaultVarList
>

 

<
variable name
="
SMSRebootMessage
"
property
="
Message
">
A new Microsoft Windows operating system is being installed. The computer must restart to continue.
</
variable
>

<
variable name
="
SMSRebootTimeout
"
property
="
MessageTimeout
">
60
</
variable
>

<
variable name
="
SMSRebootTarget
"
property
="
Target
"
hidden
="
true
">
WinPE
</
variable
>

</
defaultVarList
>

</
step
>

<
step type
="
SMS_TaskSequence_InstallSoftwareAction
"
name
="
Install Hyland Virtual Printer
"
description
=""
continueOnError
="
true
"
runIn
="
FullOS
"
successCodeList
="
0
">

 

<
action
>
smsswd.exe /pkg:KEN0002A /install /basevar: /continueOnError:
</
action
>

<
defaultVarList
>

 

<
variable name
="
PackageID
"
property
="
PackageID
"
hidden
="
true
">
KEN0002A
</
variable
>

<
variable name
="
_SMSSWDProgramName
"
property
="
ProgramName
">
On Base Virtual Printer
</
variable
>

</
defaultVarList
>

</
step
>

</
group
>

</
sequence
>

</
SequenceData
>

<
SourceDate
>
2011-09-27T13:37:12
</
SourceDate
>

<
SupportedOperatingSystems
/>

<
IconSize
>
0
</
IconSize
>

</
SmsTaskSequencePackage
>

Share this post


Link to post
Share on other sites

SMSTS.log file please, as well as a screenshot of your task sequence.

  • Are you using the network service account to join to the domain? YES
  • Are you asking the TS to join the domain via the task sequence "Apply Network Settings" step? YES
  • Is the image sysprepped and are you integrating a sysprep.inf file in the "Apply Operating System" step? The image is all ready sysprep but I have not integrate a sysprep.inf file!

Share this post


Link to post
Share on other sites

You're going to have to attach your task sequence xml file; it doesn't seem to import when it's all fragmented. And more importantly, do you have the smsts.log? It should be at C:\Windows\System32\CCM\logs\smstslog.

Share this post


Link to post
Share on other sites

I have attached the xml TS in the initial post. The smstslog is not showing, the only files that are on that folder are smscliui.log and PolicyAgentProvider.log (i will attached them just in case).

Share this post


Link to post
Share on other sites

Ok - this definitely looks like a network driver issue. I see you have a step in your task sequence to "Install Network Driver;" what is the purpose of that step? All drivers should be located in the driver pool, and the Apply Device Drivers step should take care of the rest. After the task sequence is finished, do you have network connectivity? Are all drivers installed in device manager?

 

When you say the image is sysprepped, do you mean that sysprep.exe was run from the C:\Sysprep folder without a sysprep.inf file? Or did you perform a build and capture from SCCM? You've got a lot of variables going on here - and I definitely think it's a conflict of interest in perhaps the XP sysprep trying to install drivers conflicting with the SCCM TS.

One XP log file that I used to use to troubleshoot driver installations was "setupapi.log", which is located in C:\Windows I believe. I'm not sure if it'll even be there, however, since you're using the SCCM portion to install the drivers.

 

What I would do is disable a bunch of steps from your task sequence, and narrow down which step is halting it. The smsts.log file will help tremendously in this area, and is by far the best way to troubleshoot a TS.

 

Also, read this thoroughly and see if you're missing anything:

 

http://scug.be/blogs...-sccm-2007.aspx

 

As for the smsts.log, use this list to locate it:

 

• WindowsPE, before HDD format:

x:\windows\temp\smstslog\smsts.log

 

• WindowsPE, after HDD format:

x:\smstslog\smsts.log and copied to c:\_SMSTaskSequence\Logs\Smstslog\smsts.log

 

• Full version windows, before SCCM agent installed:

c:\_SMSTaskSequence\Logs\Smstslog\smsts.log

 

• Full version windows, after SCCM agent installed:

c:\windows\system32\ccm\logs\Smstslog\smsts.log

 

• Full version x64 windows, after SCCM agent installed:

c:\windows\sysWOW64\ccm\logs\Smstslog\smsts.log

 

• After Task Sequence has finished running

c:\windows\system32\ccm\logs\smsts.log

 

• After Task Sequence has finished running(x64)

c:\windows\sysWOW64\ccm\logs\smsts

Share this post


Link to post
Share on other sites

Ok - this definitely looks like a network driver issue. I see you have a step in your task sequence to "Install Network Driver;" what is the purpose of that step? This was to make sure that connected to the LAN.

All drivers should be located in the driver pool, and the Apply Device Drivers step should take care of the rest. After the task sequence is finished, do you have network connectivity? YES

Are all drivers installed in device manager? YES

 

When you say the image is sysprepped, do you mean that sysprep.exe was run from the C:\Sysprep folder without a sysprep.inf file? YES, the image was created on a computer and later run the capture CD. When I do this with Windows 7 it runs smoothly without problems but when I did the same in Windows XP I had to extract the sysprep.exe file from the Windos XP cd and copy it to the C:\Sysprep of the computer that was been capture. I check this and it does not includes the sysprep.inf (how can I create one?)

Or did you perform a build and capture from SCCM? Yes, without the build.

 

You've got a lot of variables going on here - and I definitely think it's a conflict of interest in perhaps the XP sysprep trying to install drivers conflicting with the SCCM TS.

 

One XP log file that I used to use to troubleshoot driver installations was "setupapi.log", which is located in C:\Windows I believe. I'm not sure if it'll even be there, however, since you're using the SCCM portion to install the drivers.

 

What I would do is disable a bunch of steps from your task sequence, and narrow down which step is halting it. The smsts.log file will help tremendously in this area, and is by far the best way to troubleshoot a TS. I will try to do this next.

 

Also, read this thoroughly and see if you're missing anything:

 

http://scug.be/blogs...-sccm-2007.aspx

 

As for the smsts.log, use this list to locate it:

 

• WindowsPE, before HDD format:

x:\windows\temp\smstslog\smsts.log

 

• WindowsPE, after HDD format:

x:\smstslog\smsts.log and copied to c:\_SMSTaskSequence\Logs\Smstslog\smsts.log

 

• Full version windows, before SCCM agent installed:

c:\_SMSTaskSequence\Logs\Smstslog\smsts.log

 

• Full version windows, after SCCM agent installed:

c:\windows\system32\ccm\logs\Smstslog\smsts.log

 

• Full version x64 windows, after SCCM agent installed:

c:\windows\sysWOW64\ccm\logs\Smstslog\smsts.log

 

• After Task Sequence has finished running

c:\windows\system32\ccm\logs\smsts.log

 

• After Task Sequence has finished running(x64)

c:\windows\sysWOW64\ccm\logs\smsts

Share this post


Link to post
Share on other sites

See here:

 

http://support.microsoft.com/kb/302577

 

You need to either sysprep the image properly and then capture only, or you can simply do a build and capture in an SCCM task sequence, which syspreps it for you.

 

If you're having trouble integrating the image into SCCM, then simply get it working with the ImageX tool before you move onto a task sequence.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...