Jump to content

  • 0

Start OSD Task Sequence Automatically


Hi, I'm very new at SCCM and OSD, so please forgive me if this is a really simple question, but I can't find an answer anywhere. I have a stand-alone disk for my OS image deployment (so I'm not connected to the SCCM server at all). It works, but I'm trying to figure out how to get the Task Sequence Wizard to launch automatically. Currently I have to click Next and then Next again to start it. I need it to run without any user intervention. I've browsed Google and this forum, but haven't found anything specific. I have a vague notion that I need to use customsettings.ini and bootstrap.ini, but I don't even know where those files are, much less how I need to modify them to automate the process. Another idea I've come across is task sequence variables, but I don't know anything about those either. Any help would be much appreciated, thanks.

Share this post

Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Well, after lots of searching, I found a solution, though I'm sure it's not the "right" solution. I'll post it here, in case it helps anyone.


I did some more digging and found this post. In it, Kerwin Medina posted:

The ability to run unattended is there in the boot media. However, it is not exposed in any UI. You need to manually "fix" the boot media.

You need to edit the \sms\data\TSMBootStrap.ini file.





The "Unattended" entry determines whether or not the user interaction is required.


This is easier said than done. When SCCM creates stand-alone media, it creates an ISO file. You need 3rd party software to open and edit ISO's. I used UltraISO*. I opened the ISO in UltraISO and browsed to SMS/DATA and copied TSMBootStrap.ini to my desktop. I then deleted the file from the ISO, edited the desktop copy, and copied it back. (For whatever reason, I couldn't simply edit the file from the ISO. The changes wouldn't keep.) I then saved the ISO and burned it to a disk. It worked! I put the disk in the computer and it kicked off the task sequence without any user intervention.


It's an ineligant solution, and I had to buy software, but it worked. If you know how it's supposed to be done, I'd love to hear from you.



*I'm not sure I can recommend UltraISO to anyone. It's great software, but I still haven't received my registration code, several hours after purchasing it. Apparently this is a big problem; their forum is littered with people complaining about not receiving their registration code. I found and used another code someone posted online, which I figured was ok since I had purchased it.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.