Jump to content


Sign in to follow this  
anyweb

Install Roles and Features in Windows Server 2008 64bit Task Sequence doesn't appear

Recommended Posts

if you are deploying Windows Server 2008 X64 using System Center Configuration Manager 2007 SP1 with MDT integration, you may notice that the Install Roles and Features function gets completely ignored in your Task Sequence even though it works fine in Windows Server 2008 x86.

 

The reason is a bug in MDT when adding roles and features to Windows Server 2008 64bit

 

The "Install Roles and Features" action will fail on Windows Server 2008 x64 operating systems when used with Configuration Manager 2007. As a workaround, you can perform the following steps:

 

1. Add the "Install Roles and Features" step to the task sequence. Select the needed roles.

 

2. Add a "Run Command Line" step immediately after the "Install Roles and Features" step. Configure it to run the command: ServerManagerCmd.exe -inputpath %TEMP%\Roles.xml -LogPath %TEMP%\ServerMgr.log. Select the Disable 64-bit File System Redirection option and specify success codes on the Options tab of 0 1003 3010.

 

Here are the changes you need to make to get it to work

 

64bitbug.jpg

 

and Here are the values that you need to place on the options tab

 

64bitbug1.jpg

 

You can get more (external) info about this problem here and here

Share this post


Link to post
Share on other sites


Hi there,

 

Thanks for all the information you have on your site, it has come in handy for some time now. I am looking for some assistance with this bug but I am not sure if it is related.

 

I am attempting to use SCCM 2007 R2 to install Server 2008 R2 STD. When I try: Add > MDT > Install Roles and Features an error appers in a new window;

Exception has been thrown by the target of an invocation.

Details >> Not found , property = OSRoleIndex

 

Information is light on the ground regarding this output and the best so far I have is your site and a troubleshooting PDF which points to;

ZTIORole.wsf

Unable to located the selected set of roles in ServerManager.xml (OSRoleIndex = <index>)

The operating system selected in the “Install Roles and Features” couldn’t be found in the ServerManager.xml file.

ZTIORole.wsf reveals "Purpose: Install the specified operating system roles" which is handy, I think I am tracking correctly so far but I get flaky at this point because my VB skills are basic. Please can you check and let me know; the script seems to look for the OSVersion then apply based upon the query. It checks for 2008R2 which is handy but also where the trail ends as there is no Function to install "Server 2008 R2 Role Installation" like there is for all the other queried OS options, and this is why I see the error?

 

Either way is there any advice you can offer me to rectify this problem as our SCCM Certified guy is on holidays for 3 months.

I am using MicrosoftDeploymentToolkit2012_x64 (build 6.1.2373)

 

Final note, bit of a giggle when I saw this

"

' Find ServerManagerCmd. First check system32, then sysnative (only valid on a 64-bit OS running' in a WOW 32-bit process), and finally hope that it is somewhere in the path.
"

if the person is hoping it works out what hope do I have. lol

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...