Jump to content


Deepak Rawat

Machine not able to pick location for applications in task sequence

Recommended Posts

Hi all,

 

Whenever I try to perform OSD through network, the following steps happen:

  1. Client machines gets an IP and boot image gets downloaded.
  2. Task seqences shows up, and I choose any task sequence.
  3. As soon as I choose a Task Sequence and it tries to confirm the location of applications in Task sequences, it fails to do so. Below is the snapshot of the smsts.log file:

PackageID = 'CNT001AB' InstallSoftware 11/1/2012 7:46:47 PM 1484 (0x05CC)

BaseVar = '', Continueonerror='' InstallSoftware 11/1/2012 7:46:47 PM 1484 (0x05CC)

SwdAction = '0001' InstallSoftware 11/1/2012 7:46:47 PM 1484 (0x05CC)

DownloadOnDemand flag is true. Attempting to download content locally for Package CNT001AB.. InstallSoftware 11/1/2012 7:46:47 PM 1484 (0x05CC)

nPos != String::npos, HRESULT=800700a1 (e:\nts_sms_fre\sms\framework\core\ccmcore\path.cpp,99) InstallSoftware 11/1/2012 7:46:47 PM 1484 (0x05CC)

RecursiveCreatePath(sPath.substr(0, nPos), psa), HRESULT=800700a1 (e:\nts_sms_fre\sms\framework\core\ccmcore\path.cpp,102) InstallSoftware 11/1/2012 7:46:47 PM 1484 (0x05CC)

RecursiveCreatePath(sPath.substr(0, nPos), psa), HRESULT=800700a1 (e:\nts_sms_fre\sms\framework\core\ccmcore\path.cpp,102) InstallSoftware 11/1/2012 7:46:47 PM 1484 (0x05CC)

RecursiveCreatePath( sNormalizedPath, psa ), HRESULT=800700a1 (e:\nts_sms_fre\sms\framework\core\ccmcore\path.cpp,157) InstallSoftware 11/1/2012 7:46:47 PM 1484 (0x05CC)

DownloadContentLocally(pszSource, sSourceDirectory, dwFlags, hUserToken, pszUserName, pszUserPassword), HRESULT=800700a1 (e:\nts_sms_fre\sms\framework\tscore\resolvesource.cpp,3130) InstallSoftware 11/1/2012 7:46:47 PM 1484 (0x05CC)

TS::Utility::ResolveSource(pszPkgID, sPath, 0, hUserToken, sUserName.empty() ? NULL : sUserName.c_str(), sUserName.empty() ? NULL : sUserPassword.c_str()), HRESULT=800700a1 (e:\nts_sms_fre\sms\client\osdeployment\installsoftware\runcommandline.cpp,395) InstallSoftware 11/1/2012 7:46:47 PM 1484 (0x05CC)

Failed to resolve the source for SMS PKGID=CNT001AB, hr=0x800700a1 InstallSoftware 11/1/2012 7:46:47 PM 1484 (0x05CC)

cmd.Execute(pszPkgID, sProgramName, dwCmdLineExitCode), HRESULT=800700a1 (e:\nts_sms_fre\sms\client\osdeployment\installsoftware\main.cpp,385) InstallSoftware 11/1/2012 7:46:47 PM 1484 (0x05CC)

Install Software failed to run command line, hr=0x800700a1 InstallSoftware 11/1/2012 7:46:47 PM 1484 (0x05CC)

Process completed with exit code 2147942561 TSManager 11/1/2012 7:46:47 PM 1400 (0x0578)

 

 

 

 

 

I have feeling that machine is not able to get machine policy , as a result not able to locate the desired package.

 

Please help...Its really urgent.

 

Thanks in advance

Share this post


Link to post
Share on other sites


Package CNT001AB is HTA-Password...yes it is very much available and accesible....

 

 

However, today I realized that the ultimate issue is that OSD process is not able to pick the existence of Hard Disk and thus not able to save _SMSTASKSEQUENCE folder in the largest available partition.....(from where the process executes the "install software" applications)

 

The issue is found in the smsts.log file (as below):

 

 

 

Client machine name: MININT-Q4AUVEM

Client Identity: GUID:a73c09a9-bb5d-40e5-956c-0708bfe2c2de

Advertisement ID: CNT202BB

Package ID: CNT001A7

Sending StatusMessage

Formatted header:

<Msg SchemaVersion="1.1" ReplyCompression="zlib"><ID/><SourceID>4265fc07-e605-4b65-9b70-691fea96fa11</SourceID><SourceHost/><TargetAddress>mp:[http]MP_StatusManager</TargetAddress><ReplyTo>direct:OSD</ReplyTo><Priority>3</Priority><Timeout>3600</Timeout><SentTime>2012-11-01T14:16:47Z</SentTime><Protocol>http</Protocol><Body Type="ByteRange" Offset="0" Length="2136"/><Hooks/><Payload Type="inline"/><TargetHost/><TargetEndpoint>StatusReceiver</TargetEndpoint><ReplyMode>Sync</ReplyMode><CorrelationID/></Msg>

 

CLibSMSMessageWinHttpTransport::Send: URL: "Primary Server Name":80 CCM_POST /ccm_system/request TSManager 11/1/2012 7:46:47 PM 1400 (0x0578)

The request has succeeded. 200 OK

User did not specify local data drive TSManager 11/1/2012 7:46:47 PM 1400 (0x0578)

Volume X:\ is not a fixed hard drive TSManager 11/1/2012 7:46:47 PM 1400 (0x0578)

TSM root drive =

We do not find an available volume to store the local data path

Set a global environment variable _SMSTSNextInstructionPointer=1

Set a TS execution environment variable _SMSTSNextInstructionPointer=1

Set a global environment variable _SMSTSInstructionStackString=0

Set a TS execution environment variable _SMSTSInstructionStackString=0

Save the current environment block TSManager 11/1/2012 7:46:47 PM 1400 (0x0578)

pszPath[0] != L'\0', HRESULT=80070057 (e:\nts_sms_fre\sms\framework\core\ccmcore\path.cpp,58) TSManager 11/1/2012 7:46:47 PM 1400 (0x0578)

Filesystem::Path::Add(sEnvPath, EnvDataFileName, sEnvPath), HRESULT=80070057 (e:\nts_sms_fre\sms\framework\tscore\environmentlib.cpp,639)

Failed to save environment to (80070057)

TS::Environment::SharedEnvironment.saveEnvironment(szPath), HRESULT=80070057 (e:\nts_sms_fre\sms\client\tasksequence\executionengine\executionenv.cxx,842)

Failed to save the current environment block. This is usually caused by a problem with the program. Please check the Microsoft Knowledge Base to determine if this is a known issue or contact Microsoft Support Services for further assistance.

The parameter is incorrect. (Error: 80070057; Source: Windows)

SaveEnvironment(), HRESULT=80070057 (e:\nts_sms_fre\sms\client\tasksequence\executionengine\executionenv.cxx,420)

Failed to persist execution state. Error 0x(80070057)

Failed to save execution state and environment to local hard disk

Start executing an instruciton. Instruction name: Restart in Windows PE. Instruction pointer: 1

Set a global environment variable _SMSTSCurrentActionName=Restart in Windows PE

Set a global environment variable _SMSTSNextInstructionPointer=1

Set a local default variable SMSRebootMessage

Set a local default variable SMSRebootTimeout

 

 

 

 

Please anybody suggest on this !!!!!!!!!!!

Share this post


Link to post
Share on other sites

if you press f8 can you run diskpart on the disc ?

Share this post


Link to post
Share on other sites

if you press f8 can you run diskpart on the disc ?

 

If the problem is on both new and old systems, I'd guess storage driver may also be an issue. Diskpart would be an important check point for reused systems. Are all the same computer models having an issue? Is so, check the Boot.WIM for the correct driver. Also check the dism.log for driver installation.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...