Jump to content


ITHenke

IIS Not responding to HTTP Request: Error 500

Recommended Posts

Got big problem with SCCM 2012 SP1.

SCCM 2012 SP1 and SQL 2012 SP1 CU3 on Windows Server 2012.

Installed all prereqs and got a clean install.

Get these error every 30 minutes and both MP and SMP role are critical in Site Status.

Already checked the SPN records. IIS and SCCM use port 80.

What can be wrong? Only thing I haven't tried is removing MP and SMP and reinstallting IIS...

Also got this up on technet...

: http://social.technet.microsoft.com/Forums/en-US/configmanagergeneral/thread/85a7974a-daa2-412b-9b82-9ae6ba716c6d

____________________________

Errors:

On SMS_STATE_MIGRATION_POINT:

SMP Control Manager detected SMP is not responding to HTTP requests. The http status code and text is 500, Internal Server Error.

Possible cause: Internet Information Services (IIS) isn't configured to listen on the ports over which the site is configured to communicate.
Solution: Verify that the designated Web Site is configured to use the same ports which the site is configured to use.

Possible cause: The designated Web Site is disabled in IIS.
Solution: Verify that the designated Web Site is enabled, and functioning properly.

Possible cause: The MP ISAPI Application Identity does not have the requisite logon privileges.
Solution: Verify that the account that the MP ISAPI is configured to run under has not been denied batch logon rights through group policy.

For more information, refer to Microsoft Knowledge Base.


---------------------------------------------------------------------------------------------------------------------

************************************************************************************

-----------------------------------------------------------------------------------------------------------------------

ERROR on: SMS_MP_CONTROL_MANAGER

MP Control Manager detected management point is not responding to HTTP requests. The HTTP status code and text is 500, Internal Server Error.

Possible cause: Management point encountered an error when connecting to SQL Server.
Solution: Verify that the SQL Server is properly configured to allow Management Point access. Verify that management point computer account or the Management Point Database Connection Account is a member of Management Point Role (msdbrole_MP) in the SQL Server database.

Possible cause: The SQL Server Service Principal Names (SPNs) are not registered correctly in Active Directory
Solution: Ensure SQL Server SPNs are correctly registered. Review Q829868.

Possible cause: Internet Information Services (IIS) isn't configured to listen on the ports over which the site is configured to communicate.
Solution: Verify that the designated Web Site is configured to use the same ports which the site is configured to use.

Possible cause: The designated Web Site is disabled in IIS.
Solution: Verify that the designated Web Site is enabled, and functioning properly.

Possible cause: The MP ISAPI Application Identity does not have the requisite logon privileges.
Solution: Verify that the account that the MP ISAPI is configured to run under has not been denied batch logon rights through group policy.

For more information, refer to Microsoft Knowledge Base article 838891.


Share this post


Link to post
Share on other sites


This is really odd.


IIS applications run as local service.


SMS-services run as local service


We have the exact same setup at another customer with the same rights and it works over there.


What I did in this setup is added the MODIFY rights to Local Service for the folder: "\SMS_CCM\SMS_MP". This is where the Application in IIS tries to work and fails. With Modify it works and we have a green service in SCCM again!


Thing is that in all the other setups the Local Service only has read on the folder and it works over there...



Anyway, kind of happy at the moment and have lots of work to do now to finish before the deadline =)

Share this post


Link to post
Share on other sites

Double check that you have all the IIS-Pre Reqs installed! got the same problem when i left out ASAPI Filters and something else.

  • Thanks 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...