Jump to content


jcvnstdn

Exchange 2013, Delivery has failed to these recipients or groups:

Recommended Posts

I experienced the following error :

 

User (usern@domain.com)

The server has tried to deliver this message, without success, and has stopped trying. Please try sending this message again. If the problem continues, contact your helpdesk.

 

Diagnostic information for administrators:

 

Generating server: dc1.domainPtyLtd.local

 

usern@domain.com

#550 4.4.7 QUEUE.Expired; message expired ##

 

 

Here is the fix.

a little background regarding the mail.

I created a custom rule for users inside our company who uses a different mail account(ie jane@jane.com + jane@company.com)so that their incoming and out going mail get routed via a custom receive connector.

 

This caused me some major headaches because i was receiving the above mentioned error for about a week and no mail came into the system.

 

Here is what i did.

1: I removed the custom rule and recreated with the following setup

2: I only enabled Anonymous users on the permissions.

3: Under scoping added the IP of the external mail profile

4: Inside XCH powershell add following command : Get-ReceiveConnector "External Frontend EX2013" | Add-ADPermission -User "NT AUTHORITY\ANONYMOUS LOGON" -ExtendedRights "Ms-Exch-SMTP-Accept-Any-Recipient"

 

After this my headache was gone. took a week but fixed my issue.

Hope this helps you.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...


×
×
  • Create New...