Jump to content


SCCM 2012 SP1 and PXE -- Issues, Ahoy!

Recommended Posts

Alright, I've been having an insane amount of trouble with SCCM for the last few weeks. I am hoping someone can help me. I have combed these message boards and tried so many fixes, but no go.



SCCM 2012 SP1 Server -

DHCP Server - On 172.x.x.x network


DHCP Options:


67: Tried both smsboot\x86\wdsnbp.com and boot\x86\wdsnbp.com (not sure which to use. Many conflicting posts about them. Also, case sensitive?)


When I used to F12, I would get Boot File Not Found. That was before I added the DHCP Options.


NOW, however, I get:




PXE-M0F - Exiting Intel Boot Agent


Quite instant after it receives the IP.


Now, I have ensured the Files are within both the SMSBoot and Boot folders. Plenty of them. 7 in the SMSBoot and 10 in the boot.


I have tried uninstalling WDS. I haven't manually configured anything WDS. I let SCCM do everything.


When I try PXE-booting with the laptop, NOTHING is added to the SMSPXE log. NOTHING is added to the DISTMGR log.


Everything is added to the C: to avoid any storage-related problems.


After restarting WDS service, there is no red in either logs.


Please, somebody, save me from the demon. My brain is mush.

Share this post

Link to post
Share on other sites

Thanks for the suggestion, Rocket Man. I'm not sure I understand the logic behind this. I'm not at all saying I don't believe what you're suggesting, I'm just trying to understand. The machine trying to PXE boot is able to get an IP address. Therefore, DHCP is definitely working. However, after it pulls an address, it tries to perform a TFTP download and fails. I assume it is pulling the boot image. There are no errors in any logs regarding the failure, however. Would this still be a DHCP server issue where IP helpers/etc. are required?


Thanks again for the response!

Share this post

Link to post
Share on other sites

I do believe IP helpers help clients know where and what the PXE server is..... so maybe not your issuse but it seems like your systems cannot find the boot files!


I take it that you have deployed your TS to the unknown computer collection as available and that you have also specified to deploy boot images from PXE server?

Share this post

Link to post
Share on other sites

Yep, I most definitely did. Alright, so I set up my lab environment again. Then I noticed something about my production server. It doesn't have the SMSBoot folder. I've read forum topics about the folder being empty, but it doesn't appear that my SCCM installation created the folder whatsoever. The Boot folder is there (which is where the DHCP server options point to.) Would you happen to know if it is possible to manually create the SMSBoot folder and copy the files from the Test environment over? I seem to have this issue on a pretty constant basis as I've redone my production server 4 times now.

Share this post

Link to post
Share on other sites

Scratch that. I removed/re-added PXE to my configuration. The folders are all now there. However, I still get the same issues. I will talk to the networking team about possibly setting up an IP Helper for me. Thanks for the tip. I'll try to remember to post back here if it helped or not.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.