Jump to content


AJ82

Established Members
  • Content Count

    13
  • Joined

  • Last visited

  • Days Won

    1

AJ82 last won the day on October 27 2013

AJ82 had the most liked content!

Community Reputation

1 Neutral

About AJ82

  • Rank
    Member

Profile Information

  • Gender
    Male
  • Location
    Boston
  1. AJ82

    vbscript assistance.

    Solved: '// '// This script is provided "AS IS" with no warranties, confers no rights and '// is not supported by the authors or Deployment Artist. '// '//---------------------------------------------------------------------------- '//---------------------------------------------------------------------------- '// Global constant and variable declaration '//---------------------------------------------------------------------------- Option Explicit Dim iRetVal '//---------------------------------------------------------------------------- '// End declarations '//---------------------------------------------------------------------------- '//---------------------------------------------------------------------------- '// Main routine '//---------------------------------------------------------------------------- 'On Error Resume Next iRetVal = ZTIProcess ProcessResults iRetVal On Error Goto 0 '//--------------------------------------------------------------------------- '// '// Function: ZTIProcess() '// '// Input: None '// '// Return: Success - 0 '// Failure - non-zero '// '// Purpose: Perform main ZTI processing '// '//--------------------------------------------------------------------------- Function ZTIProcess() Dim sFile Dim sCmd Dim sApp Dim sSCOMManagementGroup sSCOMManagementGroup = oEnvironment.item("OrgName") sApp = "System Center 2012 R2 Operations Manager" oLogging.ReportProgress "Installing " & sApp & "", 20 sFile = oUtility.ScriptDir & "\Source\setup.exe" If not oFSO.FileExists(sFile) then oLogging.CreateEntry "Install " & sApp & ": " & sFile & " was not found, unable to install " & sApp & "", LogTypeError ZTIProcess = Failure Exit Function End if oLogging.CreateEntry "Installing " & sApp & ": Server", LogTypeInfo oLogging.CreateEntry "The Setup log file for " & sApp & " is OpsMgrSetupWizard.log", LogTypeInfo sCmd = """" & oUtility.ScriptDir & "\Source\setup.exe"" /silent /install /components:OMServer /ManagementGroupName:" & sSCOMManagementGroup & " /SqlServerInstance:SQLSERVER01\INSTANCE /DatabaseName:OperationsManager /DWSqlServerInstance:SQLSERVER02\INSTANCE /DWDatabaseName:OperationsManagerDW /UseLocalSystemDASAccount /DatareaderUser:Domain\SCOM_DA /DatareaderPassword:********** /DataWriterUser:Domain\SCOM_DA /DataWriterPassword:******* /EnableErrorReporting:Never /SendCEIPReports:0 /UseMicrosoftUpdate:0 /AcceptEndUserLicenseAgreement:1 /ActionAccountUser:Domain\SCOM_AA /ActionAccountPassword:*******" wscript.echo sCmd iRetVal = oUtility.RunWithHeartbeat(sCmd) if iRetVal <> 0 then oLogging.CreateEntry "Install " & sApp & ": Error installing " & sApp & ", Server was not installed.", LogTypeWarning End If oLogging.CreateEntry "Installing " & sApp & ": Console", LogTypeInfo sCmd = """" & oUtility.ScriptDir & "\Source\setup.exe"" /silent /install /components:OMConsole /EnableErrorReporting:Never /SendCEIPReports:0 /UseMicrosoftUpdate:0" wscript.echo sCmd iRetVal = oUtility.RunWithHeartbeat(sCmd) if iRetVal <> 0 then oLogging.CreateEntry "Install " & sApp & ": Error installing " & sApp & ", Console was not installed.", LogTypeWarning End If '//---------------------------------------------------------------------------- '// oLogging.CreateEntry "Installing " & sApp & ": Reporting", LogTypeInfo '// '// sCmd = """" & oUtility.ScriptDir & "\Source\setup.exe"" /silent /install /components:OMReporting /SRSInstance:SQLSERVER01 /DataReaderUser:" & sSCOMDASAccount & " /DataReaderPassword:" & sSCOMDASAccountPW & " /SendODRReports:0 /UseMicrosoftUpdate:0" '// wscript.echo sCmd '// iRetVal = oUtility.RunWithHeartbeat(sCmd) '// '// if iRetVal <> 0 then '// oLogging.CreateEntry "Install " & sApp & ": Error installing " & sApp & ", Reporting was not installed.", LogTypeWarning '// End If '//---------------------------------------------------------------------------- End Function </script> </job>
  2. Hi All, I am trying to build an enviornemnt an dusing Hyrdation scripts from deploymentresearch.com ( thanks to Johan Arwidmark and team). The below mentioned script works fine with local SQL server deployment but i want it to work with my remote SQL server instance. Can any please advice as to what all changes I have to do to make this script work. Appreciate your help in advance.
  3. How can I deploy Windows 7 X64 to the Microsoft Surface Pro using Configuration Manager 2007 R3 or 2012 SP1? I have both USB 3.0 and 2.0 Standlone media created on both of them (using SCCM 2007). With both FAT32 and NTFS, but the PRO wont boot into the device at all. I have tried both - vloume button and Advance recovery options as well. Device is detected but booting wont happen. Any information is appreciated. But my case is strictly WIN 7x64. PXE is not an option as if now. The same keys workm on other device with UEFI BIOS (Legacy and Both mode on)
  4. Well, I made a mistake in my package for multi LP ...... (this is what happens when you try to be a - Ninja). I remained my CAB files like LP01.cab, LP02.cab etc... Once I removed the 01,02.... and placed them in the right folder (es-es, fr-fr....) all went smooth. Appreciate all you help.
  5. Hi All, I am able to deploy win7 successfully using OSDTaskSequence. But now I have requirement to add language pack-4 in total to the OSD TS. The problem I am facing is that if the sequence of LP in the TS is as mentioned below: First ---Spanish Second ---French Third ---Russian only English and Spanish get installed and rest of the languages are skipped. If I change the sequence to anyother language at "First" only that language and English gets installed. All my packages work fine as I have tested them one at a time in the TS using "Offline LP install" Can some one guide to as to how I can create a single LP for all LP or how to solve this issue of only two LP getting installed during OSD. I have tried but no fun. I have also used DISM online addpackage, throws error, lpksetup works but will again install only one LP with English. Regards, AJ
  6. Hi All, I have a perfectly working TS for deploying OSD on physical machines. What I am trying to achieve is to use the same TS and branch out if the condition is true: IsVM equal to TRUE or a WMI query: http://social.technet.microsoft.com/Forums/systemcenter/en-US/d10c3e05-c211-45a6-859e-8c1ca2936430/vmware-tools-how-to-detect-a-virtual-machine I have tried both the options but they do not work, please let me know if I am making a mistake. Using: SCCM 2007 R3 Windows 7 deployment on a VMware platform. Virtual machine will be created using HW template using vCenter (which I don not care about).
  7. OK, this is what we are trying to achieve. When the users login they should be able to use the virtual applications (that we have advertised to Stream from the DP), generally this takes time, in our case default is 60mins, but for a specific users group we want to make sure that when they login SCCM client should retrieve the policies ASAP, so App-v agent can pull the streamed applications and launch the same for them (as per requirement). We have managed to reduce the time from "Modify Collections Setting" option to 1:21Mins, but now we are looking for "at logon". I am trying to follow these scripts but cant make them work: http://heineborn.com/tech/actions-in-configuration-manager-client/ http://myitforum.com/myitforumwp/2011/07/08/powershell-script-to-refresh-sccm-client-machine-policy/ Any simple idea would really make my life easy. I hope I am making sense. Really appreciate your help.
  8. Yes I did, but again the min time is 5 mins as default/least -I guess, policy retrival time. I want this to be ASAP or may be as soon as user logs in. SCCM 2007 R3 App-v 4.6 SP1 client Virtual Apps delivered from Local DP, with ASAP option, Streamed.
×
×
  • Create New...