Jump to content


Sign in to follow this  
Adam Bise

Application content will not update

Recommended Posts

I have an application with a script installer deployment type. I had modified this script but I cannot update the content. When I try to install the application it fails, and when I dig through the ccmcache folder I see that the script files have not been updated, which is why it is failing.

At first I simply updated the files in the source folder. When that didn't work I tried clicking redistribute content in the app properties "content location" tab, I also deleted the cache from my test machine, ran the machine policy and app eval cycle for good measure. Still getting the old content.

So I right clicked the deployment type, chose update content, created a new revision, redistributed again, cleared client cache, and ran the client cycles. Still getting the old content.

Then I went to application properties, content location, selected the distribution point, and removed it. I checked content status and it was grey (0 targeted). I went to application revisions and removed all previous revisions. Double-checked source files and path, distributed application to the DP again, cleared client cache, ran client cycles, and I'm STILL getting the old content.

 

Then I deleted the whole deployment. Only when I did this I was stuck because the application was stuck in software center with status failed, even after deleting the deployment and running the machine and app cycles. When I tried to re-deploy it would say the software I selected is no longer available, press F5, which didn't remove the failed application from the list in software center.

 

Finally I had to delete the application entirely and wait for the failed application to remove itself from software center, because there was no apparent way to get rid of it besides waiting. I ran all of the client cycles and rebooted etc.

 

Why would modifications to my applications source files not be reflected by the DP, even after removing from the DP entirely? BranchCache is not enabled so that isn't it. The client cache was cleared so it had to re-download from the DP.

 

Any assistance appreciated.

Share this post


Link to post
Share on other sites


I haven't played much with applications in SCCM 2012 yet, but when I updated the content of a package in SCCM 2007, I would *change* the path to the source files (then let it sit for about 30-60 minutes), and then change the path back to the correct source files location. Then, I would update all distribution points, and they would get the new content. The changing of source file path seemed to trigger SCCM to realize there was new/updated content.

 

Not sure if this is the case with SCCM 2012, but it's worth a shot.

Share this post


Link to post
Share on other sites

What do you guys do when you need to update an Application?

 

I would rather use applications over packages for detection.

 

I don't like the message I get when I click update content on a deployment type. It says "clients may be updated" Assuming everything is working, when exactly do clients get updated? I don't want to run into a situation where all of my clients are uninstalling and reinstalling huge programs just because I needed to modify an installer script. On my larger applications the source is just a folder with the scripts, and the real content is ran over the network.

Share this post


Link to post
Share on other sites

I'll preface this again by saying that I'm pretty new to applications in SCCM 2012, but before I updated any source files/scripts, I would make sure that the deployment is not currently active. You don't want to actively be deploying an application while the source files are in flux.

 

After updating the source files and successfully redistributing the content to the distribution points, you can then actively target the collection that (still) needs to get the application. Within the application, you can set the "re-run" behaviors (only re-run if failed previous, always re-run, etc.)

 

Alternatively, you could build a brand new application, and then use the new application supersedence option tab:

 

http://social.technet.microsoft.com/Forums/en-US/1abcc581-1ee8-4929-8a2f-71c8843a257c/application-supersedence-not-working-as-i-want-and-expect?forum=configmanagerapps

http://setupconfigmgr.com/application-supersedence-in-configuration-manager/

 

Is this putting you on the right path?

Share this post


Link to post
Share on other sites

Try this:

Change the version of the application (optional)

Delete all revisions of the application except the latest.

Right click the deployment type and update it (will create a new revision and update DPs)

Make sure you run a user or machine policy update on the client depending on what you deployed the application to, otherwise it'll try to install a previous revision with the old source. (Verify software center displays the correct version as changed above)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...