Jump to content


K11PER

Java 8 Update 31 MSI extraction Issue

Recommended Posts

Hello All,

 

I recently downloaded Java 8 Update 25, ran the installer, and browsed to the LocalLow Java folder to copy the MSI and create an SCCM package for deployment. I was able to install this across multiple platforms (Win7 32& 64, Win 8.1) without any issues. Now a new release as of the 20th for Update 31 extracts to the same location (obviously a separate folder labeled for this version) but I am unable to install this MSI.

 

I haven't even made it to SCCM yet, just trying to run this MSI as a local admin fails on all 3 platforms with the following message:

 

There is a problem with this Windows Installer package. A program required for this install to complete could not be run. Contact your support personnel or package vendor.

 

On a side note, I have had this message come up on 9 machines out of a few hundred that failed this way for Update 25. I have been unable to locate what missing requirement or issue is preventing me from installing this on those machines..any help would be greatly appreciated.

 

 

I tried deleting everything, and downloaded a new .exe from Java's website for Update 31 and I am still having the same issue. Maybe its still to new, but I'm sure by now this would be talked about if it was a global problem. Did I miss something here that's changed since the last update?

 

Has anyone tested this and have a working MSI file that they can upload? I'm lost.

 

Thanks,

 

Kevin

 

 

Share this post


Link to post
Share on other sites


For some reason my computer is having a hard time extracting MSI files (they all seem to be corrupt, even with flash), ill have to investigate that later. I was able to use another machine and tested the MSI from it without any issues. Odd, because my adobe and java msi extraction worked on Monday with my laptop.

Share this post


Link to post
Share on other sites

I think I spoke to soon. I was able to use the MSI taken from another machine, however after installing/uninstalling and testing it via a script twice, the same error now comes up on that machine. Tried running the Java cleanup tool with no luck. Has anyone else been experiencing issues with this release?

 

Thanks

Share this post


Link to post
Share on other sites

Just deployed this out to a new lab yesterday via a clean install of OS and java 8.0 update 31 as a package attached without issues. It installed fine and verified fine also on the machines I randomly trialled verification.

 

On another note I have a java updater package that consists of a script that will uninstall all other pre-releases if found and then install the latest version with a restart, this is done via a TS with multiple run command lines, just tested this out this morning on 3 machines that have 3 different versions of java and again it installed fine too removing the legacy versions.

Are you removing older versions 1st before you install the new version?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...