Jump to content


2 Issues With UDI OSD Task Sequence

Recommended Posts

Hey Guys / Niall -

I'm currently using a fairly recent build of SCCM 2012 R2 SP1 CU3 which has MDT 2013 Update 2 installed. The task I'm working on now is creating an OSD Task Sequence which includes a UDI Wizard created using MDT. Currently, I am able to apply the task sequence to a system and have it complete without error - however - there are a couple of things which are not correct that I'm trying to figure out. I figured I'd post each to get opinions from others.

Issue #1 - No Applications Installed (TS or UDI)

Despite being added as a step to the TS or selected in the UDI Wizard, any/all Applications do not install. Packages which are listed in TS right after the Applications install just fine. Below is how I have my "Install Application" steps configured in the TS in order:

  • Install Applications Group (No conditions)
  • x2 Install Application step listing 5 apps. No conditions / not set to continue on error
  • x3 Install Program steps (which work)
  • "Convert list to two digits" step which runs "cscript.exe "%deployroot%\scripts\ZTICoalesce.wsf" /CoalescePattern:Applications /CoalesceTarget:CoalescedApps /CoalesceDigits:2"
  • Install Application step which installs all with base variable name "COALESCEDAPPS"
  • Install Package step which installs all with base variable name "PACKAGES" (don't have any packages configured in UDI - only apps)
  • All apps listed are known to install successfully and log files shows them parsing, but never attempting installation. In fact, an AppEnforce.log file doesn't even exist once the build completes!

Issue #2 - Reserved Partition Assigned Drive Letter Even Though Set Not To Do So

This one isn't as big, but the 350mb System Reserved partition is assigned the drive letter D:. I went back and checked inside of the TS (and know I'm looking at correct step due to how partitions are named) and the partition has the option checked to not assign a drive letter. Below is how that step is configured:

  • Format and Partition Disk (Conditions SMSTSMediaType not equal OEMMedia & SMSTSBootUEFI not equals true)

  • System Reserved: Primary / 350mb fixed size / Make bootable / Do not assign drive letter / NTFS / Quick format
  • Local Disk: Primary / 99% of disk / not bootable / assign drive letter / NTFS / Quick Format / Variable: OSDisk
  • Windows: Recovery / 1% of disk / All options greyed out
  • I'm not dead set on having the volumes configured this way - just basically need the OS to install to C:, have it be the only with a drive letter, and have it take up the most disk space - that's it.
I'm collecting log files from a build this morning right now and can post them after generalizing them.

Any suggestions? Thanks


I generalized, compressed, and have attached all log files from C:\Windows\CCM of build with these issues I ran this morning.


Share this post

Link to post
Share on other sites

Applications - did you deploy all applications do a single collection?! You don't need any members inside of this collection, but you need to deploy all applications to a collection for what I remember.

Share this post

Link to post
Share on other sites

Thanks for the replies, guys...


ZeZe: I double checked the step for "Set Variable for Drive Letter" prior to my partition step and it is set to "false". My fault if i noted otherwise. :) Also, yes - I did deploy all applications to a single collection without members and they are showing up in UDI just fine. The problem isn't just with ones selected during OSD, though - it's Applications also within the task sequence from "Install Application" steps.


Niall: Hey! The log files should be attached to the initial post in Logs.zip. It's basically a copy of everything from C:\Windows\CCM\Logs after being generalized. I would be happy to provide additinoal logs if desired.


One more update - After posting here, I did a bit more research and saw that some had this issue for Applications and they were able to resolve it by setting the option within each of the apps to download and install locally. I tried doing this to a couple of the apps (from UDI selection and hard coded in a TS step) but it still didn't install any Applications. That was yesterday afternoon. This morning, I was using the same VM to test something different and was able to successfully deploy an Application (not one of the ones attempted during OSD) to it - still, though - none of the Applications from the TS or selected during UDI have yet to install.


Very strange. What do you think? Thanks for your help!!!

  • Like 1

Share this post

Link to post
Share on other sites

I read my steps in my UDI environment. I'm not a big expert, maybe Niall can confirm this.


You have steps for refresh and steps just imaging (no USMT). Not sure if you have to add the step where you are installing applications in your UDI. :)

Share this post

Link to post
Share on other sites

Thanks for the reply - I've got to get this working today if at all possible so appreciate the help!


Attached is a screenshot I compiled of my current TS. Due to time constrants, much of it it basically MDT's default client UDI TS. A few notes are also below...



  • Please remember, it's not just that UDI selected applications are not installing but NO applications are installing including ones hard-coded in TS
  • Upon TS completion, all drivers are successfully installed - Testing in a Hyper-V VM
  • COALESCEDAPPS & PACKAGES variable steps are labeled as such
  • The Two steps under the "Install Applications" group are "Install Application" steps which have no conditions - None of these install
  • The two Citrix Registry steps below the two above are "Install Package" steps which are successful upon TS completion
  • The "Install HPP" group is successful
  • The "Convert list to two digits" step executes the below string
  • cscript.exe "%deployroot%\scripts\ZTICoalesce.wsf" /CoalescePattern:Applications /CoalesceTarget:CoalescedApps /CoalesceDigits:2

OSD UDI Task Sequence



PS: Drivers for additional models will be added later if wondering :)


Thanks guys!


Share this post

Link to post
Share on other sites

Hey Guys -


Any suggestions on this? I'm at a loss, but must find a solution. I considered repacking everything as Packages, but not only would that take forever, it would be working backwards!


I re-ran the TS again today on a VM with the same results. Once done, I loaded all logs in CCM\Logs within Support Center so that everything would be slipstreamed. I found one of the apps which is being installed from an "Install Application" step (not a UDI selection) which was "PowerPoint Viewer" which is pretty straightforward.


Attached is this custom log which shows lines from all log files during the installation of this one app. The issues reported are the same that all other applications are experiencing. Below is a list of all errors & warnings within this log.




  • GetLocationSyncEx failed with error 0x80040154 ContentAccess
  • Failed to send Location Request Message
  • CheckLocations failed. Error = 0x87d00607
  • State transition to (Failure), Param(-2016410105) : CTaskConsumer(ScopeId_.../DeploymentType_
  • Failed to get the display name of the CI. Status messages will be based on the CI ID. (x2 times)
  • Conformant Rule:..._Configuration_PolicyDocument not found (x2 times)
  • Failed to create Location Request Message body ContentAccess
  • Unable to get locations, no need to continue with download
  • Error obtaining message hook object 'zlib-compress'. Code 0x80040154
  • No location available : CTaskConsumer(ScopeId_...)
  • Job({4E257A6F-1009-4C11-9BC7-F14566E5C70C}): Handling dependency failure : Task(ScopeId_...)
  • NotifyProgress received: 24 (Application download failed )
  • Execution status received: 24 (Application download failed )
  • App install failed.
  • Install application action failed: 'Office PowerPoint Viewer'. Error Code 0x80004005



  • No ConfigPoints found for rule:System Center Configuration Manager.ScopeId_... (many times)
  • ...No mandatory Enforce tasks. No actions will be performed. (x2 times)
  • CCIInfo::SetError - Setting CI level error to (0x87d00607).
  • Remove failed. Error 0x80041002 : CITask(ScopeId_...)


As you can see, it seems to be that the client cannot download the content for whatever reason. It is distributed and shouldn't even let me start the TS unless it was.


Any ideas? I'm still trying to look some of this up but so far, no luck :( Thanks!

Share this post

Link to post
Share on other sites

There is an issue with "Install applications" that causes the applications to not install. I had the issue as well when I would add a list of applications to install and it wouldn't do them.


To get around this I made packages of all the applications I want in my task sequence and added steps for each one. It was more time consuming to have to do this but it works 100% of the time.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.