Jump to content


MDT (PXE boot) does not work on some models

Recommended Posts

Hope that someone can help me. 

I am running MDT\WDS on windows 2012 server. DHCP server runs on a separate server. My clients are on another VLAN. I use IPhelpers in order to facilitate communication between clients, and WDS, and DHCP servers. It works all fine in case of HP Z420 (legacy bios) and Lenovo T430s, but it does not work on HP Z440 even when I use legacy bios mode, does not work in UEFI mode as well.

The above makes me think that something is going on with Z440 and its bios version, or maybe Intel boot agent version. I do not use any selection profiles, I have all WinPE drivers loaded into my boot image, but as far I understand I do not even reach this stage, as my process fails before downloading anything. The error message I get is that “Boot filename was not received”. Again, I do not make any changes on the server and it works fine for other two models.

Here is the successful capture (HP z420), and towards the bottom there is the unsuccessful capture (HP z440). All packets look the same until almost the end. However, within unsuccessful capture the client sends RELEASE message, like it would release DHCP address, why? And instead downloading a bootfile the whole process starts again. This happens a few times and finally it times out. Again, because it works for other models it makes me think the problem is the client, not the server. I have tried, I believe all, suggestions I was able to find online, but nothing worked.

In both cases WDS tells the client to use: BootFileName: boot\x86\wdsnbp.com


If I use UEFI mode on 440 then WDS never sends ACK message after client’s request. Here of course client identifies himself as x64bit, WDS should send him to boot\x64

Maybe I am missing something in configuration, hope I do!. When I use this on other models which work (p 420 and lenovo laptop), they both identify themselves as x86. However 440 in legacy mode also identifies itself as x86, and I believe this is all expected.


Maybe I have “Multiple PXE servers on same network segment. A client will respond only to the first PXE server offered.https://support.symantec.com/en_US/article.HOWTO8573.html

Scenario number 2?

I appreciate any help!


Similar story - https://supportforums.cisco.com/t5/lan-switching-and-routing/dhcp-pxe/td-p/2627424


Explanation for screenshots:

Blue – switch (relaying client packets), ignore blue font on the screenshot, it does not mean anything

Red – WDS Server

Yellow – client




Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...