Jump to content


Strange issue with Latitude 7490

Recommended Posts

I'm seeing some weird behaviour when building a new Dell Latitude 7490. Boot List Option is set to UEFI and I've tried this with SATA Operation mode in both AHCI and RAID On. I PXE boot the laptop and start my OSD TS which sets some more BIOS settings (disable UEFI Network Stack, disable Legacy Option ROMs and enable Secure Boot). It then formats the disk with GPT partitions (700MB FAT32 Primary with TSUEFIDrive variable and 100% of remaining space NTFS Primary) and reboots.

The laptop goes through POST, displaying the Dell splash screen and then just powers off as if there are no boot options available. If I start the laptop again, it'll keep doing the same thing until I either press F12 and select the HDD (and M.2 SATA SSD) to boot from or simply just enter and exit the BIOS. If I do either of those, WinPE loads and the TS continues as normal.

I've tried various workarounds including setting  "cctk.exe bootorder --bootlisttype=uefi --sequence=hdd --enabledevice=hdd" and different combinations of BIOS settings but I can't get past this problem.

When the laptop was first built, the BIOS was upgraded from 1.1.6 to 1.2.6 as part of the task sequence (I don't remember if I encountered the above problem that first time) but I'm not able to downgrade to any of the previous versions. *EDIT - Forgot to mention that 1.2.6 is no longer available on Dell's website with no mention of why.*

Any ideas? Could this be a bug with the BIOS firmware?

Thanks in advance!

Share this post

Link to post
Share on other sites

Thanks for the response simulacra75! A Spectre/Meltdown issue with the missing version was my thought as well.

So, it turns out that a couple of BIOS settings can cause this issue (on this particular model). Firstly, disabling the "Disable UEFI Network Boot" step allowed the TS to proceed past the first reboot. I then had the same issue after disabling "Thunderbolt Pre-Boot Module" (despite not even having a Thunderbolt device connected) in a later step. I worked around the issue by moving one step to later in the TS, creating an additional one and adding some filtering.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.