Jump to content


soultrain99

Upgrade Windows 7 to Window 10 version 1703

Recommended Posts

I have done windows 7 to windows 10 upgrade version 1607 with no issues.  It does the upgrade in about 1 hour.  Which is great.

With 1703 it takes about 2.5 hours.  It sits on Waiting for service CcmExec to exit pending state 3 for over 1 hour.  I think that CCMEXEC.exe is trying to start but its in a stopping state.  I remoted into the services on the 

I read somewhere that there's a service that was dependant on it and that dependency can be removed by putting this in the beginning of the TS:

sc config "smstsmgr" depend= ""  

Still doesnt work.  Not sure if anyone else ran into this.

Executing C:\WINDOWS\ccmsetup\ccmsetup.exe /remediate:client /OSUpgradeRepair    OSDUpgradeWindows    2/22/2018 5:58:57 PM    4972 (0x136C)
Command line for extension .exe is "%1" %*    OSDUpgradeWindows    2/22/2018 5:58:57 PM    4972 (0x136C)
Set command line: "C:\WINDOWS\ccmsetup\ccmsetup.exe" /remediate:client /OSUpgradeRepair    OSDUpgradeWindows    2/22/2018 5:58:57 PM    4972 (0x136C)
Executing command line: "C:\WINDOWS\ccmsetup\ccmsetup.exe" /remediate:client /OSUpgradeRepair    OSDUpgradeWindows    2/22/2018 5:58:57 PM    4972 (0x136C)
Process completed with exit code 0    OSDUpgradeWindows    2/22/2018 6:21:10 PM    4972 (0x136C)
CcmSetup remediate succeeded.    OSDUpgradeWindows    2/22/2018 6:21:10 PM    4972 (0x136C)
SMS Client remediated    OSDUpgradeWindows    2/22/2018 6:21:10 PM    4972 (0x136C)
Enabling CCMExec service    OSDUpgradeWindows    2/22/2018 6:21:10 PM    4972 (0x136C)
CcmExec service startup type is set to automatic    OSDUpgradeWindows    2/22/2018 6:21:10 PM    4972 (0x136C)
Taking the client out of provisioning mode    OSDUpgradeWindows    2/22/2018 6:21:20 PM    4972 (0x136C)
getPointer()->ExecMethod( BString(pszObject), BString(pszMethod), 0, 0, pInParams, ppOutParams, 0 ), HRESULT=80004005 (..\WmiNamespace.cpp,1391)    OSDUpgradeWindows    2/22/2018 6:26:29 PM    4972 (0x136C)
ns.ExecMethod( c_szWmiClass_SmsClient, c_szSetProvisioningMode, inParams, &outParams ), HRESULT=80004005 (..\ProvisioningMode.cpp,64)    OSDUpgradeWindows    2/22/2018 6:26:29 PM    4972 (0x136C)
Could not execute WMI method SMS_Client.SetClientProvisioningMode    OSDUpgradeWindows    2/22/2018 6:26:29 PM    4972 (0x136C)
Exiting SetClientProvisioningMode 0x80004005    OSDUpgradeWindows    2/22/2018 6:26:29 PM    4972 (0x136C)
Starting CCMExec service    OSDUpgradeWindows    2/22/2018 6:26:29 PM    4972 (0x136C)
Waiting for service CcmExec to exit pending state 3    OSDUpgradeWindows    2/22/2018 6:26:29 PM    4972 (0x136C)
Waiting for service CcmExec to exit pending state 3    OSDUpgradeWindows    2/22/2018 6:26:29 PM    4972 (0x136C)
Waiting for service CcmExec to exit pending state 3    OSDUpgradeWindows    2/22/2018 6:26:30 PM    4972 (0x136C)
Waiting for service CcmExec to exit pending state 3    OSDUpgradeWindows    2/22/2018 6:26:30 PM    4972 (0x136C)
Waiting for service CcmExec to exit pending state 3    OSDUpgradeWindows    2/22/2018 6:26:31 PM    4972 (0x136C)

Share this post


Link to post
Share on other sites


On 2/23/2018 at 11:15 AM, soultrain99 said:
2

So correction.  Putting ConfigMgr Remote Control Users into the local computer seemed to fix the problem.  

 

I added this as command line to my TS:

cmd /c net localgroup "ConfigMgr Remote Control Users" /add

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...