Jump to content


Methods in PowerShell

Recommended Posts

Hello, I had a question on PowerShell Version: 5.1.19041.1023

If you look at the attached screenshot you'll see what I'm curious about.   I run this command in PowerShell ISE:

Get-CimInstance -ClassName win32_computersystem -Property *  | Get-Member -MemberType Method

You see what it displays in the display window.

But when I run WEBMTEST and I choose OPEN CLASS and then Win32_ComputerSystem you'll notice the METHODS don't match what you see in the ISE command.

My question is why?  

Thank you.


Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...