Jump to content


fred19

Using MDT Task Sequence

Recommended Posts

Hello,

 

I have some questions regarding using the Microsoft Deployment Task Sequence in SCCM, we have the following setup in place

 

MDT 2010 with a Database Configure (Roles, Make and Model)

SCCM 2007 SP2 Integrated with MDT

 

When using the Microsoft Deployment task sequence you are prompted to create or use existing packages

 

MDT Package (This creates a distribution point to be use within your task sequence)

Settings Package (CustomSettings.ini, Unattend.xml, and sysprep.inf for Windows XP)

 

We have created a new Windows 7 x86 Image on MDT using the build and capture then created the new OS and TS in MDT, from there we used WSIM to change the copyprofile = true in order to have the same profile for every user (this works fine).

 

Now in SCCM when we created the Settings Package we selected create new, it then created a out of the box Customsettings.ini and unattend.xml, we replaced the unattend.xml with the one we edited in MDT and updated our distribution point. When we created the Microsoft Deployment Task Sequence we also specified to join a domain using an account and also provided the Windows Settings, now when the image get's deployed for some reason the laptop/desktop do not join the domain.

 

If you have specified in your task sequence to join a domain but in your unattend.xml you have nothing i guess the unattend.xml takes precedence? (hence the reason why it is failing)

 

Looking at the logs i noticed the follwoing in the BDD.log

 

The TaskSequenceID is blank, possibly a misconfigured customsettings.ini or task sequence

Merge specified, but C:\_SMSTaskSequence\WDPackage\Control\\Unattend.xml wasn't found, unable to merge

 

The WDPackage refering in this error is our MDT package and indeed we do not have any unattend.xml in that folder, in our Task Sequence under the "Apply Operating System Image" we have a check mark under "Use an unattended or sysprep answer file for a custom installation" and this is using our Settings package (CustomSettings and the unattend.xml), unless i am wrong we do need this to be enable since we want to be able to use our modified unattend.xml (specificly for the copyprofile = true in our case)?

 

Other question, can we replace the customsettings.ini that SCCM generated when we created the package with the existing customsettings.ini that we have on MDT 2010 (We have all the settings configured for the database) and use it in SCCM?

 

If i look under the Task Sequence i see many Gather sequence with the following configured option

 

Initialization (Gather local data and process rules from CustomSettings.ini)

Refresh Only (Gather only local data (do not process rules))

Post Install (Gather only local data (do not process rules))

State Restore (Gather only local data (do not process rules))

 

If we can use the pre-configured CustomSettings.ini from MDT that would save us a lot of time since we have many config in the database, however in which steps from the list above should this be configured?

 

Thanks for your help

Share this post


Link to post
Share on other sites

I'm getting the exact same problem. Does someone has a solution for this issue ?

 

As I'm using MDT Tasksequence and MDT Database, I'm questionning myself if the problem could come from the MDT Database ? Is there a special params to define in customsettings.ini ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...